First of all Hello and thanks for reading my thread. I have a SIEG CNC lathe and it from about 2014 and basically has been sitting for a long time as I cannot get the pendant to work. I did not buy this new and the seller couldn’t explain the issue or remedy as he was a manual machinist and retired and decided CNC was too hard for him. The lathe was supplied with an old Windows Computer running Windows XP. The software for the lathe is Mach 3 Demo version. The pendant never worked for me and I suspect for him either, or certainly not at the end. I converted the lathe to run on my modern laptop with a USB output using a UC100 (genuine) and all functions including programming work. Having the modern computer is much better.

However the pendant, a CNC Vista item didn’t work, it was the base model, I think a PIA with a RJ45 connection which is plugged into the lathe along with a USB connection. As I didn’t know any better I bought a new CNC Vista pendant with RJ45 and that was a PIA-S with the screen. I connected that and still no difference. Can somebody help with the programming of the pendant? I have looked at the various ports regarding turning them on but I suspect it has to do with the numbers being wrong. I don’t have an original program and somebody may have fiddled with mine and mucked it. I also replaced the ee box that was fitted with a new one from CNCVista. So every thing works except the pendant. I bought time with CNCVista to troubleshoot or was that the Mach 3 people? Sorry it was a while ago and that didn’t help at the time.

Is there any tips to get a PIA or PIA-S pendant working?

PS not that I’m running on the laptop with the UC 100 you need to provide the USB input into the lathe or the display screen won’t light up on the PIA-S.

Thanks in advance

Similar Threads: