Hi guys
I have a proturn 360 xyz lathe on a 2002 model and I have a problem with the spindle encoder.

The control system is on a LX3 prototrack and has been running fine until last week.

When I am running in program mode the saddle goes to Z0. Position and then will not run.....if I press the track button it will actually still track through the whole program until the end. I have tried to press go and it won't hardly move at all only .05mm increments and really slow.

I was advised and told that it is the spindle encoder which is at fault and to test this I went into the service page and inputted the spindle code 133 which tests the spindle encoder in both directions of rotational movement and no movement was evident on the X.

So I got a new encoder and did the same again checked in the service page and still no movement.....I have had the plug pins on the cable on both the female and male connections and have all tested ok.

So I have a new encoder but I am still not being able to get it to pick the spindle speed up.....

Have gone to XYZ and they are now saying that it could be the board at fault and to send this with the new encoder back to them for testing....have also had the new encoder retested prior to make sure it is not faulty too.

Tried to find some info online and noticed that someone had mentioned it could be the software needs updating to pick up the new encoder.

Any help guys would be much appreciated...if I have missed anything please tell me lol.

Similar Threads: