Apparent bug in zigzag pocket


Results 1 to 9 of 9

Thread: Apparent bug in zigzag pocket

  1. #1
    Member Asymtek's Avatar
    Join Date
    Sep 2019
    Posts
    5
    Downloads
    1
    Uploads
    1

    Default Apparent bug in zigzag pocket

    I am wondering how to report a bug in the zigzag routine. I am machining a acrylic window for a display and have found the zigzag routine cuts the bottom of some of the LED windows leaving a flat spot on some of them. I'd like to report that issue to the software developer.

    I have a row of leds cut into an aluminum bud box and am cutting an acrylic window for it. Of the eight leds, four of them get clipped on the bottom creating a flat. I hand edited the g-code to get around the issue, but think it would be appropriate to report the problem.

    Can anyone help me get in touch with the developer?

    Similar Threads:


  2. #2
    Member Jim Dawson's Avatar
    Join Date
    Dec 2013
    Posts
    3634
    Downloads
    0
    Uploads
    0

    Default Re: Apparent bug in zigzag pocket

    I guess it would help to know what CAM and machine software you are using.

    Jim Dawson
    Sandy, Oregon, USA


  3. #3
    Member Asymtek's Avatar
    Join Date
    Sep 2019
    Posts
    5
    Downloads
    1
    Uploads
    1

    Default Re: Apparent bug in GrblGru zigzag pocket

    The DXF file was created with Autocad Lt 2000. G-Code created with GrblGru V3.42.0. The router processes the cuts exactly as the G-code commands it to. The error shows up in GrblGru 3D plot tab regardless of the machine selection and examining the G-code confirms the bug. When the zigzag routine is creating the pocket, it appears it does not correctly compensate for the radius of the cutting tool, but only some of the time (50%).

    FYI, my router is a modified Asymtek Automove 201 controller driving an Asymtek 12"x12" machine (don't know the model) driven by a custom, (written by me in National CVI) translator and sender, since the Automove has its own ACL language.

    I have also acquired an Automove 303 XY table which I am currently building up which I will either drive with the 201 controller or perhaps Grbl on a Mega 1260 board or some other driver. I haven't decided as of yet.

    Last edited by Asymtek; 09-08-2019 at 10:06 PM. Reason: Title not specific to CAM software


  4. #4
    Member
    Join Date
    May 2016
    Posts
    122
    Downloads
    4
    Uploads
    0

    Default Re: Apparent bug in zigzag pocket

    This looks like a bug in my program. Thanks for the information.
    Can you please provide me with the DXF file.



  5. #5
    Member Asymtek's Avatar
    Join Date
    Sep 2019
    Posts
    5
    Downloads
    1
    Uploads
    1

    Default Re: Apparent bug in zigzag pocket

    File is called Plexi.dxf in the Downloads:Post Files section. Mill bit is 1.5mm endmill.



  6. #6
    Member maxhowells7's Avatar
    Join Date
    Sep 2019
    Posts
    1
    Downloads
    0
    Uploads
    0

    Default Re: Apparent bug in zigzag pocket

    The bugs on the Zigzag pocket is always available for the router. Once I was using this product and after some time my router shows me Wii Error Code 51330 and it's really a problem for me. Because these bugs really irritate me so much and not even know how to solve this problem. So I suggest to reinstall all the drivers of the router properly then you will solve it out.



  7. #7
    Member
    Join Date
    May 2016
    Posts
    122
    Downloads
    4
    Uploads
    0

    Default Re: Apparent bug in zigzag pocket

    @Asymtek

    I found the bug and (hopefully) fixed it in the new beta version V3.42.6.
    If you process the edges after the 'Pocket' job with a 'Cut' job you get the result on the 2nd picture.

    Thanks again for your help to improve GrblGru.

    Attached Thumbnails Attached Thumbnails Apparent bug in zigzag pocket-pic1-jpg   Apparent bug in zigzag pocket-pic2-jpg  


  8. #8
    Member Asymtek's Avatar
    Join Date
    Sep 2019
    Posts
    5
    Downloads
    1
    Uploads
    1

    Default Re: Apparent bug in zigzag pocket

    Quote Originally Posted by GrblGru View Post
    @Asymtek

    I found the bug and (hopefully) fixed it in the new beta version V3.42.6.
    If you process the edges after the 'Pocket' job with a 'Cut' job you get the result on the 2nd picture.

    Thanks again for your help to improve GrblGru.
    And thank you for the amazing support. I've written a lot of automation software in my career and know just how hard it is to keep up with the bug reports. Thank you for the excellent work.



  9. #9
    Member Asymtek's Avatar
    Join Date
    Sep 2019
    Posts
    5
    Downloads
    1
    Uploads
    1

    Default Re: Apparent bug in zigzag pocket

    maxhowells7, the bug was in the code generation, not the router driver. GrblGru has fixed the problem in the current beta version. I applaud him for the excellent support and dedication.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Apparent bug in zigzag pocket

Apparent bug in zigzag pocket

Apparent bug in zigzag pocket