Huanyang VFD Macro/ Plugin - Page 32

Page 32 of 42 FirstFirst ... 2229303132333435 ... LastLast
Results 373 to 384 of 502

Thread: Huanyang VFD Macro/ Plugin

  1. #373
    Registered
    Join Date
    Nov 2005
    Location
    UK
    Posts
    40
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Hi Dan

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65


    Thats exactly what im getting

    when i scoped the data lines with the pico scope which i can set to decode the rs485 there wasn't any data on the line even though the serial monitor was showing that it was transmitting
    and this was the same for both my computers running different software versions including a fresh install

    when the spindle ran the one time data showed in the serial data logger

    New rs to usbs turned up today so hope to try later and post results


    Thanks for your help so far Dan

    Andrew



  2. #374
    Registered
    Join Date
    Mar 2010
    Location
    America
    Posts
    778
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Quote Originally Posted by andrewbishop66 View Post
    Hi Dan

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65

    [07/11/2017 07:36:15] Written data
    01 01 03 8e 00 00 5c 65


    Thats exactly what im getting

    when i scoped the data lines with the pico scope which i can set to decode the rs485 there wasn't any data on the line even though the serial monitor was showing that it was transmitting
    and this was the same for both my computers running different software versions including a fresh install

    when the spindle ran the one time data showed in the serial data logger

    New rs to usbs turned up today so hope to try later and post results


    Thanks for your help so far Dan

    Andrew
    The serial monitor is showing you what your com port is transmitting... but not getting any further than there. This tells you the com port and plugin are configured/working correctly. The next thing you look for is a reply from VFD, and this is what your not getting. For each "written data" string should be followed by a "Read data" string. The "Read Data" is the VFD transmitting back.

    Dan



  3. #375
    Registered
    Join Date
    Nov 2005
    Location
    UK
    Posts
    40
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Hi Dan

    their won't be any reply from the vfd as although serial data is showing that there is no data package being sent to the vfd live data via the scope of the rs twisted pair shows no data on the line

    dont know how much you know about the picoscope but it will show the raw data on the twisted pair and there is not a thing

    I use it at work on car can networks which is very similar to this application

    just waiting for my grandson who is staying over to go to bed as its considered poor form to let a 2 year old play with mains voltage

    so i can run some tests

    Thanks Andrew



  4. #376
    Registered
    Join Date
    Nov 2005
    Location
    UK
    Posts
    40
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    So quick Kitchen table test and have coms with vfd with new rs485 to usb so that would seem to be problem now just need to set up on the mill

    Thanks Dan for all your help and for taking the time to make the thing in the first place



  5. #377
    Registered
    Join Date
    Mar 2016
    Location
    United States
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    I have been able to get the plugin to work to turn the spindle on, however the slider is not working to adjust the speed. I am using the latest version of UCCNC, Screenset 2017 and the HYPlugin. Fresh copies were downloaded and installed two days ago. I have my max/min RPM set to 8000/24000 for the 2.2kw spindle. Any ideas on what I might be doing wrong?


    Nate



  6. #378
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    31820
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    I just sent you an email.

    I believe that nothing is wrong. UCCNC starts with the spindle speed set to minimum, in your case 8000 rpm. You are trying to use the slider to adjust the speed. The problem is that the slider has a max of 100%, which would be 8000rpm. Since your minimum speed is also 8000, the slider won;t do anything. Try using the MDI to set the speed higher, using S15000 or S20000. Then the slider should work.

    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  7. #379
    Registered
    Join Date
    Mar 2010
    Location
    America
    Posts
    778
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Quote Originally Posted by ger21 View Post
    I just sent you an email.

    I believe that nothing is wrong. UCCNC starts with the spindle speed set to minimum, in your case 8000 rpm. You are trying to use the slider to adjust the speed. The problem is that the slider has a max of 100%, which would be 8000rpm. Since your minimum speed is also 8000, the slider won;t do anything. Try using the MDI to set the speed higher, using S15000 or S20000. Then the slider should work.
    Also, with 2017 screenset you will need to edit your RPM field labelnunber from 870 to 2451 in UCCNC screen edit.

    Dan

    ***Edit****

    ooops...just reread, sounds like the problem and fix is exactly what Gerry already posted.



  8. #380
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    31820
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Also, with 2017 screenset you will need to edit your RPM field labelnunber from 870 to 2451 in UCCNC screen edit.
    Dan, is this info in the instructions? I don't think so.

    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  9. #381
    Registered
    Join Date
    Mar 2010
    Location
    America
    Posts
    778
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Quote Originally Posted by ger21 View Post
    Dan, is this info in the instructions? I don't think so.
    No Ger it's not. Not sure what version I stop including instructions and relied on this thread for info, but this plugin certainly can use a facelift after I reviewed code, and when I find the time I will include. Sorry if causing you and troubles.

    Dan



  10. #382
    Registered
    Join Date
    Feb 2012
    Location
    United States
    Posts
    60
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    First off... thanks for all the work you guys have put into this. I was about to declare victory tonight before I went in "M4" and started going backwards.

    So here's where I'm at.

    Got the VFD and spindle working in manual mode and so everything seems right from the VFD and spindle standpoint.

    I'm using the 2017 screenset and just updated to the latest UCCNC software (1.2047) and 2017 install today. That is working fine.

    Connected the RS485. Changed PD001 and PD002 to 2.

    Installed the HYPLUGIN (12) and checked the enable and call on startup boxes. Restarted UCCNC and configured the plugin per this thread. Restarted UCCNC. Also turned off all other plugins.

    Changed the RPM box to 2451 and missed the right place to save it off. M3 didn't turn on the spindle.

    Went back to the stock UCCNC profile and followed those instructions to configure the HYPLUGIN. After doing that UCCNC started crashing on startup.

    Went back to the 2017 screen and woo hoo.... M3 worked and the spindle turns on and off. Slider didn't work.

    Looked at the RPM block and it was still set to 870. Figured out I was using the wrong save settings. Had I read the tread a little slower... and all the way through.. I would have know this earlier

    Fired it up and RPM block was still at zero. Clicked on the slider bar and the RPM flashed to 6,000 and then UCCNC crashed. Reloaded and crashes every time.

    Turned the VFD off and UCCNC will run but as soon as I plug the VFD in and when it comes on UCCNC crashes.

    Tried the other RS485 adapter (bought 2 since they were cheap and seems that some have had problems with them) and still the same.

    I'm also probably the last person running a windows vista machine.... but it seems to work fine.

    I'm sure I've got something set wrong. Any idea on where to start would certainly be appreciated. It's late and I've learned to walk away and come back another day to prevent magic smoke from forming. Again.... thanks to all the effort that went into this plugin.



  11. #383
    Registered
    Join Date
    Mar 2010
    Location
    America
    Posts
    778
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Quote Originally Posted by lambodesigns View Post
    First off... thanks for all the work you guys have put into this. I was about to declare victory tonight before I went in "M4" and started going backwards.

    So here's where I'm at.

    Got the VFD and spindle working in manual mode and so everything seems right from the VFD and spindle standpoint.

    I'm using the 2017 screenset and just updated to the latest UCCNC software (1.2047) and 2017 install today. That is working fine.

    Connected the RS485. Changed PD001 and PD002 to 2.

    Installed the HYPLUGIN (12) and checked the enable and call on startup boxes. Restarted UCCNC and configured the plugin per this thread. Restarted UCCNC. Also turned off all other plugins.

    Changed the RPM box to 2451 and missed the right place to save it off. M3 didn't turn on the spindle.

    Went back to the stock UCCNC profile and followed those instructions to configure the HYPLUGIN. After doing that UCCNC started crashing on startup.

    Went back to the 2017 screen and woo hoo.... M3 worked and the spindle turns on and off. Slider didn't work.

    Looked at the RPM block and it was still set to 870. Figured out I was using the wrong save settings. Had I read the tread a little slower... and all the way through.. I would have know this earlier

    Fired it up and RPM block was still at zero. Clicked on the slider bar and the RPM flashed to 6,000 and then UCCNC crashed. Reloaded and crashes every time.

    Turned the VFD off and UCCNC will run but as soon as I plug the VFD in and when it comes on UCCNC crashes.

    Tried the other RS485 adapter (bought 2 since they were cheap and seems that some have had problems with them) and still the same.

    I'm also probably the last person running a windows vista machine.... but it seems to work fine.

    I'm sure I've got something set wrong. Any idea on where to start would certainly be appreciated. It's late and I've learned to walk away and come back another day to prevent magic smoke from forming. Again.... thanks to all the effort that went into this plugin.

    When changing field from 870 to 2451 in screen edit after you press apply you need to click on File tab in screen edit and than press save screenset.

    Reason the slider is not working is because you are at minimum RPM setting at startup and the slider is at 100%, HY12 won't set a RPM lower than what you have min RPM set in configure. Just set a higher RPM using MDI and you will be good to go.

    You should be able to adjust slider settings in screen edit, click on slider and set min value to 0 and max value to 200%.


    Dan



  12. #384
    Registered
    Join Date
    Feb 2012
    Location
    United States
    Posts
    60
    Downloads
    0
    Uploads
    0

    Default Re: Huanyang VFD Macro/ Plugin

    Quote Originally Posted by Dan911 View Post
    When changing field from 870 to 2451 in screen edit after you press apply you need to click on File tab in screen edit and than press save screenset.

    Dan
    Did that. Just took me a little bit to get it right.

    Quote Originally Posted by Dan911 View Post
    Reason the slider is not working is because you are at minimum RPM setting at startup and the slider is at 100%, HY12 won't set a RPM lower than what you have min RPM set in configure. Just set a higher RPM using MDI and you will be good to go.


    You should be able to adjust slider settings in screen edit, click on slider and set min value to 0 and max value to 200%.


    Dan
    Right now UCCNC is crashing before I can set a value in the MDI if the VFD is on. It is crashing with or wtihout the 2017 screenset so I'm not sure where I went wrong. I'll trace back through my steps and see what I can find. Thanks for the reply.



Page 32 of 42 FirstFirst ... 2229303132333435 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Huanyang VFD Macro/ Plugin

Huanyang VFD Macro/ Plugin