PathPilot v 2.2.2 is now available showthread.php?t=379654

Results 1 to 5 of 5

Thread: PathPilot v 2.2.2 is now available

  1. #1
    Member kstrauss's Avatar
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    1431
    Downloads
    0
    Uploads
    0

    Default PathPilot v 2.2.2 is now available

    Fixed Issues:

    All
    • We fixed an issue where using the Admin Logdata command didn't copy the log files .zip to the USB drive if the drive name had a space in it.
    • We improved the soft travel limits for each axis: when you enter a value, the soft travel limit range is now validated. You can also now view the current values for any soft travel limits on the Status tab.

    Mills

    We fixed issues where:
    o The following machines (with shared X- and Y-axis limit switches) sometimes incorrectly attempted to reference both axes at the same time:
    PCNC 1100 and PCNC 770 mills with an Enclosure Door Switch Kit installed
    PCNC 440 mills
    o In some situations, reverting to a previous version of Automatic Tool Changer (ATC) firmware failed.
    o Probe input wasn't triggering on PCNC 440 mills.

    Similar Threads:
    Last edited by kstrauss; 05-09-2019 at 11:12 AM. Reason: Improve formatting


  2. #2
    Member kstrauss's Avatar
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    1431
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot v 2.2.2 is now available

    I installed PP 2.2.2 this morning and spent a little time exploring. There are a number of new ADMIN commands listed but many do not appear to do anything. For example ADMIN GET_AXIS_BACKLASH is accepted but doesn't show anything on the Status tab. ADMIN MEMORY works as expected. ADMIN MOUSE gives a nice menu to set mouse speed and other goodies. ADMIN BOOTMENU ON briefly enables coolant and then gives the errors in the second screen shot. It seems that a controller reboot is required to again connect to my 770. After the reboot everything appears normal and unchanged.

    Has anyone else tried the additions?

    Attached Thumbnails Attached Thumbnails PathPilot v 2.2.2 is now available-screenshot-7-jpg   PathPilot v 2.2.2 is now available-screenshot-8-jpg  


  3. #3
    Member maker of things's Avatar
    Join Date
    Mar 2012
    Location
    United States
    Posts
    96
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot v 2.2.2 is now available

    I installed this weekend in preparation for servo upgrade. Now my Vistacnc p4s pendant doesn't work (worked on 2.1.6) When I edit the 1100m specific ini halfile (per vista cnc instructions) the machine can no longer figure out what it is and won't boot. When I delete the new line, PP boots up fine. Hate not having the MPG.

    -Jon


  4. #4
    Member kstrauss's Avatar
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    1431
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot v 2.2.2 is now available

    Your Vista P4S works? I tried unsuccessfully to follow their instructions when I first moved to PP and reluctantly put my pendant into a box somewhere. What version of their stuff and instructions are (were) you using?

    After making a chip-proof enclosure for my Tormach pendant I've grown used to it.



  5. #5
    Member maker of things's Avatar
    Join Date
    Mar 2012
    Location
    United States
    Posts
    96
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot v 2.2.2 is now available

    Quote Originally Posted by kstrauss View Post
    Your Vista P4S works? .
    Not anymore. Since I updated to 2.2.2.

    on 2.1.6 I followed the instructions that are currently on their site http://www.vistacnc.com/manual_downl...s_linuxCNC.zip . I'm not a programmer so I don't even fully understand what everything is supposed to do, but I do know that the makefile did not run as advertised. I manually copied and pasted vc-p4s and 99-vistacnc-pentant.rules to the folders indicated. I added the halfile = vc-p4s-pp.hal line to tormach_1100m.ini instead of 1100-3 (I think, that was the nomenclature in 2.1.6)
    In 2.2.2 there is 1100M, 1100M+ and 1100MX.specific.ini available. Updateing to 2.2.2 overwrote some of the folders so I had to copy a file to two again. When I added the halfile = vc-p4s (still don't know what that means) the mill boots to a screen declaring PP was unable to determine the machine type, would I please select the machine from a list and restart. This becomes an endless loop. When I edit the .ini to remove the halfile edit, the machine again identifies as an 1100M. One time I told it that it was an M+ and it liked that very much, until I tried to reference the z axis and it ignored the limit switch and made a terrible noise trying to lift the head off the casting. I would not recommend doing this.

    I did try adding the halfile edit to the base machine.ini as well and had the same result as modifying the 1100M file.

    Tormach tells me after the MX is out they will have something similar to the control panel they showed at IMTS and that will have an MPG.

    -Jon


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

PathPilot v 2.2.2 is now available

PathPilot v 2.2.2 is now available

PathPilot v 2.2.2 is now available