Need Help! Stepper motors don't seem to work :-(

Results 1 to 2 of 2

Thread: Stepper motors don't seem to work :-(

  1. #1
    Join Date
    Feb 2014

    Question Stepper motors don't seem to work :-(

    Hi everyone, i'm planning to build my own cnc machine and recently i have received my usbcnc controlboard, motor drivers and motors.
    Unfortunately, I can't get it to work..

    Here is what I'm trying to hook up:

    - USBCNC board : USB CNC 4 Axis Controller Interface Board Cncusb MK1 Usbcnc 2 1 Substitute Mach3 | eBay
    - Motor drivers (3x) : CNC Router Single 1 Axis 3 5A TB6560 Stepper Stepping Motor Driver Board Control | eBay
    - Motors (3x): 3 x NEMA 17 Japan Servo Stepper Motors 83oz in Mill Robot RepRap Makerbot Prusa | eBay

    Here a pic from my test setup:
    Stepper motors don't seem to work :-(-dsc_0014_800px-jpg1

    If not clear from the picture, this is how the wires are connected:

    usbcnc board -> motor driver wires:

    CP -> Pul-
    CW -> Dir-
    - -> EN-
    +5 -> +V

    motor driver -> motor wires

    A+ -> brown
    A- -> orange
    B+ -> red
    B- -> yellow

    black and white wires on motors are common and not connected
    I have measured this (resistance between fases = 4 ohms, between fase and common= 2 ohms) and is also in line with the color table on:
    301 Moved Permanently

    The motor driver is connected to a 24V 2.5A powersupply (also tried a 12V 1.25A power supply)

    -- What happens? --

    The USBCNC board is recognized by the driver and software. When jogging, the coordinates change on the screen.
    I suppose it works correctly

    The motor driver also seems to work as far as i can see.
    It's 'power' LED is on and when jogging the X-axis, the 'run' LED is on

    The motor however does not, move, click vibrate what so ever.
    The holding torque seems to be same as when not connected

    -- What have i tried? --

    I tried :
    - two different power supplies (12V and 24V)
    - various dipswitch settings on the motor driver
    - hooking up the other 2 motors (
    - hooking up the other 2 motor drivers
    - one of the other 2 motor cables (connector could be faulty)
    - switching the B+ and B- wires` (ebay page of motor says: "Comes with 6-Lead Wire; A, A Common, A-, B-, B Common, B")

    What could be wrong, other than i have received 3 defective stepper motors?

    Similar Threads:
    Last edited by winand; 03-05-2014 at 02:22 PM. Reason: typing errors

  2. #2
    Join Date
    Feb 2014


    Don't you hate that, that you solve the problem after posting it on a forum?
    Seems to work now, i have disconnected wire "-" (controllerboard) -> "EN-" (driver)

    little new problem occurs now;
    after stop jogging, sometimes the motor keeps making noise and gets hot.
    Suppose it has something to do with the parameters of the driver board.
    I'm on to it now!

    Last edited by winand; 03-05-2014 at 03:08 PM. Reason: typing error

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts


    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on

Our Brands

Stepper motors don't seem to work :-(

Stepper motors don't seem to work :-(