420 owner needs help

Results 1 to 4 of 4

Thread: 420 owner needs help

  1. #1
    Member doncraig's Avatar
    Join Date
    Nov 2019
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default 420 owner needs help

    Hi,
    I hope someone can help me please. I have multiple problems here with a Stepcraft 420 and would like to get them sorted.

    I have been given a Stepcraft 420 to try and get it working again. I have no knowledge of this machine, the old man who owned the machine has recently died and his family have asked me to have a look at it before selling it. There is also a problem as they can't access his computer that the machine ran from.
    When the power is supplied to the board I get 2 green lights which (I think) indicates that "Sharing ok, output stage switched on, emergency switch switched off" and "Voltage is applied at (5V)" and I am quite happy with that, so far.

    My problem really starts when I try to connect with a computer. The daughter board is a SC 100 USB - LPT Controller and into this is a UC 100 CNC Motion Controller. When I try to connect the USB cable from computer to the UC 100 the connection is not secure and sometimes falls out. Sometimes when moving it about the green light comes on at the left side of the UC 100 and there is a noise comes from the Y axis motor.
    Can I substitute the other (unused) daughter board, which has a D type port (for a printer) and see if that works.
    I believe the machine came originally with UCCNC

    Don W

    Similar Threads:
    Attached Thumbnails Attached Thumbnails 420 owner needs help-img_3992-jpg  


  2. #2
    Member doncraig's Avatar
    Join Date
    Nov 2019
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: 420 owner needs help

    I have found a problem with the Emergency Stop button (I think). When I plug the power to the board on the machine all the motors seize up. When I hit the Emergency Button the motors are free. When I turn the Emergency Button to safe again the motors all seize up again. Can anyone explain what is happening please ???
    Don W



  3. #3
    Member
    Join Date
    Dec 2015
    Posts
    433
    Downloads
    0
    Uploads
    0

    Default Re: 420 owner needs help

    Your motors should only be powered when the e-stop is in the off state. So when they "seize" they are actually holding position as they should be, then when the e-stop pushed, the motors will lose power and turn freely.

    Somebody that knows more about the SC 100 USB-LPT can probably help with your connection issue, but I know USB is fairly susceptible to noise so that could be your issue.

    Again, I'm not familiar with the UCCNC board, but the UCCNC license I think get's tied to your specific motion controller board, so if the original PC and License is lost you'll likely need to contact UCCNC support for help. They've been very responsive when I had questions.



  4. #4
    Member doncraig's Avatar
    Join Date
    Nov 2019
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: 420 owner needs help

    Quote Originally Posted by CL_MotoTech View Post
    Your motors should only be powered when the e-stop is in the off state. So when they "seize" they are actually holding position as they should be, then when the e-stop pushed, the motors will lose power and turn freely.
    I am having a little trouble understanding this point. I have reattached the wires from the Estop. When I connect the power to the board, one green led comes on and the motors turn freely.
    When I hit the Estop both leds light up and the motors 'seize'. Is this what should happen ??

    Somebody that knows more about the SC 100 USB-LPT can probably help with your connection issue, but I know USB is fairly susceptible to noise so that could be your issue.
    I have individual surge protectors fitted on the units

    Again, I'm not familiar with the UCCNC board, but the UCCNC license I think get's tied to your specific motion controller board, so if the original PC and License is lost you'll likely need to contact UCCNC support for help. They've been very responsive when I had questions.
    I think I will ask UCCNC but as the UC 100 motion controller and the USB cable are both damaged I think I may need to purchase a new set. It is just annoying that I can't get any movement on any axis just to see if the machine works

    Thanks again
    Don W

    Attached Thumbnails Attached Thumbnails 420 owner needs help-pic_1-jpg   420 owner needs help-pic_2-jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

420 owner needs help

420 owner needs help

420 owner needs help