Need some general advice on VFD parameters for a spindle - Page 2


Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

Thread: Need some general advice on VFD parameters for a spindle

  1. #21
    Member
    Join Date
    Jul 2008
    Location
    Canada
    Posts
    29
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    I did a 13-08=4 factory reset. Then I input all of the codes again.

    00-06 the Alt Freq command source - defaults to 4 ( external ) and would not accept 1 ( Pot on keyboard )

    01-04 Middle Output Freq would not accept 0. I tried a number of other values and it finally accepted 200.

    01-05 Middle Freq voltage ratio 2 would not accept 0. It automatically input 115 which I accepted.


    The motor ran much as before and responds normally to the pot but as I bring the frequency gets down to about 157 Hz, the motor slows to a complete stop.

    And then I went back to try to sort out the values that would not be accepted and now nothing works. I get an OC-A error : Output current exceeds the over current level.

    I seems that with certain inputs being made, the VFD does a bit of its own math and changes other parameters. Probably some that are not on my list but ones that are being reset by the 13-08=4 factory reset. I'm going to go back and do it all over again.



  2. #22
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10764
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    Quote Originally Posted by David Morrow View Post
    I did a 13-08=4 factory reset. Then I input all of the codes again.

    00-06 the Alt Freq command source - defaults to 4 ( external ) and would not accept 1 ( Pot on keyboard )

    01-04 Middle Output Freq would not accept 0. I tried a number of other values and it finally accepted 200.

    01-05 Middle Freq voltage ratio 2 would not accept 0. It automatically input 115 which I accepted.


    The motor ran much as before and responds normally to the pot but as I bring the frequency gets down to about 157 Hz, the motor slows to a complete stop.

    And then I went back to try to sort out the values that would not be accepted and now nothing works. I get an OC-A error : Output current exceeds the over current level.

    I seems that with certain inputs being made, the VFD does a bit of its own math and changes other parameters. Probably some that are not on my list but ones that are being reset by the 13-08=4 factory reset. I'm going to go back and do it all over again.
    It sounds like the VFD Drive is not suited for your spindle, but also may be something simple

    After you do a reset just put in all the motor spec's and what the Keypad needs the Minimum and Max Frequency 133.4 and 400 and then try it again

    You get that fault because the motor is not running correct and will damage it if it keeps doing this

    Mactec54


  3. #23
    Member
    Join Date
    Jul 2008
    Location
    Canada
    Posts
    29
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    The spindle wiring is fairly straight forward - 4 pins but only 1,2, and 3 are used. Is there a way to test the motor pins to be sure that the right ones are being used and connected correctly ?



  4. #24
    Member
    Join Date
    Jul 2008
    Location
    Canada
    Posts
    29
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    It seems that 01-08 and 01-09 seem to be the issue. When I go into those parameters after setting everything else, the VFD has entered values of .60 and 2.2 respectively. I find that if I just leave those values, the motor runs. I'm going to leave it there for now and maybe get a tachometer to measure the spindle speeds.

    Thank you so much for your help and patience. I will report back in as things develop.

    The next thing is to connect the external controls. I left that out of this step as that would mean way to many variables to sort through.

    https://www.factorymation.com/30PBA3-N12-300-AS_2



  5. #25
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10764
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    Quote Originally Posted by David Morrow View Post
    The spindle wiring is fairly straight forward - 4 pins but only 1,2, and 3 are used. Is there a way to test the motor pins to be sure that the right ones are being used and connected correctly ?
    You can not use a normal meter to measure the output Power of the VFD Drive

    You have to use all 4 Pins the spindle must be Grounded this sounds like another problem you have

    The normal connection is

    Pin 1=U

    Pin 2=V

    Pin 3=W

    Pin 4=Ground which in most spindles is not connected this needs to be connected your air cooled spindle is a little harder to connect from the plug to the spindle Body

    Remove the plastic cap and connect a Ground wire to Pin 4 and then cut out part of the cap where the mounting screws hold it on you will use a stud and lock nut to mount the Ground wire crimped on fitting and then a nut to hold the plastic cover back on

    You can not use the Spindle without a Ground wire from the spindle to the VFD Drive this cable needs to be 4 wire Shielded and Grounded correctly

    Mactec54


  6. #26
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10764
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    Quote Originally Posted by David Morrow View Post
    It seems that 01-08 and 01-09 seem to be the issue. When I go into those parameters after setting everything else, the VFD has entered values of .60 and 2.2 respectively. I find that if I just leave those values, the motor runs. I'm going to leave it there for now and maybe get a tachometer to measure the spindle speeds.

    Thank you so much for your help and patience. I will report back in as things develop.

    The next thing is to connect the external controls. I left that out of this step as that would mean way to many variables to sort through.

    https://www.factorymation.com/30PBA3-N12-300-AS_2
    Yes that is the correct way to get a drive like this going to use the KeyPad first and then go remote, you don't need that type of switch button control you can do it all through your control software

    I have another Parameter list to try, although what you just posted this may not change much but I did leave out some of the parameters you where having trouble with and have added some others

    The 60 is relating to a 60Hz motor which could be a problem and may mean that the drive is not suitable for your spindle or could be still just a Parameter conflict

    00-00=0 V/F Mode

    00-07=1

    00-08=400

    00-11=400 ????

    00-12=400

    00-13=133.4

    01-02=220

    01-02=400

    01-08=133.4 ????

    02-00=80%

    02-01=3

    02-03=24000

    02-04=220

    02-05=.8

    02-06=400

    00-00=2 Vector mode only change this if you are going to try Vector mode IF you do you can then use Auto Tune

    These motor spec's should be set

    17-01=.8

    17-02=3

    17-03=220

    17-04=400

    17-05=24000

    Mactec54


  7. #27
    Member
    Join Date
    Jul 2008
    Location
    Canada
    Posts
    29
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    I am happy to report that I have now wired the external Start / Stop / Variable Speed Control potentiometer and have the related VFD parameters set. That means not having to use those tiny Start, Stop, and speed controls on the face of the VFD.

    External control box : https://www.factorymation.com/30PBA3-N12-300-AS_2


    I will leave the Google Sheet with the VFD parameters in place for reference for anyone else who may face the same hurdles that I did.
    https://docs.google.com/spreadsheets/d/1W4X_DvuCc1bX9P3939E15rDRaK6fd7wsmvdbrKgH90g/edit#gid=0







  8. #28
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10764
    Downloads
    0
    Uploads
    0

    Default Re: Need some general advice on VFD parameters for a spindle

    Quote Originally Posted by David Morrow View Post
    I am happy to report that I have now wired the external Start / Stop / Variable Speed Control potentiometer and have the related VFD parameters set. That means not having to use those tiny Start, Stop, and speed controls on the face of the VFD.

    External control box : https://www.factorymation.com/30PBA3-N12-300-AS_2


    I will leave the Google Sheet with the VFD parameters in place for reference for anyone else who may face the same hurdles that I did.
    https://docs.google.com/spreadsheets/d/1W4X_DvuCc1bX9P3939E15rDRaK6fd7wsmvdbrKgH90g/edit#gid=0



    Good to hear you are running if you had just moved my list up ( 2 ) spaces up to 01.04 and left the bottom 2 at the default you would of had the same outcome

    What got me was the Middle output frequency 2 normally when you see a ( 2 ) that means for a second motor control in other drives

    Mactec54


Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Need some general advice on VFD parameters for a spindle

Need some general advice on VFD parameters for a spindle

Need some general advice on VFD parameters for a spindle