Need Help! Mach3, 4 axes, Post-processor, SolidCam


Results 1 to 3 of 3

Thread: Mach3, 4 axes, Post-processor, SolidCam

  1. #1
    Registered
    Join Date
    Dec 2008
    Location
    Canada
    Posts
    38
    Downloads
    0
    Uploads
    0

    Default Mach3, 4 axes, Post-processor, SolidCam

    Hello! en need help
    My project is 3 grooves at 120 degrees around a cylinder, my 4th axis revolves around Y axis. I use Mach3 on my Router, SolidCam and Fanuc_2013_4X as a postprocessor to generate the G-Codes. The problem: My router works the first groove but is not able to do the other 2. The G-Code is not correct. He makes the first groove, he indexes at 120 degrees and returns to zero to make the 2nd. In the end, there is only one groove, the one at A0. What is the problem? The * .vmid file, the post-processor, Mach3. The simulation on SolidCam is perfect.

    Similar Threads:
    Attached Files Attached Files


  2. #2
    Registered IdefixRC's Avatar
    Join Date
    Jan 2017
    Location
    Singapore
    Posts
    13
    Downloads
    1
    Uploads
    0

    Default Re: Mach3, 4 axes, Post-processor, SolidCam

    Quote Originally Posted by jdgromi View Post
    Hello! en need help
    My project is 3 grooves at 120 degrees around a cylinder, my 4th axis revolves around Y axis. I use Mach3 on my Router, SolidCam and Fanuc_2013_4X as a postprocessor to generate the G-Codes. The problem: My router works the first groove but is not able to do the other 2. The G-Code is not correct. He makes the first groove, he indexes at 120 degrees and returns to zero to make the 2nd. In the end, there is only one groove, the one at A0. What is the problem? The * .vmid file, the post-processor, Mach3. The simulation on SolidCam is perfect.
    Have you tried this postprocessor already? https://github.com/teodoryantcheff/SolidCam-Mach3-Post



  3. #3
    Registered
    Join Date
    Dec 2008
    Location
    Canada
    Posts
    38
    Downloads
    0
    Uploads
    0

    Red face Re: Mach3, 4 axes, Post-processor, SolidCam

    Hello! idefixRC
    Yes, I already used it. Mach3_4Y sends me error messages. The only post-processor that works well is the fanuc_2013_4X. I think that this one does not recognize the function "TRANFORM" of SolidCam. If, I draw 3 grooves without "TRANFORM" everything is OK, all angles are good and the parts are perfect. I do not know how to include in the postprocessor the command "TRANFORM" and write the code.
    Thank for your reply



  4. #4
    kingson's Avatar
    Join Date
    Jan 2019
    Posts
    1
    Downloads
    0
    Uploads
    0

    Default

    i would very happy if i get an SolidCam 2017 Post for mach3 4-Axis (on X).
    try to Educate my self, i love CNC machining but no one wants to Help/-no time or not interested to Help XD



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Mach3, 4 axes, Post-processor, SolidCam

Mach3, 4 axes, Post-processor, SolidCam