Need Help! jerky g0 movement


Results 1 to 7 of 7

Thread: jerky g0 movement

  1. #1
    Registered
    Join Date
    Jun 2012
    Location
    US
    Posts
    72
    Downloads
    4
    Uploads
    0

    Default jerky g0 movement

    Hello,

    I really need some light on this trouble, please.

    I am trying to make my rotary axis more useful,
    searched and installed several different version of post processor for mach3 (or generic fanuc 4x)
    and looking into all of them, modifying a little bit here and there.

    while testing the post processor, I found this to be very weird and couldn't figure where the source of it is located.

    This is the shape of the model

    jerky g0 movement-03-jpg

    jerky g0 movement-solidcam-png

    as is seen in the screenshot of g-code, this zone makes the weird situation.

    1. it happens when it tries to approach to its first cutting level

    2. its generated using @move_5x procedure, traced it many times, it never calls @line_4x or @move_4x. only @line_5x or @move_5x

    3. it splits the whole distance into very small pieces, and that even happens in pure-z-level-movement, which was splitted exactly every 2mm

    4. CV mode doesn't help situation with G0 moves...

    so I temporarily edited @move_5x to have G1 instead of G0


    what is unclear to me is the source of this trouble.


    - it might be SC's own bug in logic
    - not a bug but wrong toolpath strategy(or option)?
    - it might be wrong machine setup with VMID (but which one???)
    - incomplete post processor

    I actually test-cut this shape and it seems like there is no wrong movement other than this.


    Can someone point me the direction where to look???

    tks, Kevin

    I am attaching this g-code.




    solidcam 2018SP2

    Similar Threads:
    Attached Files Attached Files


  2. #2
    Registered
    Join Date
    Jun 2012
    Location
    US
    Posts
    72
    Downloads
    4
    Uploads
    0

    Default Re: jerky g0 movement

    Okay, I tried to modify another, completely different post processor(original is Integrex which syntax is very close to generic fanuc) and the result is same.
    With approach/retract, it makes jerky G0 segments.

    Tried 3 types of simple models to see how it handles;

    1. 2.5D box type with 2 pockes : runs good, no oddity at all

    2. a box having 3D surface on top : runs good too, no oddity

    3. 4axis rotary cam model : it again makes these small-segmented g0 codes.


    So my best guess is that it is either within VMID setting or within solidcam itself, not sure which one yet.

    Any advise would be highly appreciated,

    tks
    Kevin



  3. #3
    Registered
    Join Date
    Jun 2012
    Location
    US
    Posts
    72
    Downloads
    4
    Uploads
    0

    Default Re: jerky g0 movement

    self-answering....

    this is very annoying.
    picture says it all...

    unchecked, and it again makes many small g0 segments
    checked, and I can get only 2 lines.
    this apparently isn't from post processor...
    simply stupid logic...
    again, this happens pnly in simultaneous 5axis mode(though I have 4axis only, it automatically calls for @move_5x & @line_5x, I have no idea why)

    jerky g0 movement-solidcam-2-jpg



  4. #4
    Registered partur's Avatar
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    36
    Downloads
    0
    Uploads
    0

    Default Re: jerky g0 movement

    Quote Originally Posted by Lozzy View Post
    again, this happens pnly in simultaneous 5axis mode(though I have 4axis only, it automatically calls for @move_5x & @line_5x, I have no idea why)
    https://vdocuments.mx/what-is-new-in...tool-2011.html
    read chapter 2.2.5 on 34 page. bdw u can turn off new working style @move_5x & @line_5x in vmid file.. tab working style > Working Style > Pos to machine

    Last edited by partur; 12-22-2018 at 02:16 PM.


  5. #5
    Registered
    Join Date
    Jun 2012
    Location
    US
    Posts
    72
    Downloads
    4
    Uploads
    0

    Default Re: jerky g0 movement

    Tks for the pointing this out and I appreciate the linked document. very helpful.
    It still is a mystery to me why SC makes many segmented G0 moves in sim5x mode. Any idea?

    regards,
    Kevin



  6. #6
    Registered partur's Avatar
    Join Date
    May 2013
    Location
    United Kingdom
    Posts
    36
    Downloads
    0
    Uploads
    0

    Default Re: jerky g0 movement

    I create a similar operarion with similar shape, my UI is in Polish lng but is only one things what you need to change:
    this is code for default settings:
    jerky g0 movement-2018-12-29-08_48_07-4x_ms_wybranesciany_-nc-d__dokumenty_solidworks_g

    Now u need open machine controls > choice advanced options > click on advanced Tab > go to Rapid Move frame and uncheck distance interpolation settings
    jerky g0 movement-2018-12-29-09_00_50-frezowanie-wieloosiowe-png

    Code after change:
    jerky g0 movement-2018-12-29-09_02_04-cimco-edit-8-a

    Last edited by partur; 12-29-2018 at 09:54 AM.


  7. #7
    Registered
    Join Date
    Jun 2012
    Location
    US
    Posts
    72
    Downloads
    4
    Uploads
    0

    Default Re: jerky g0 movement

    oh!!!!
    Found that option, and thanks for your help!!!!!!!!
    I really appreciate

    regards,
    kevin



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

jerky g0 movement

jerky g0 movement