Need Help! ESS not communicating with the computer


Results 1 to 6 of 6

Thread: ESS not communicating with the computer

  1. #1
    Member
    Join Date
    Jul 2017
    Location
    United States
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default ESS not communicating with the computer

    I have been using the ESS smooth stepper on my machine for about 6 months or so. Lately, I experienced a crash on my machine and I had to perform an E-stop on all my electronics in the middle of a job. After checking the machine the next day the spindle and spindle motor appeared okay, and all the diagnostic lights on the electronic parts came on without a problem. Also, it sounded as though all of the motors powered when I supplied power to them. However, when I loaded Mach4 the ESS did not communicate with Mach. I attempted all of the potential fixes listed on Warp9td's website, but I never got the ESS to respond, even though all of LEDs appeared to indicate it was working properly. It's not the ethernet cable and I repeatedly tried reconfiguring the board but I was never able to get the ESS to respond. Usually when the connection is successfully made the green light starts flickering rapidly, but I was never able to get it to connect. Whenever I run the configurator (and I made sure that Mach and SCU were closed while running it), the best I could get was the ESS device to display under "listening for smooth stepper", but the IP address on the device was listed as *.*.*.*.* even though I had attempted to set it both automatically as well as manually. Initially, I received an error code and suggestion to remove the jumper from JP1, but there was no jumper connected. Then I attempted the fix suggested on Warp9td's website to run the configurator while the jumper was connected. All of those attempts failed to cause the ESS to connect. I also went through the option of restoring the Windows Firewall defaults and then followed the configuration process that automatically sets up Windows to allow Mach3 & Mach4 to bypass the firewall, but I was still unsuccessful. Does anyone have any ideas what the problem could be, and how to diagnose it?

    Similar Threads:


  2. #2
    Member
    Join Date
    Dec 2009
    Location
    Australia
    Posts
    151
    Downloads
    0
    Uploads
    0

    Default Re: ESS not communicating with the computer

    I would start by testing the ethernet card itself by sending a constant ping to the ip address from a command prompt type "ping -t ipaddress"
    If this test okay I would then check the cable between the ESS and the Card

    If these test all pass you may have a faulty ESS



  3. #3
    Member
    Join Date
    Jul 2017
    Location
    United States
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default

    Thanks for your help!!!! I will give them a try.

    I’m wondering, also, if the WiFi dongle could have intercepted the IP address b/c support @ Warp9TD asked me if I get internet on that computer.




    QUOTE=squirrel_41;2252288]I would start by testing the ethernet card itself by sending a constant ping to the ip address from a command prompt type "ping -t ipaddress"
    If this test okay I would then check the cable between the ESS and the Card

    If these test all pass you may have a faulty ESS[/QUOTE]



  4. #4
    Member
    Join Date
    Jul 2017
    Location
    United States
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by Gallen66 View Post
    Thanks for your help!!!! I will give them a try.

    I’m wondering, also, if the WiFi dongle could have intercepted the IP address b/c support @ Warp9TD asked me if I get internet on that computer.




    QUOTE=squirrel_41;2252288]I would start by testing the ethernet card itself by sending a constant ping to the ip address from a command prompt type "ping -t ipaddress"
    If this test okay I would then check the cable between the ESS and the Card

    If these test all pass you may have a faulty ESS
    [/QUOTE]



  5. #5
    Member
    Join Date
    Jun 2011
    Location
    USA
    Posts
    42
    Downloads
    0
    Uploads
    0

    Default Re: ESS not communicating with the computer

    First check your IP address of your ethernet card(NIC).
    Since by default, the ESS IP address is set to 10.9.9.9.....
    Make sure the NIC address is Manually set to anything else i.e.10.9.9.1
    Make the NIC address is not set to Automatic or DCHP
    If this is done correctly, the Wifi dongle should affect it!
    As for the Firewall, for testing...turn it off!!

    Good Luck



  6. #6
    Registered
    Join Date
    Aug 2010
    Location
    US
    Posts
    29
    Downloads
    0
    Uploads
    0

    Default

    Not sure about this but it's a thought. Maybe the crash caused some settings to be mismatched.
    Ie... ip address and things such as that. Perhaps a hard reset of ip setting on the smoothstepper board are in order. I remember reading about the config jumper on the board being able to do that. Have you tried researching that option?

    Attached Thumbnails Attached Thumbnails ESS not communicating with the computer-screenshot_20190212-155314_samsung-internet-jpg   ESS not communicating with the computer-screenshot_20190212-155337_samsung-internet-jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

ESS not communicating with the computer

ESS not communicating with the computer

ESS not communicating with the computer