Need Help! Sharp 1640L Lathe Spindle Problem


Results 1 to 2 of 2

Thread: Sharp 1640L Lathe Spindle Problem

  1. #1
    Registered bcavender's Avatar
    Join Date
    Apr 2016
    Location
    United States
    Posts
    56
    Downloads
    0
    Uploads
    0

    Default Sharp 1640L Lathe Spindle Problem

    A friend has a 1640L with a CamLock system that holds the spindle to the head. He started to simply face a small bar and the entire spindle came off and fell.

    I went over and we put it back on, but I noticed there wasn't any detent or locking "click" when you engaged the cams. Seems odd like I am missing something. Couldn't find a Sharp manual last night for a search.

    Anyone know the trick here on how to lock these cams in so we can avoid a spindle problem again?

    Thanks!!!

    B

    Similar Threads:


  2. #2
    Registered
    Join Date
    Oct 2004
    Location
    usa
    Posts
    169
    Downloads
    0
    Uploads
    0

    Default Re: Sharp 1640L Lathe Spindle Problem

    tighten them up. There's no detent. Clean everything well before putting it together.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Sharp 1640L Lathe Spindle Problem

Sharp 1640L Lathe Spindle Problem