Need Help! Laser not firing with test button


Results 1 to 1 of 1

Thread: Laser not firing with test button

  1. #1
    Member
    Join Date
    Jan 2010
    Location
    USA
    Posts
    33
    Downloads
    0
    Uploads
    0

    Default Laser not firing with test button

    I have a 100W Redsail Laser and the laser stopped working.

    I have 220V to the laser power supply but the laser does not fire when the test button is pushed. Does the test button need water flowing to work? I have water flowing through the tube but I don't know how the system senses water flow. Can someone explain that to me?

    Assuming the water flow is sensed correctly does that mean I have a bad power supply? Is there a visual indicator of the power supply working? I know some have a light when the power supply is active.

    If the power supply is bad where can I find a replacement? I see many 100W/110V but no 100W/220V.

    Any help would be greatly appreciated.

    Tom

    Similar Threads:
    Last edited by tas99; 10-18-2020 at 04:22 PM.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Laser not firing with test button

Laser not firing with test button

Laser not firing with test button