Tool change AuroReturn to work instead of machine position

Results 1 to 6 of 6

Thread: Tool change AuroReturn to work instead of machine position

  1. #1
    Member AndrewRyan's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Tool change AuroReturn to work instead of machine position

    Hello.
    I have a Router with an MK3 controller.

    I would like to use the "AutoReturn" Feature after tool Change. The problem is that "AutoReturn" returns to the Machine position before the Tool Change procedure. When I switch from a small end mill to a longer end mill the machine may plunge directly into the workpiece after the tool change (depending on length of the new end mill end safe hight). I would like to AutoReturn to the Work position (which then includes the new tool length).

    Is it possible to change this behavior?

    Similar Threads:


  2. #2
    Member PlanetCNC's Avatar
    Join Date
    Mar 2017
    Location
    Slovenia
    Posts
    689
    Downloads
    0
    Uploads
    0

    Default Re: Tool change AuroReturn to work instead of machine position

    Autoreturn returns to work position.
    You can check and/or modify M6 script.



  3. #3
    Member AndrewRyan's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Tool change AuroReturn to work instead of machine position

    Actually it doesn't. At least not with my machine.
    I have Tool 1 active and jog to the surface of the workpiece.
    Then I set the work offset of all axis (for simplicity) to zero. (Work: 0/0/0 Machine: 204/256.3/29.5)
    Then I click on machine--> tools --> change --> tool 2.
    The Router drives to safe hight and then to the tool change position. I change the tool and click OK.
    The Router drives to the fixed Tool sensor and descends the z axis until switch is triggered (then again with low speed).
    When the tool length is measured it drives up to save hight, then back to X and Y.
    As last step it descends the Z axis to the starting Z MACHINE position --> Work:0/0/-6.533 Machine: 204/256.3/29.5

    I attached my config and a screenshot.

    Attached Thumbnails Attached Thumbnails Tool change AuroReturn to work instead of machine position-bildschirmfoto-2020-07-13-um-14-28-a  
    Attached Files Attached Files


  4. #4
    Member tantemay's Avatar
    Join Date
    Nov 2015
    Location
    Warendorf
    Posts
    186
    Downloads
    0
    Uploads
    0

    Default Re: Tool change AuroReturn to work instead of machine position

    I had the same problem. I decided to compromise.
    I have under Settings / Tool Change -> at "Tool Offset"

    "Set Offset" activated.
    "Enable Offset" is set to Enable
    "Auto Return" is set to Enable

    I also changed a script.
    Settings / Scripts / M-Code / M6 -> there I entered the command "G53 Z -5" in line 15.
    Now the machine moves before storing the XYZ coordinates, the Z axis to machine position -5
    So almost to the top.

    For me it works pretty well.
    I should have been able to write that in the PP. But then I would still have the problem when measuring the tool length by using the GUI



  5. #5
    Member PlanetCNC's Avatar
    Join Date
    Mar 2017
    Location
    Slovenia
    Posts
    689
    Downloads
    0
    Uploads
    0

    Default Re: Tool change AuroReturn to work instead of machine position

    I will fix this. Seems like wrong default script was included in distribution.



  6. #6
    Member AndrewRyan's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Tool change AuroReturn to work instead of machine position

    Quote Originally Posted by tantemay View Post
    I had the same problem. I decided to compromise.
    I have under Settings / Tool Change -> at "Tool Offset"

    "Set Offset" activated.
    "Enable Offset" is set to Enable
    "Auto Return" is set to Enable

    I also changed a script.
    Settings / Scripts / M-Code / M6 -> there I entered the command "G53 Z -5" in line 15.
    Now the machine moves before storing the XYZ coordinates, the Z axis to machine position -5
    So almost to the top.

    For me it works pretty well.
    I should have been able to write that in the PP. But then I would still have the problem when measuring the tool length by using the GUI
    "So almost to the top" --> I changed it to "G53 Z 100" because my machine coordination system starts at the bottom.
    This works great as a workaround. Thank you.

    @Planet-CNC Thanks for fixing it. Could you please post the right default script?



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Tool change AuroReturn to work instead of machine position

Tool change AuroReturn to work instead of machine position

Tool change AuroReturn to work instead of machine position