Blending function does not work in 3D [SOLVED]

Results 1 to 6 of 6

Thread: Blending function does not work in 3D [SOLVED]

  1. #1
    Member JerryBurks's Avatar
    Join Date
    Aug 2011
    Location
    USA
    Posts
    973
    Downloads
    0
    Uploads
    0

    Default Blending function does not work in 3D [SOLVED]

    I got TNG V2 running and for the most part it looks very good.
    However, I notice the blending feature (I have it set at the default values of 1.5mm / 0 degrees / 135 degrees) seems to work only if the machine is running in the x/y plane. As soon as the machine ramps the z-axis while moving, the blending appears to be suspended (even if the path angle change is very small) and starts decelerating and accelerating in very short increments.

    I have attached 4 gcode files that show the blending when machining flat (steady feed rate) and what happens when z goes up and down (stops for each segment). Especially with the spiral this gets annoying and slow.

    This behavior makes 3d-carving almost impossible. What can I do about that? Should I make the "Join" angle greater than zero? I guess then it might work at least like the old USBCNC?
    For that matter, it would be worthwhile to get more explanation how the blending works and how to set the parameters, maybe with a sketch.

    Similar Threads:
    Attached Files Attached Files
    Last edited by PlanetCNC; 11-04-2019 at 04:31 PM.
    Box Joint, Dovetail, Maze and Guilloche CAM software here: WWW.TAILMAKER.NET


  2. #2
    Moderator PlanetCNC's Avatar
    Join Date
    Mar 2017
    Location
    Slovenia
    Posts
    458
    Downloads
    0
    Uploads
    0

    Default Re: Blending function does not work in 3D

    Seems fine to me


    Export your profile and send it to our support email. I will take a look.



  3. #3
    Member JerryBurks's Avatar
    Join Date
    Aug 2011
    Location
    USA
    Posts
    973
    Downloads
    0
    Uploads
    0

    Default Re: Blending function does not work in 3D

    Thanks, I will send the settings file.
    FWIW, the effect can not be seen in the simulation. But on the real machine it becomes obvious.
    I will try to make a video clip that compares the flat machining with the 3d-machining.
    Maybe I should also try a simple vcarve how that works.

    Box Joint, Dovetail, Maze and Guilloche CAM software here: WWW.TAILMAKER.NET


  4. #4
    Moderator PlanetCNC's Avatar
    Join Date
    Mar 2017
    Location
    Slovenia
    Posts
    458
    Downloads
    0
    Uploads
    0

    Default

    Not settings file. Export you profile and send zip file.
    Don't bother with video until I examine it.



  5. #5
    Member JerryBurks's Avatar
    Join Date
    Aug 2011
    Location
    USA
    Posts
    973
    Downloads
    0
    Uploads
    0

    Default Re: Blending function does not work in 3D

    Just experimented with the "Join" angle: When I change it from zero to 8 degrees the motion for the ramped spiral becomes as smooth as for the flat spiral. (I suppose this is similar to the CNCUSB lookahead angle of 172 deg ?) But I have not tested this extensively.

    Sorry, just saw your reply. I will export the profile as well.

    Last edited by JerryBurks; 11-03-2019 at 06:53 PM.
    Box Joint, Dovetail, Maze and Guilloche CAM software here: WWW.TAILMAKER.NET


  6. #6
    Moderator PlanetCNC's Avatar
    Join Date
    Mar 2017
    Location
    Slovenia
    Posts
    458
    Downloads
    0
    Uploads
    0

    Default Re: Blending function does not work in 3D

    Solved. Z axis speed limit was set to low.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Blending function does not work in 3D [SOLVED]

Blending function does not work in 3D [SOLVED]

Blending function does not work in 3D [SOLVED]