Coordinates modal and / for rapids


Results 1 to 7 of 7

Thread: Coordinates modal and / for rapids

  1. #1
    Registered HuFlungDung's Avatar
    Join Date
    Mar 2003
    Location
    Canada
    Posts
    4826
    Downloads
    0
    Uploads
    0

    Default Coordinates modal and / for rapids

    In OnecncXP:

    More Shadow/Bandit peculiarities to deal with: these controllers require a "/" before each named axis on a Rapid move. This is not hard to do in the OnecncXP, but there is a problem with the slashes that are not needed when coordinate output is modal.

    Example:

    /X1. /Y1. /Z1.
    / / /Z0. (no movement in X and Y).

    Any trick to get around this? I could run with Coordinate output modal unchecked, but this makes for more stuff to transmit for DNC, as well as cluttering up the code a bit with redundant stuff.

    Thanks.

    Similar Threads:
    First you get good, then you get fast. Then grouchiness sets in.

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  2. #2
    Registered OneCNC's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    70
    Downloads
    0
    Uploads
    0

    Default / Modal

    Hu,

    Rather than inserting a "/" and removing the G00 from the format as you seem tobe doing currently , change the G00 variable as the posti designed to format, it insures 100% seemless posting.

    From ther Posting Format Dialogue Box Choose -> Rapid Line Format from the Drop Down Menu.

    On the right side are the available Insertions and Substitutions for that cycle. Select the - G00 Rapid Move and below will appear the current Rapid Line Variable Prefix. Repalce the G00 Value with the '/" character you require and click OK.

    This is proper method.

    Tech Support
    OneCNC LLC
    (877) 626-1262
    www.onecnc.com

    Attached Thumbnails Attached Thumbnails Coordinates modal and / for rapids-bandit-gif  


  3. #3
    Registered OneCNC's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    70
    Downloads
    0
    Uploads
    0

    Default / Modal

    Hu,

    Rather than inserting a "/" and removing the G00 from the format as you seem tobe doing currently , change the G00 variable as the posti designed to format, it insures 100% seemless posting.

    From ther Posting Format Dialogue Box Choose -> Rapid Line Format from the Drop Down Menu.

    On the right side are the available Insertions and Substitutions for that cycle. Select the - G00 Rapid Move and below will appear the current Rapid Line Variable Prefix. Repalce the G00 Value with the '/" character you require and click OK.

    This is the proper and correct method, hope this helps.



    Tech Support
    OneCNC LLC
    (877) 626-1262
    www.onecnc.com

    Attached Thumbnails Attached Thumbnails Coordinates modal and / for rapids-bandit-gif  


  4. #4
    Registered HuFlungDung's Avatar
    Join Date
    Mar 2003
    Location
    Canada
    Posts
    4826
    Downloads
    0
    Uploads
    0

    Default

    I thought I tried that. I will recheck, but I think that will only place a single "/" at the front of the line, and it needs to be placed in front of each axis that happens to be named in that move. I'll recheck tonight when I get home just to be sure.

    I also tried a {G} in front of each axis like this:
    {G}{X} {G}{Y} {G}{Z}

    but this works out the same as doing what you said to do. It works fine if all axis are required, but if one or two of them are not needed, then we get the extra "/" in front of the deleted entry

    Thanks.

    First you get good, then you get fast. Then grouchiness sets in.

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  5. #5
    Registered HuFlungDung's Avatar
    Join Date
    Mar 2003
    Location
    Canada
    Posts
    4826
    Downloads
    0
    Uploads
    0

    Default

    Okay, I did recheck what happens and I was correct in what I described.

    Here is another thing I tried:

    In the Rapid Line Format G00, instead of replacing the G00 prefix with a "/", I just ignored this, because no {G} will be used at all. What I did is relace the X with a /X prefix, a Y with a /Y prefix, and a Z with a /Z.

    So the Start lines field displays simply as follows:
    {X} {Y} {Z}

    But the prefixes are all changed as described above.

    This seems to work right for Rapid mode, but unfortunately this /X or /Y or /Z gets retained as the "permanent prefix" for Feedrate mode, too.

    I notice that this "universal prefix" rule does not seem to apply to the {G}, for example, in G00, it will retain the "/" if I put it in, and if I then go to the G01 setup and check the prefix that is associated with {G}, it can be different, or blank as I desire.

    Perhaps you can fix is so that the XYZ prefixes remain associated uniquely with each setup field.

    Last edited by HuFlungDung; 04-04-2003 at 10:23 PM.
    First you get good, then you get fast. Then grouchiness sets in.

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  6. #6
    Registered OneCNC's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    70
    Downloads
    0
    Uploads
    0

    Lightbulb

    HU,

    The posting works as I described but I will elaborate further.

    As per the above posting replace the G00 with a "/" .

    Modify the Rapid Move format as follows:
    {G}{X} {G}{Y} {G}{Z} {F}

    Doing as instructed in the above post produces a / for each axis as it is just a multiple variable call/insertion which works in both modal and non-modal formats.

    The resulting code output is as follows:

    (This is a series of rapid moves between 4 points followed by 2 feed movements using the above format. )

    MODAL COORDINATES AND G CODES
    /X-1.4219 /Y-1.1458 /Z0.
    Y1.7396
    X1.6094
    Y-1.1458
    X-1.4219
    G01 X1.6094 Y1.7396 F10.0
    X-1.4219

    NON-MODAL
    /X-1.4219 /Y-1.1458 /Z0.
    /X-1.4219 /Y1.7396 /Z0.
    /X1.6094 /Y1.7396 /Z0.
    /X1.6094 /Y-1.1458 /Z0.
    /X-1.4219 /Y-1.1458 /Z0.
    G01 X1.6094 Y1.7396 Z0. F10.0
    G01 X-1.4219 Y1.7396 Z0.

    Tech Support
    OneCNC LLC
    (877) 626-1262
    www.onecnc.com



  7. #7
    Registered HuFlungDung's Avatar
    Join Date
    Mar 2003
    Location
    Canada
    Posts
    4826
    Downloads
    0
    Uploads
    0

    Default

    This first combination of options will not work with Bandit/Shadow, as every axis that is moving in Rapid must always be addressed with a "/", thus Gcodes must be nonmodal always.
    MODAL COORDINATES AND G CODES
    /X-1.4219 /Y-1.1458 /Z0. (Rapid move, correct syntax)
    Y1.7396 (considered feedrate move)
    X1.6094 (considered feedrate move)
    Y-1.1458 (considered feedrate move)
    X-1.4219 (considered feedrate move)
    G01 X1.6094 Y1.7396 F10.0 (considered feedrate move)
    X-1.4219 (considered feedrate move)


    This one I can get all right, just as you posted:
    NON-MODAL Gcodes and Non-modal Coordinates
    /X-1.4219 /Y-1.1458 /Z0.
    /X-1.4219 /Y1.7396 /Z0.
    /X1.6094 /Y1.7396 /Z0.
    /X1.6094 /Y-1.1458 /Z0.
    /X-1.4219 /Y-1.1458 /Z0.
    G01 X1.6094 Y1.7396 Z0. F10.0
    G01 X-1.4219 Y1.7396 Z0.


    Here is the third option which I originally spoke of and was having trouble with:
    NON-MODAL Gcodes and Modal Coordinates. Notice the "/" that is retained when the associated redundant axis movement is eliminated. Here is what it would turn out like (but is incorrect Bandit/Shadow syntax), using your same code as above:

    /X-1.4219 /Y-1.1458 /Z0.
    / /Y1.7396 /
    /X1.6094 / /
    / /Y-1.1458 /
    /X-1.4219 /Y-1.1458 /
    X1.6094 Y1.7396 Z0. F10.0
    X-1.4219 Z0.


    ( I also removed the G01, since this is not required, but this is easily eliminated in the NC setup)

    Note, this third permutation of modal options does work correctly in OneCNC Mill Professional.

    As I suggested above, the simplest fix would be to allow for unique prefixes to exist in the G00 setup versus the G01 setup for these three:
    Value X
    Value Y
    Value Z
    If you can acoomplish this, I think it would be harmless to all other users who are using the standard FANUC-speak.

    (and no, I didn't stay up till 4 in the morning to post this )

    Last edited by HuFlungDung; 04-07-2003 at 02:47 AM.
    First you get good, then you get fast. Then grouchiness sets in.

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Coordinates modal and / for rapids

Coordinates modal and / for rapids

Coordinates modal and / for rapids