PathPilot on a Novakon Questioin - Page 4

Page 4 of 4 FirstFirst 1234
Results 37 to 45 of 45

Thread: PathPilot on a Novakon Questioin

  1. #37
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Thanks for those, I had to go out of town for business, but will be home Wednesday night and give it a shot then. Also thanks for annotating your changes to the hal file. I'm definitely no developer, but I like to think I can follow along and maybe learn a little something. I'd love to here and see more about your pendant setup.

    Also, I have noticed every once in a great while, when I fire up the machine, and then go to reference the axis' , the homing goes in the wrong direction of travel. If I shut the machine all the way down and bring it back up, everything seems OK. It's not the end of the world, but it's happened at least twice.

    Jason --CNC Newbie--


  2. #38
    Registered
    Join Date
    Oct 2004
    Location
    usa
    Posts
    166
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Make sure it is not setting on a limit switch when you go to home the machine. I have not figured out why yet but I had to put a large home offset in the z axis because if Z calibrated it first it would not come off the switch. then do x or y and it would move the other direction to try an clear the limit.



  3. #39
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    So I tried Powerr's files as-is, and the spindle now runs the correct direction, although the speed seems to be 16% off. 500 Commanded, PDB shows 420 actual. Also, all the jog and homing are now completely backwards from what they were before. Over the next few days I am going to try and take parts of both configs and get it to do what I need it to.

    Jason --CNC Newbie--


  4. #40
    Registered
    Join Date
    Oct 2004
    Location
    usa
    Posts
    166
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Interesting, we both have servo machines I wonder why the different travel directions. In the INI file I changed the direction sign for SCALE to flip my travel directions. had to change HOME_SEARCH_VEL and HOME_LATCH_VEL signs too.
    At the moment I am using 2.1.3 and having a Issue with the tool table getting wiped out with each shutdown of the machine.



  5. #41
    Registered
    Join Date
    Dec 2012
    Location
    Norway
    Posts
    314
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Quote Originally Posted by powerr View Post
    At the moment I am using 2.1.3 and having a Issue with the tool table getting wiped out with each shutdown of the machine.
    Try to upgrade to 2.1.4. From the release notes, it looks like your problem mat have been fixed.

    "If changes were made to tools 1 through 256 in the tool table, and the controller unexpectedly restarted, the changed values weren't retained (PP-2233)"



  6. #42
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Quote Originally Posted by Stigoe View Post
    Try to upgrade to 2.1.4. From the release notes, it looks like your problem mat have been fixed.

    "If changes were made to tools 1 through 256 in the tool table, and the controller unexpectedly restarted, the changed values weren't retained (PP-2233)"
    FWIW, 2.13 to 2.14 resolved a touchscreen calibration issue I was having. There is a ton of fixes in that release.

    Jason --CNC Newbie--


  7. #43
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    So I was able to make some good progress. I was able to get the spindle direction flipped around so it works correctly. I still have the problem with the spindle not running at commanded speed, or at least there is a discrepancy as to what is commanded and what the PDB display is reporting. I would assume that the PDB display pulls the info off the spindle encoder, so it's probably more accurate. It was apparently doing this before, because when I reverted back to sagreen's files, the RPM behavior was identical.

    500=410 =18% Low
    1000=1140 =11.4% High
    1500=1806 = 20% High
    2000=2401 = 20% High
    3000=3525 = 17.5% High
    4000=4700 = 17.5% High
    5000=5865 = 17.3% High
    6000=6230 = 4% High


    So if you throw out the highest and the lowest #, and the highest number, the bulk of the error appears to be pretty consistent 17-20% It appears there is some information over in one of the older threads that is pertinent to scaling the speed. I am going to go over and read through that a little more.

    Also commanding RPM in the RPM window is still broken for me, It seems to work fine from the MDI, so not a dealbreaker.

    Jason --CNC Newbie--


  8. #44
    Registered
    Join Date
    Oct 2004
    Location
    usa
    Posts
    166
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    I will give 2.1.4 a try tonight. Thanks guys.
    I was able to fix the commander speed in the novakon.hal I think it is so strange that it does
    Not work for you.
    I will check spindle rpm tonight. See what the machine does. When setting it all up
    I set the spindle speed to 6000 rpm on the control and adjusted the blue pot on the novkon board
    Until it was reading 10volts. I would swear it was around 480 when commanding 500.
    Tinkered with this thing so much I can not remember all the crap I have adjusted on the drives.
    Was running mach4 with a hicon. But until they do something different with the trajectory planner
    I have abbandonded it. Also like with linuxcnc and pathpilot motion stops on a accidental probe hit



  9. #45
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on a Novakon Questioin

    Wow, so what day. After doing a bunch of research, it appeared that lincurve would be just the ticket to sort out the speed errors I was seeing. So I started working on it by re-enabling lincurve in the novakon.hal. That didn't go so well. So long story short, with the change to Linux Mint in 2.x PP no longer compiles the real time libs as kernel modules, instead they run in user space. So I found a thread on the LinuxCNC forum, and ended up compiling everything from scratch. I copied the new lincurve over, and bam, we are in business. My RPM error is down in the single digits across the board now, except for right at 6000, I will need to tweak that guy some more. Anyhow, I have attached a copy of my files, and a complete set of 2.x compatible rt libraries in case anyone should ever have a need.
    Thanks for all the help along the way!!
    Jason

    Attached Files Attached Files
    Last edited by WTFover; 10-06-2018 at 09:04 AM.
    Jason --CNC Newbie--


Page 4 of 4 FirstFirst 1234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

PathPilot on a Novakon Questioin

PathPilot on a Novakon Questioin