PathPilot on Novakon Torus Pro - Page 5

Page 5 of 7 FirstFirst ... 234567 LastLast
Results 49 to 60 of 77

Thread: PathPilot on Novakon Torus Pro

  1. #49
    Registered bill south's Avatar
    Join Date
    Apr 2005
    Location
    usa
    Posts
    1195
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Hey WT;
    I have been attempting to install PP on my pro without any success. It just does not want to install as described here and on other threads. On one of the other Tormach threads, there is a mention of a new issue of PP labeled as PP2.0 and is suppose to be an enhanced versions. Also, it addresses issues with installation and USB ports which I think is my problem. So, I'm on hold until version 2.0 is issues and (hopefully) Tormach will sell me the upgrade for use on my Novakon. I'm literally hundreds of $$ into this conversion and am still running Mach.
    Good luck and I'll keep watching to see what you come up with.
    Bill

    billyjack
    Helicopter def. = Bunch of spare parts flying in close formation! USAF 1974 ;>)


  2. #50
    Registered
    Join Date
    Feb 2008
    Location
    USA
    Posts
    511
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    If the 6I25 card gets flashed that pretty much guarantees that its OK

    I suspect that to debug these issues you will have to find out the actual error message from Pathpilot startup
    have you tried looking at the kernel log (with dmesg) after attempting to start PathPilot?

    Can you launch PathPilot from the command line? that may also yield some clues

    I think the chief issue is that you are flying blind, where the smallest error say in the hal file only gets a generic "Oww" error
    without any hint of what actually is wrong, This make sense for Tormach where the hardware is all standard but is really a pain
    with different hardware/firmware



  3. #51
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by bill south View Post
    Hey WT;
    I have been attempting to install PP on my pro without any success. It just does not want to install as described here and on other threads. On one of the other Tormach threads, there is a mention of a new issue of PP labeled as PP2.0 and is suppose to be an enhanced versions. Also, it addresses issues with installation and USB ports which I think is my problem. So, I'm on hold until version 2.0 is issues and (hopefully) Tormach will sell me the upgrade for use on my Novakon. I'm literally hundreds of $$ into this conversion and am still running Mach.
    Good luck and I'll keep watching to see what you come up with.
    Bill
    There's a great video on YouTube that shows you how to make a bootable flash drive with a piece of software called R-Drive If you have the iso file. That's what I did, after dicking around with things like Rufus and Linux USB creator without much success. It worked like a champ. I suggest giving that a shot.

    Jason --CNC Newbie--


  4. #52
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by PCW_MESA View Post
    If the 6I25 card gets flashed that pretty much guarantees that its OK

    I suspect that to debug these issues you will have to find out the actual error message from Pathpilot startup
    have you tried looking at the kernel log (with dmesg) after attempting to start PathPilot?

    Can you launch PathPilot from the command line? that may also yield some clues

    I think the chief issue is that you are flying blind, where the smallest error say in the hal file only gets a generic "Oww" error
    without any hint of what actually is wrong, This make sense for Tormach where the hardware is all standard but is really a pain
    with different hardware/firmware
    I am going to go take the motherboard and card out of the enclosure tonight and bring home so I can do some bench testing and some more debugging. I also have another M-ITX board here that I would like to give it a try too.

    Jason --CNC Newbie--


  5. #53
    Registered bill south's Avatar
    Join Date
    Apr 2005
    Location
    usa
    Posts
    1195
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    WT;
    I've already tried the r-drive/flash drive approach. Didn't work for me! I do have a question for the experts though. If I change to a new motherboard and use the processor from the original, will it still be compatible with the original windows on the Novakon SSD which I am not making changes to? If memory serves me, back in yesteryears windows married itself to the motherboard/bios of the computer it is installed on. I want the ability to switch back to the original novakon configuration if troubles still haunt me!
    Thanks.
    Bill

    billyjack
    Helicopter def. = Bunch of spare parts flying in close formation! USAF 1974 ;>)


  6. #54
    Registered
    Join Date
    Mar 2009
    Location
    USA
    Posts
    303
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by WTFover View Post
    I am going to go take the motherboard and card out of the enclosure tonight and bring home so I can do some bench testing and some more debugging. I also have another M-ITX board here that I would like to give it a try too.
    I'll echo what PCW said above. If you open a terminal window and run PP from the command line you will get a lot more information as to what is happening during the load process. That always got me on the right path.

    PCW_MESA I had some similar flukiness with the firmware that you made for me. I never really got to the bottom of what the problem was cause it went away. Initially I had the exact same problems where it would boot and tell me that I needed to install a new version of PP. I had to reflash about 3 times then it magically worked. I believe that KVOM had exactly the same prob. Not sure if you could re-create the firmware and let me do a binary diff.

    Also, I would check to make sure that the flash actually worked. I'm not at the mill, but I think the command to check the pins is this. (Brian or PCW, please correct me if im wrong)

    sudo mesaflash --device 5i25 --readhmid

    #################################################################################################
    # 5i25 Pin out for NOVAKON Torus bit file
    #IO Connections for P3

    #Pin# Mill Fxn I/O Pri. func Sec. func Chan Pin func Pin Dir

    # 1 X step 0 IOPort StepGen 0 Step (Out)
    #14 Spindle Dir 1 IOPort PWMGen 0 Dir (Out)
    # 2 X Dir 2 IOPort StepGen 0 Dir (Out)
    #15 ProbeIn(act low) 3 IOPort None
    # 3 Y Step 4 IOPort StepGen 1 Step (Out)
    #16 Spindle Step 5 IOPort PWMGen 0 PWM (Out)
    # 4 Y Dir 6 IOPort StepGen 1 Dir (Out)
    #17 Charge Pump 7 IOPort StepGen 4 Step (Out)
    # 5 Z Step 8 IOPort StepGen 2 Step (Out)
    # 6 Z Dir 9 IOPort StepGen 2 Dir (Out)
    # 7 A Step 10 IOPort StepGen 3 Step (Out)
    # 8 A Dir 11 IOPort StepGen 3 Dir (Out)
    # 9 Flood Relay 12 IOPort None
    #10 E-Stop In 13 IOPort None
    #11 All Limit Sw 14 IOPort None
    #12 ?spindle home 15 IOPort None
    #13 Timing/Touch pl 16 IOPort None

    If it doesnt output something with the same pin config, specifically the PWMgen part, you likely dont have a flash that worked.


    Scott...

    Last edited by sagreen; 12-07-2017 at 07:29 PM.
    Instructional Videos for CNC Guitar Building
    http://www.rmgvideos.com


  7. #55
    Registered
    Join Date
    Feb 2008
    Location
    USA
    Posts
    511
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    You do need to power cycle (or use the mesaflash --reload option)
    before the FPGA will reload itself from the flash memory



  8. #56
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    So, just a quick update. starting the operator login script from the command line gave me something to chase. Here is the error message:

    postgui_tormach_mill.hal:6: Pin 'zbotatc.config-number' does not exist
    Error: something failed running halcmd on 'postgui_tormach_mill.hal'
    Shutting down and cleaning up LinuxCNC...


    Not exactly sure where to go from here. I'm going to keep digging but if anyone has any ideas, let me know.

    Jason --CNC Newbie--


  9. #57
    Registered
    Join Date
    Mar 2009
    Location
    USA
    Posts
    303
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by WTFover View Post
    So, just a quick update. starting the operator login script from the command line gave me something to chase. Here is the error message:

    postgui_tormach_mill.hal:6: Pin 'zbotatc.config-number' does not exist
    Error: something failed running halcmd on 'postgui_tormach_mill.hal'
    Shutting down and cleaning up LinuxCNC...


    Not exactly sure where to go from here. I'm going to keep digging but if anyone has any ideas, let me know.
    That is getting some where. That is saying that there is an error on line 6 of 'postgui_tormach_mill.hal'. That file is in the same directory as the config files if I recall.

    I'm going to take a wild guess and say that you are using a newer version of PathPilot and the postgui_tormach_mill.hal is looking for a variable that doesnt exist in the files that you got from me. i.e. tormach added this to the config between our versions. Pretty easy to fix, you just have to track down where that is set in the original distribution files and copy it over to where it may need to be in the files you got from my install.

    Make sense?

    Scott...

    Instructional Videos for CNC Guitar Building
    http://www.rmgvideos.com


  10. #58
    Registered
    Join Date
    Aug 2007
    Location
    usa
    Posts
    689
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by sagreen View Post
    That is getting some where. That is saying that there is an error on line 6 of 'postgui_tormach_mill.hal'. That file is in the same directory as the config files if I recall.

    I'm going to take a wild guess and say that you are using a newer version of PathPilot and the postgui_tormach_mill.hal is looking for a variable that doesnt exist in the files that you got from me. i.e. tormach added this to the config between our versions. Pretty easy to fix, you just have to track down where that is set in the original distribution files and copy it over to where it may need to be in the files you got from my install.

    Make sense?

    Scott...
    I would just comment it out - that’s for the tormach/zenbot ATC so it really isn’t even necessary on the novakon



  11. #59
    Registered
    Join Date
    Aug 2016
    Location
    United States
    Posts
    45
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    Quote Originally Posted by sagreen View Post
    That is getting some where. That is saying that there is an error on line 6 of 'postgui_tormach_mill.hal'. That file is in the same directory as the config files if I recall.

    I'm going to take a wild guess and say that you are using a newer version of PathPilot and the postgui_tormach_mill.hal is looking for a variable that doesnt exist in the files that you got from me. i.e. tormach added this to the config between our versions. Pretty easy to fix, you just have to track down where that is set in the original distribution files and copy it over to where it may need to be in the files you got from my install.

    Make sense?

    Scott...
    So for Posterity's sake, and to save someone else some grief along the way: I initially had attempted this on 1.9.3 which is pretty old, but that is what was on the iso they sent me. It was too old in fact, as I was commenting out lines in the postgui hal it would complain about a module missing in rtlib. So I figured the version that you were on was somewhere higher than that, but not the latest, so I did the upgrade to 1.9.12 and started there. After the upgrade, the new module that was absent previously did appear so I started commenting out lines in the postgui hal file. I can now successfully boot in to PP, after commenting the following lines below. Overall the 4 things it appears to be complaining about are the tool changer, digital height gauge, USBIO and Smart Cool. Does anyone see anything important in the list below that I need to put back or work on sorting, otherwise it seems to be working now. I am going to go reinstall in the mill later today and see how it behaves. Thanks to everyone for all the help!!!

    Edit: I also just did the update from 1.9.12 to 1.9.13 and applied the same fixes to the postgui hal file with complete success.

    #net config zbotatc.config-number
    #net config zbotschnozz.config-number


    # digital height gauge
    #net thg-net-height tormachheightgauge.net-height => tormach.hg-height
    #net thg-zero-offset tormachheightgauge.zero-offset => tormach.hg-zero-offset
    #net thg-button-pressed tormachheightgauge.button-pressed => tormach.hg-button-pressed
    #net thg-button-changed tormachheightgauge.button-changed => tormach.hg-button-changed
    #net thg-mm-mode tormachheightgauge.mm-mode => tormach.hg-mm-mode
    #net thg-set-zero-offset tormachheightgauge.set-zero-offset => tormach.hg-set-zero-offset
    #net thg-present tormachheightgauge.present => tormach.hg-present
    #net thg-debug tormachheightgauge.debug => tormach.hg-debug
    #net thg-enable tormachheightgauge.enable => tormach.hg-enable
    #net thg-has-zero-button tormachheightgauge.has-zero-button => tormach.hg-has-zero-button


    # Z-Bot ATC Pins to motion contoller DIO , AIO stuff


    #command and control
    #net atc-request-ngc motion.analog-out-04 => zbotatc.0.ain.0.request
    #net atc-data-ngc motion.analog-out-05 => zbotatc.0.ain.1.request_data


    #net atc-status motion.digital-in-16 <= zbotatc.0.dout.5.exec_status
    #net atc-status tormach.atc-hal-busy <= zbotatc.0.dout.5.exec_status




    #net atc-retcode motion.analog-in-05 <= zbotatc.0.aout.0.request_rc
    #net atc-retcode tormach.atc-hal-return <= zbotatc.0.aout.0.request_rc


    #hardware status variables
    #net atc_tray-in motion.digital-in-17 <= zbotatc.0.dout.0.tray_status
    #net atc_tray-in tormach.atc-tray-status <= zbotatc.0.dout.0.tray_status


    #net atc-vfd motion.digital-in-18 <= zbotatc.0.dout.1.vfd_status
    #net atc-vfd tormach.atc-vfd-status <= zbotatc.0.dout.1.vfd_status


    #net atc-draw-bar motion.digital-in-19 <= zbotatc.0.dout.2.draw_status
    #net atc-draw-bar tormach.atc-draw-status <= zbotatc.0.dout.2.draw_status


    #net atc-pressure motion.digital-in-20 <= zbotatc.0.dout.3.pressure_status
    #net atc-pressure tormach.atc-pressure-status <= zbotatc.0.dout.3.pressure_status


    #net atc-slot motion.analog-in-06 <= zbotatc.0.aout.1.tray_position
    #net atc-slot tormach.atc-tray-position <= zbotatc.0.aout.1.tray_position
    #net atc-tray-tools tormach.atc-tools-in-tray <= zbotatc.atc-tools-in-tray
    #net atc-vfd-rpm zbotatc.vfd-rpm




    #hardware status variables
    #net atc-device motion.digital-in-21 <= zbotatc.0.dout.4.device_status
    #net atc-device tormach.atc-device-status <= zbotatc.0.dout.4.device_status






    #net atc-loop-back zbotatc.0.aout.2.request_ack => motion.analog-in-07


    # USBIO
    #net usbio-enabled tormach.usbio-enabled => usbio.enabled
    #net dig-out-0 tormach.usbio-output-0
    #net dig-out-1 tormach.usbio-output-1
    #net dig-out-2 tormach.usbio-output-2
    #net dig-out-3 tormach.usbio-output-3


    #net dig-in-0 tormach.usbio-input-0
    #net dig-in-1 tormach.usbio-input-1
    #net dig-in-2 tormach.usbio-input-2
    #net dig-in-3 tormach.usbio-input-3


    #Smart Cool keyboard override pins
    #net sc_override tormach.smart-cool-man-auto => zbotschnozz.man-auto
    #net sc_up tormach.smart-cool-up => zbotschnozz.cool-up
    #net sc_down tormach.smart-cool-down => zbotschnozz.cool-down

    Last edited by WTFover; 12-08-2017 at 02:43 PM.
    Jason --CNC Newbie--


  12. #60
    Registered
    Join Date
    Aug 2007
    Location
    usa
    Posts
    689
    Downloads
    0
    Uploads
    0

    Default Re: PathPilot on Novakon Torus Pro

    No just comment those out - you can always come back to them once you get things running.



Page 5 of 7 FirstFirst ... 234567 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

PathPilot on Novakon Torus Pro

PathPilot on Novakon Torus Pro