Stepper motor problems

Results 1 to 4 of 4

Thread: Stepper motor problems

  1. #1

    Default Stepper motor problems

    I too have jumped into the Clough42 ELS upgrade. This will be for my Central Machinery 8x12 lathe. It is my first foray into stepper motors. After problem upon problem, a taste of which I'll list below, I got the development board, control board, and encoder (2000 p/r) working. But the motor will not turn. Now this could be a programming or dip switch on the driver error on my part but while troubleshooting I found the extension cables of my stepper motor are wired differently than the instructions from the seller show. I have seen this same motor/driver combo on youtube wired as shown in the instructions so I assume that mine is just bad. But that would mean both the power and the encoder extensions are wired wrong. And with everything I've had issues with I'm not sure if this is really a bad wiring job, me making a mistake there or somewhere else, or a bit of both.

    I am using a Stepperonline CL57Y driver with a 24HE40-5004D-E1000 closed loop motor. The set up comes with two extension cables. One is a 4-pin to bare wire and the other is a 15-pin serial plug (with only 6 wire in it) to bare wire. These let you plug the motor into the driver. I think the 4-pin power extension is wired exactly backwards, but that is not an issue since I can just plug the bare wire end of the cable into the driver in a different order. But the encoder (a 1000 p/r on the closed loop stepper) extension is a 15-pin serial plug that only has 6 wires. I can not just re-wire the plug as some of the pins I need have no connected wires. The directions show pins 1,2,3,11,12,13 used but instead pins 3,4,5,13,14,15 are used.

    Before I go and try and make a serial extension cord it there a way to tell what pins on the encoder cord coming from the motor are being used? If I find that 1,2,3,11,12, and 13 are being used then I know the extension is wrong and if it is wired right then it is something else that is the issue.
    Also, is there a way to tell if the power wiring to the motor is backwards or if it is just the extension cable?

    I have tried running the motor without the motor's encoder plugged in but it did not run (other than to twitch very slightly when I turned on the power). The thing is, I have had so many issues, at this point I don't know if it is something I did, bad wiring from the manufacturer (twice), or a combination of them.

    On another note, how can you tell what the pulses per revolution to set the driver to and the steps and micro steps for the program? The motor I have has a step angle of 1.8 degrees, which I assume means 200 steps per revolution. I also am assuming that there are 8 micro steps per step but that is a complete guess on my part as I can not find that anywhere (or even if it has any). So set the driver to 1600 and the program to 8/200?

    So, for your entertainment, some issues I've had (admittedly many are my own fault):
    TI CCS 9.1 and 9.2 cannot see the development board even though my computer can. Still don't know what the issue is. Nothing wrong that I can tell. But It works on another computer I have so.....
    I broke a connection in the display board when changing out the pins. Took a long while to discover what was wrong. I soldered a jumper from the pad to a trace and it woks fine now.
    General 'labels not matching what other people have used or even between plugs'. So I'm not sure if I'm plugging the correct thing into the correct thing. Such as the driver has MF- instead of the EN- on clough42's board. The encoder has OUTA/OUTB/OUTZ instead of the 1A/1B/1I on the development board. Etc. It makes me second guess everything. Is it really a problem or do I just not know enough that X=Y in this case.
    One of the jumper wires I was using to test stuff out was broken internally.
    Stupidly had my multi meter in AC instead of DC once. Figured that one out fairly fast. Was just glad no one was around to notice.

    Similar Threads:

  2. #2

    Default Re: Stepper motor problems

    Never mind. I had to enable 'reverse enable pin' in the software, reverse a signal wire I had mixed up at some point, and my tired mind didn't notice that the pin out is for the motor, not the extensions, which would naturally be mirrored when looking end on.
    Sigh. Well, I figured it out. It works now.

  3. #3
    Member Algirdas's Avatar
    Join Date
    Mar 2009
    United Arab Emirates

    Default Re: Stepper motor problems

    on the other hand, you do good using encoder despite the stepper motor is used there.
    Do you expect to follow the positioning error?

  4. #4

    Default Re: Stepper motor problems

    I'm not sure I understand your question. Are you asking if the encoder and stepper motor will get out of sync?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts


    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on

Our Brands

Stepper motor problems

Stepper motor problems

Stepper motor problems