Need Help! A corrupt Centurion 5 hard drive?

Results 1 to 2 of 2

Thread: A corrupt Centurion 5 hard drive?

  1. #1

    Default A corrupt Centurion 5 hard drive?

    I recently bought an old Milltronics VM-16 A with a Centurion 5 controller. It had a bad x axis motor, so I decided to swap out the old dc motor for a somewhat newer Yaskawa SGDM 3 phase servo motor. I got everything mostly hooked up, but the servo motor just spins. It seems that when the machine is in estop, the X drive analog output from the computer is at 12 volts making the servo run at full speed. Not only does this seem odd to me, but it's driving me nuts since I can't debug the new servo motor.

    So my question is, is this normal? I am also having some odd problems with the HMI. I disabled x homing as to help debug various problems. After successfully homing Z and Y (ignoring X) I can jog in one direction once. After the first jog, or jogging in the wrong direction, jogging does nothing. Handwheel page also doesn't work. This seems to me symptoms of a corrupt hard drive. And I am wondering if this is a part of the 12 volts e stop issue.
    Is it possible to obtain the centurion 5 OS/program to install a new hard drive? Is my axis card bad? Am I just missing something?

    Similar Threads:


  2. #2

    Default Re: A corrupt Centurion 5 hard drive?

    Update: So I got the new servo motor working after flipping*analog signal*polarity. I tried both directions in the drivers firmware so I don't know why that worked. But it did. It seems like it was going*to 12 volts in an attempt to reverse the direction*of the servo. It goes into estop and just doesn't*update the analog output. Dumb, but probably*normal.

    What isn't normal is the jogging issue. Still can't*jog normally, can't use the handwheel, and I can't even give it G codes to move any of the axis. Though, I have been bale to get the spindle going. I also tried to perform a tool change and nothing*happened. I am new to cnc, so I may be messing up some of the gcode, but I should still be able to jog. I'm pretty good with computers and my gut is telling*me that it's bit rot.

    Which brings me back to wondering if there is a way to obtain*a fresh copy of the software.*Or am I being an idiot. We can never rule that one out!



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

A corrupt Centurion 5 hard drive?

A corrupt Centurion 5 hard drive?

A corrupt Centurion 5 hard drive?