Just In Folger Tech Cloner 3D Printer Kit - Assembly required


Results 1 to 2 of 2

Thread: Folger Tech Cloner 3D Printer Kit - Assembly required

  1. #1
    Registered josephfrancis's Avatar
    Join Date
    Jan 2014
    Location
    bangalore
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default Folger Tech Cloner 3D Printer Kit - Assembly required

    Folger Tech Cloner 3D Printer Kit - Assembly required

    Folger Tech Cloner 3D Printer Kit - Assembly required-1-jpg

    Highlighted features:

    Impressive 230mmx150mmx120mm Build Area.
    Able to print ABS, PLA, Wood, HIPS, PETG and PVA (1.75mm).
    Layer Resolution of 50 microns.
    Print Speed of 60 to 160 mm/sec
    Supports SD card for offline printing. Print without PC.
    Oak or Melamine Chassis.
    Can run 110V or 220V (Only Comes With US Cord).
    Packed And Shipped from the USA.

    https://www.3dprintersonlinestore.co...3d-printer-kit

    Similar Threads:


  2. #2
    Member
    Join Date
    Apr 2019
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Re: Folger Tech Cloner 3D Printer Kit - Assembly required

    You sell Folger Tech? Why? I've had the worst experience with their tech support. They actually want me to pay them to even talk to me. All I wanted was to BUY some parts for a machine they make. No help what-so-ever. I will never buy anything they make again, nor will I shop at a company that sells their products. You can tell them they are costing you some sales because of their greed.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Folger Tech Cloner 3D Printer Kit - Assembly required

Folger Tech Cloner 3D Printer Kit - Assembly required

Folger Tech Cloner 3D Printer Kit - Assembly required