Hello all,

I am new to programming using multiple work offsets. The job I am programming is using g54 - g59, 3 parts per vise, and I have attached a sample. The machinist told me each part has been indicated in and registered under the correct offset. When the program runs it locates the first part in each vise G54 and G57, but when it moves to the other offsets it is no where near where it should be.

The machine is a Haas VF3 and I am programming with mastercam.

Thanks in advance for any help!

G20
G0 G17 G40 G49 G80 G90
(1/8 SPOTTING DRILL AND CHAMFER)
T6 M6
G187 P3 E.001
G0 G90 G54 X-.5483 Y.056 S2139 M3
G43 H6 Z.25
G99 G81 Z-.045 R.25 F1.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
(1/8 SPOTTING DRILL AND CHAMFER)
G55 X-.5483 Y.056 Z.25
G99 G81 Z-.045 R.25 F1.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
(1/8 SPOTTING DRILL AND CHAMFER)
G56 X-.5483 Y.056 Z.25
G99 G81 Z-.045 R.25 F1.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
M5
G91 G28 Z0.
M01
(1/16 DRILL)
T1 M6
G187 P3 E.001
G0 G90 G54 X-.5483 Y.056 S4278 M3
G43 H1 Z.1
M8
G99 G83 Z-.1969 R.1 Q.05 F4.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
(1/16 DRILL)
G55 X-.5483 Y.056 Z.1
G99 G83 Z-.1969 R.1 Q.05 F4.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
(1/16 DRILL)
G56 X-.5483 Y.056 Z.1
G99 G83 Z-.1969 R.1 Q.05 F4.
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
M5
G91 G28 Z0. M9
M01
(M2X.4 TAP)
T7 M6
G187 P3 E.001
G0 G90 G54 X-.5483 Y.056 S100 M3
G43 H7 Z.25
G99 G84 Z-.197 R.25 F1.5748
X-.1884 Y-.518
X.5428 Y-.0959
X.2256 Y.5029
G80
M5
G91 G28 Z0.
M01
(#60 DRILL)
T2 M6
G187 P3 E.001
G0 G90 G54 X-.3319 Y-.3871 S6750 M3
G43 H2 Z.1
M8
G99 G83 Z-.1969 R.1 Q.04 F6.5
X.5012 Y.0939
G80
(#60 DRILL)
X-.3319 Y-.3871
G99 G83 Z-.1969 R.1 Q.04 F6.5
X.5012 Y.0939
G80
(#60 DRILL)
G55 X-.3319 Y-.3871 Z.1
G99 G83 Z-.1969 R.1 Q.04 F6.5
X.5012 Y.0939
G80
(#60 DRILL)
G56 X-.3319 Y-.3871 Z.1
G99 G83 Z-.1969 R.1 Q.04 F6.5
X.5012 Y.0939
G80
M5
G91 G28 Z0. M9
M01

Similar Threads: