Cut quality problem - Page 3


Page 3 of 3 FirstFirst 123
Results 25 to 31 of 31

Thread: Cut quality problem

  1. #25
    Member Mecanix's Avatar
    Join Date
    Aug 2019
    Posts
    277
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    Quote Originally Posted by williamsmotower View Post
    I'd love to try code by another cam package that uses g2/g3.

    This Madcam forum has been slow. Is Madcam still going strong with new coding and updates, or should I look elsewhere?

    This is my first CAM package, and I really like how I've adapted to using it. I really don't want to change

    Unfortunately a CAM package unable to convert linear motions to arc via software isn't exactly an ideal package you'd want to use for end-machining. Unless of course you have the capacity to do it via hardware (e.g. industrial control, linear to nurbs/splines). In my case I only use linear motions with relevant tolerances and have the control do its thing (Siemens' cycle832). For M3 however (which I also use, mind you), its a whole different story; linear-to-arc conversion via software (CAM) is mandatory.

    Quite a few hacked their postprocessor's logic with the equivalent maths to essentially achieve the same conversion of what Industrial controllers does, although I wouldn't launch into this if you aren't an advanced programmer i.e. by the time you'll be done with the research, dev and debugging, your hourly-rate may well exceed twice the price of what it cost to simply procure a CAM package that fits within those limitations of M3.

    Hope someone more familiar with your current package will chime in soon. Who knows, someone may have a quick solution for you. Also worth emailing corporate and asking them also... pretty sure they had to deal with this before and know of a solution for you.

    G'luck friend



  2. #26
    Member
    Join Date
    May 2006
    Location
    usa
    Posts
    313
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    Thank you for your help!

    Yes, hopefully someone more familiar with this situation chimes in



  3. #27
    Member Mecanix's Avatar
    Join Date
    Aug 2019
    Posts
    277
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    Workaround is like you've identified already; overkilling the total number of points on those curves you are trying to finish. Although not the best way, I can see models loading and panning quite slowly, cpu fan screaming and weighting 1gig in data, kinda thing. Anyway. Sure you'll find a way. Let us know what was the ultimate solution when you find it.

    tc



  4. #28
    michael_lu's Avatar
    Join Date
    Sep 2019
    Location
    JINAN
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default

    Can you provide a video reference, maybe I can help you

    Supply Forever Global Industry Co., Ltd.:https://www.supplyforever.com/


  5. #29
    Member
    Join Date
    May 2006
    Location
    usa
    Posts
    313
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by michael_lu View Post
    Can you provide a video reference, maybe I can help you
    I could, but I assure you the axis are running very smoothly. It's definitely just trying to cut small lines instead of smooth arcs.

    I emailed Joakim from Madcam. No reply, is he still going strong with Madcam?



  6. #30
    Member
    Join Date
    Jan 2018
    Location
    United Kingdom
    Posts
    315
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    Just of interest. What spec PC have you got running the machine?
    I have had past problems using 3D code with say 30,000 lines in Mach3 with a previous PC.

    What I was getting was a constant stop/start routine every time it turned any corners/arcs.
    I'm assuming my PC processing wasn't up to it.

    I do still get 1 issue with the newer 1.
    If I send a CAM file over to my machine PC and put it in the same folder as a CAM file the machine is currently running. I get the start/stop behaviour back again.



  7. #31
    Member
    Join Date
    May 2006
    Location
    usa
    Posts
    313
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    I'd have to look at PC specs. I'm pretty sure it's decent. Plus, I'm using ESS smoothstepper. They have settings for how much data to transfer per second and I have it set to max.



  8. #32
    Member
    Join Date
    May 2006
    Location
    usa
    Posts
    313
    Downloads
    0
    Uploads
    0

    Default Re: Cut quality problem

    Update Madcam does support g2/g3.

    I received a post from Madcam. Hopefully I can figure out how to implement it



Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Cut quality problem

Cut quality problem

Cut quality problem