Mach 3 Homing the wrong way


Results 1 to 3 of 3

Thread: Mach 3 Homing the wrong way

  1. #1
    Member
    Join Date
    Feb 2013
    Location
    uk
    Posts
    60
    Downloads
    0
    Uploads
    0

    Default Mach 3 Homing the wrong way

    Hi,
    I'm just refurbing an earlier build and upgraded to proximity switches, using the existing Gecko 540 and 4 x Nema 24’s.
    I put four NPN proximity switches on it, 2 on the Y, one of the X and one on the Z. When I press Ref All Its homing to the top on the z fine but then heads off up the Y away from the front. I want to reference/home front left standing at the machine. Here’s a couple of screen shots. I ticked and unticked a combination of both these screen but it to no avail. Am I just looking in the wrong place
    Mach 3 Homing the wrong way-screen-1-jpgMach 3 Homing the wrong way-screen-2-jpg? Mach 3 Homing the wrong way-cncz-jpg

    Similar Threads:


  2. #2
    Member CitizenOfDreams's Avatar
    Join Date
    Nov 2012
    Location
    USA
    Posts
    845
    Downloads
    4
    Uploads
    0

    Default Re: Mach 3 Homing the wrong way

    The menu shown in your screenshot controls the general direction of movement. Set it so that the machine moves correctly when you press up/down/left/right/PgUp/PgDown keys.

    Homing is set up in Config - Homing/Limits menu. There is a tick mark labeled "Home Negative".

    P. S. Also, your pin numbers don't seem to be set correctly.

    You said you have 1 switch on the X axis - then why do you have both X++ and X-- set in the menu? Same goes for the Z axis.

    On the Y axis, do you have one switch on each side of the portal? Why are they both wired to the same pin? That could make automatic squaring of the portal a bit problematic. Also, same problem with Y++ and Y--. You really have home switches, not limit switches, so it would be best not to use X++, X--, Y++, Y--, Z++ and Z-- at all.



  3. #3
    Member
    Join Date
    Feb 2013
    Location
    uk
    Posts
    60
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 Homing the wrong way

    Quote Originally Posted by CitizenOfDreams View Post
    The menu shown in your screenshot controls the general direction of movement. Set it so that the machine moves correctly when you press up/down/left/right/PgUp/PgDown keys.

    Homing is set up in Config - Homing/Limits menu. There is a tick mark labeled "Home Negative".

    P. S. Also, your pin numbers don't seem to be set correctly.

    You said you have 1 switch on the X axis - then why do you have both X++ and X-- set in the menu? Same goes for the Z axis.

    On the Y axis, do you have one switch on each side of the portal? Why are they both wired to the same pin? That could make automatic squaring of the portal a bit problematic. Also, same problem with Y++ and Y--. You really have home switches, not limit switches, so it would be best not to use X++, X--, Y++, Y--, Z++ and Z-- at all.
    Thanks. Very good andswers and questions. I had totally forgotten about the Homing/Limits menu, dhoh!. This is a sign that working at low temperatures does not always make for rational descision making at the end of the day ha. I have motor on Y axis and slave the A xis to it, giving two motors on the Y. Your right i'll uncheck lots of these switches. Thanks!



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Mach 3 Homing the wrong way

Mach 3 Homing the wrong way

Mach 3 Homing the wrong way