Need Help! 4th Axis working, but very jerky


Results 1 to 5 of 5

Thread: 4th Axis working, but very jerky

  1. #1
    Member
    Join Date
    Jun 2016
    Location
    United States
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default 4th Axis working, but very jerky

    I've been reading and attempting everything I have found. My 4th axis is working surprisingly well, but its very jerky. I'm using fusion 360 with usb smoothstepper and have tried various smoothing settings, slower feed rates and it all yields the same results. Theres a video below with some sample code.

    I see lots of people with harmonic drive 4th axis and mach3 and they all seem so smooth. The pausing is adding a decent amount of machining time and leaving marks on my finish. Does anyone have any ideas what's causing the jerkiness/stuttering?



    Code:
    Z0.6334 A-6.574 F2836.3323Z0.6395 A-9.401 F2653.4703
    Z0.642 A-10.341 F7665.2579
    Z0.6468 A-12.217 F3861.3871
    Z0.6488 A-13.152 F7937.2541
    Z0.6507 A-14.087 F7996.3277
    Z0.6523 A-15.02 F8146.2995
    Z0.6538 A-15.953 F8273.91
    Z0.6551 A-16.884 F8360.7096
    Z0.657 A-18.745 F4297.0773
    Z0.6582 A-20.603 F4442.1249
    Z0.6585 A-21.531 F9124.6597
    Z0.6584 A-23.387 F4677.8014
    Z0.6582 A-24.315 F9147.9255
    Z0.657 A-26.171 F4444.8371
    Z0.655 A-28.029 F4297.6506
    Z0.6537 A-28.958 F8398.9712
    Z0.6522 A-29.888 F8277.2542
    Z0.6506 A-30.818 F8155.041
    Z0.6487 A-31.75 F8035.2122
    Z0.6467 A-32.682 F7924.6533
    Z0.6445 A-33.616 F7856.4056
    Z0.642 A-34.55 F7700.0207


    Similar Threads:


  2. #2
    Member Algirdas's Avatar
    Join Date
    Mar 2009
    Location
    United Arab Emirates
    Posts
    1481
    Downloads
    0
    Uploads
    0

    Default Re: 4th Axis working, but very jerky

    Try this code:
    G00 A000 Z250
    G01 A180 F12




  3. #3
    Community Moderator Jim Dawson's Avatar
    Join Date
    Dec 2013
    Posts
    4880
    Downloads
    0
    Uploads
    0

    Default Re: 4th Axis working, but very jerky

    Take a look at the feed speeds in the G code, they are all over the map. Every line has a different speed. The action in the video looks like it is following the G code commanded speed.

    Jim Dawson
    Sandy, Oregon, USA


  4. #4
    Member
    Join Date
    Jan 2018
    Location
    United Kingdom
    Posts
    703
    Downloads
    0
    Uploads
    0

    Default Re: 4th Axis working, but very jerky

    Quote Originally Posted by Jim Dawson View Post
    Take a look at the feed speeds in the G code, they are all over the map. Every line has a different speed. The action in the video looks like it is following the G code commanded speed.
    Looks like Jim is the winner!
    Wow. I wonder how that happened?.

    Need to figure out how to stop that happening, wouldn't fancy having to edit every line of code to delete the F rates!
    Must be something in Fusion. Different feedrates for smoothing, roughing, finishing, plunging, cornering etc must have been set.



  5. #5
    Member
    Join Date
    Jun 2016
    Location
    United States
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: 4th Axis working, but very jerky

    Quote Originally Posted by dazp1976 View Post
    Looks like Jim is the winner!
    Wow. I wonder how that happened?.

    Need to figure out how to stop that happening, wouldn't fancy having to edit every line of code to delete the F rates!
    Must be something in Fusion. Different feedrates for smoothing, roughing, finishing, plunging, cornering etc must have been set.
    I should have mentioned that fusion is using the inverse time mode for this moves.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

4th Axis working, but very jerky

4th Axis working, but very jerky

4th Axis working, but very jerky