Need Help! Help G41 doesn't work for multiple offsets! - Page 3


Page 3 of 3 FirstFirst 123
Results 25 to 31 of 31

Thread: Help G41 doesn't work for multiple offsets!

  1. #25
    Member BehemothDT's Avatar
    Join Date
    Mar 2014
    Posts
    35
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    Quote Originally Posted by metalmayhem View Post
    Attachment 426828

    this is what I'm getting in mach 3
    Did you input the tool diameter 1.25" in the tool table for #120?

    If diameter is set at 0.0" mine looks like yours.

    Sent from my SAMSUNG-SM-G891A using Tapatalk



  2. #26
    Member metalmayhem's Avatar
    Join Date
    Jun 2018
    Location
    on my feet
    Posts
    130
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    i was playing around with it and I see what you mean . I put 1.25 in the wear earlier , when I put it in diameter then it's pretty whacked out



  3. #27
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10309
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    Quote Originally Posted by metalmayhem View Post
    i was playing around with it and I see what you mean . I put 1.25 in the wear earlier , when I put it in diameter then it's pretty whacked out
    You would never put 1.25 in the wear dia that would mean the tool diameter would be 2.5 dia

    D the tool diameter=1.250 tool wear is only how much you want to add so if you added 0.010 this would add 0.010 to the diameter of the tool

    Mactec54


  4. #28
    Member metalmayhem's Avatar
    Join Date
    Jun 2018
    Location
    on my feet
    Posts
    130
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    Quote Originally Posted by mactec54 View Post
    You would never put 1.25 in the wear dia that would mean the tool diameter would be 2.5 dia

    D the tool diameter=1.250 tool wear is only how much you want to add so if you added 0.010 this would add 0.010 to the diameter of the tool

    tell me something I don't know
    I'm just trying to repeat what was suggested and I happened to put the suggested value in wear rather than diameter



  5. #29
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    Shelby Township
    Posts
    34533
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    The Wear offset column in Mach3 doesn't do anything at all.

    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  6. #30
    Member metalmayhem's Avatar
    Join Date
    Jun 2018
    Location
    on my feet
    Posts
    130
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    I played around some and chopping up the code into sub routines for the finish paths resolves the problem on multiple work offsets



  7. #31
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10309
    Downloads
    0
    Uploads
    0

    Default Re: Help G41 doesn't work for multiple offsets!

    Quote Originally Posted by ger21 View Post
    The Wear offset column in Mach3 doesn't do anything at all.
    I don't know if it works or not I never use the wear offset

    But I do use a P value in the code and it work just fine

    Just did this for kicks and giggles these are just straight lines, and it works as programed what ever the P value is it will offset the tool by that amount

    %
    G90 G17 G40 G80
    G21
    G54
    G0Z1.
    G0 X0 Y0.
    S1000 M3
    G1 G41 P0.05 Y.5 F25.
    X1.5
    Y.6
    X2.0
    G40 Y1.25
    M5
    M30
    %

    Mactec54


Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Help G41 doesn't work for multiple offsets!

Help G41 doesn't work for multiple offsets!

Help G41 doesn't work for multiple offsets!