Mach4 Need rev 4612


Results 1 to 9 of 9

Thread: Mach4 Need rev 4612

  1. #1
    Member
    Join Date
    Jun 2007
    Location
    USA
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default Mach4 Need rev 4612

    I am really surprised by Mach4 support.
    I am having an interaction /communication problem between Mach4 and the ESS. It randomly locks up and I have to restart Mach4.
    Mach4 support recommend using the version of Mach4 that is suggested by Warp9's ESS smooth steeper. That makes sense.
    Recommended is the .4612 version.

    Going to Mach4 support, the only version available is .5000 which Tec support stated is "broken and updated".
    If updated, it ought to be a different release version.

    Also tec support stated that no older versions of Mach4 were available.
    I have never seen a software company that not carefully keeps previous versions archived.
    Usually Mach tech support is excellent so I do not know what happened.
    That brings back the question: Where can I download the .4612 version?
    Bertho

    Similar Threads:


  2. #2
    Member
    Join Date
    Nov 2013
    Posts
    4666
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    Hi,
    I use 4612 and have done for quite a while, maybe as long as a year. It is still available on the New Fangled Solution FTP server.

    Mach4Hobby build 5000 has certain sections of code that now run blazing fast, much faster than they did in prior builds. As a consequence many
    of the motion board plugins were undone by thta extra speed. The ESS was amongst them . What was happening is the fast code set up a 'race condition'.

    Many of the motion board manufacturers have had to update/rework their plugins. I cannot say where Warp9TD (ESS manufacturer) is in that process.

    Craig

    Attached Thumbnails Attached Thumbnails Mach4  Need rev 4612-nfspage-jpg   Mach4  Need rev 4612-nfsftppage-jpg   Mach4  Need rev 4612-ftppage-jpg  


  3. #3
    Member
    Join Date
    Jun 2007
    Location
    USA
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    Thank you Craig for a detailed reply with explanations.
    I missed the FTP server, I kept going directly to the Mach4 section. I am surprised tech support did not point it out when I asked.
    Unfortunately, I am still out of luck: the first version available is 4162, the next one is 4902..
    Bertho



  4. #4
    Member
    Join Date
    Nov 2013
    Posts
    4666
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    Hi,
    I think any build prior to 5000 will be adequate.

    In most cases Mach changes very little between builds. I hold to the idea that if I have a build which is working well for me; then why bother updating?
    I found about a year ago my machine was still running a 38xx?? build and had been for three years. I did update to 4612, and I've been using it ever since,
    maybe a year or so. Unless there is something you need or want in the latest build then don't bother. In most cases its seamless but it can and does screw
    up sometimes to.

    I have machining work to do...keeping up with the latest build of mach does not help me get it done.

    Craig



  5. #5
    Member
    Join Date
    Nov 2013
    Posts
    4666
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    HI,
    I still have a copy of 4612, but its 100MB, not quite sure how to post it. Maybe send me a PM and I can send it as an email???

    Craig



  6. #6
    Member
    Join Date
    Jun 2007
    Location
    USA
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    Thanks!!
    I have a method for transfer but lets wait a little bit. I sent in a support request to Warp(td to see which version they currently suggest for Mach4..
    I have recently switched from Mach3 to 4. The Mach4 .5000 works fine with the same ESS driving my laser. I am using the same hardware, just moving the ESS outputs between the two machines.
    Bertho



  7. #7
    Member
    Join Date
    Jun 2007
    Location
    USA
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    I finally found out the current recommended versions:
    ESS: v285
    Mach4: .4809

    That brings me back to the same point. The Mach4 FTP server does not have the 4809 either
    So now I am hunting for the 4809 versio9.



  8. #8
    Member
    Join Date
    Jun 2010
    Location
    us
    Posts
    27
    Downloads
    4
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    there is a link on the Warp9 website for both recommended Mach4 and ESS;
    https://www.warp9td.com/index.php/ge...nstallMachFour



  9. #9
    Member
    Join Date
    Jun 2007
    Location
    USA
    Posts
    47
    Downloads
    0
    Uploads
    0

    Default Re: Mach4 Need rev 4612

    Thank you so much!
    There is an amazing amount of information on the Warp9 website.
    Unfortunately, I missed those links.
    Thanks again,
    Bertho



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Mach4  Need rev 4612

Mach4  Need rev 4612