data transfer between TNC355 and a computer

Page 1 of 2 12 LastLast
Results 1 to 12 of 14

Thread: data transfer between TNC355 and a computer

  1. #1
    Registered benotto's Avatar
    Join Date
    Dec 2011
    Location
    Frammersbach
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    Hello

    I have the following problem:

    Machine Mirkron WF71
    Controller TNC355
    Computer Windows XP

    I cannot establish a connection with TNCremo. The problem is probably the transmission protocol- that’s how far I got with the help of the forum.
    So now with the TNCServer

    However when I open the TNC server then I can send from the machine to the computer.
    However when I want to get the programs from the computer then it comes to a break off!

    Does anybody have an idea?

    Greetings
    Benotto



  2. #2
    vagabund's Avatar
    Join Date
    Nov 2010
    Location
    Schalksmühle
    Posts
    123
    Downloads
    0
    Uploads
    0

    Default

    Are the Baud rate and the connection type of the computer and the controller equal? If yes, then go down with the Baud rate and make you way upwards.



  3. #3
    Registered benotto's Avatar
    Join Date
    Dec 2011
    Location
    Frammersbach
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    Thank you dir1

    I already played with the Baud rate, now I have set the standard value 9600 again.
    I have also played with the connection type FE and ME, also only send ME and receive ME

    I just don’t know why it continuously breaks off.

    Can I send the program from the TNC Server?



  4. #4
    vagabund's Avatar
    Join Date
    Nov 2010
    Location
    Schalksmühle
    Posts
    123
    Downloads
    0
    Uploads
    0

    Default

    Usually that doesn’t work- but another question: when does the transfer breaks off?
    Maybe our memory is not sufficient for the program?
    I know it from my machine; usually after 5000 signs it’s full



  5. #5
    Registered Parameterfritze's Avatar
    Join Date
    Feb 2012
    Location
    Klingenthal
    Posts
    56
    Downloads
    0
    Uploads
    0

    Default

    Hello Benotto!

    Have a look into the user parameter of the controller if the data transmission EXT is configured.

    You have to use baud rate 2400 with that old controller- and it’s best to use ME send/receive.
    Or maybe the memory is full. You can only save max. 20 programs or 3000 blocks.

    However the TNC should release an error message (NC memory)

    Kind regards



  6. #6
    Registered benotto's Avatar
    Join Date
    Dec 2011
    Location
    Frammersbach
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    The memory is pretty full!
    I have deleted 2 programs that I have saved on the computer and now I tried to send one of them from the computer.

    The result was that it started to send and then after 3 rows the TNC server wrote “break off”. Maybe I am doing something wrong on the machine?!
    I go to receive selected program and then enter the program number that I would like have.



  7. #7
    Registered Parameterfritze's Avatar
    Join Date
    Feb 2012
    Location
    Klingenthal
    Posts
    56
    Downloads
    0
    Uploads
    0

    Default

    Hello Benotto

    Of course, the program name has to be identical with the name behind “Begin PGM...”

    Kind regards



  8. #8
    Registered benotto's Avatar
    Join Date
    Dec 2011
    Location
    Frammersbach
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    I think I got it right; I have named the program 12345. The file is called 12345.h and then I enter 12345



  9. #9
    Registered Parameterfritze's Avatar
    Join Date
    Feb 2012
    Location
    Klingenthal
    Posts
    56
    Downloads
    0
    Uploads
    0

    Default

    How long is the cable between the TNC and the computer? It should not be longer than 8m.

    Kind regards



  10. #10
    Registered Parameterfritze's Avatar
    Join Date
    Feb 2012
    Location
    Klingenthal
    Posts
    56
    Downloads
    0
    Uploads
    0

    Default

    You can also try to use a different interface with the TNC server (COM-Port) but if you are able to receive then it’s pretty unlikely. But sending definitely works with the TNC server.

    Kind regards



  11. #11
    Registered millmen's Avatar
    Join Date
    May 2002
    Location
    finnentrop
    Posts
    157
    Downloads
    0
    Uploads
    0

    Default

    Hello
    I had the same problem a few years ago.
    Have a look at my description to see if the MP222 it set to 168.
    Regards
    Lars

    Heidenhain TNC 155 or rather 355
    Transfer end to ETX
    Row end = ASCII 13+10
    Protocol to XON

    With TNC135 : 100x ASCII=0 as credits, and recognise read-in end with 5 seconds idling.

    From TNC155 : In case the machine doesn’t read-in set parameter 222 = 168
    In PDF section 5.1.2 as described = 7 Datenbit, 1 Stopbit, even Parity, Software-Handshake

    Set operation mode = Over MOD or Machine parameter -> EXT-Mode
    Standardformat, no block by block transmission - Parameter 223 = 0 or rather from 5000

    CPVwin can no FE , ME , LSV/2 Protocol or block by block transmission
    transmission end EOT : Parameter 224 = 4



  12. #12
    Registered Cleaner's Avatar
    Join Date
    Sep 2010
    Location
    Bremen
    Posts
    35
    Downloads
    0
    Uploads
    0

    Default

    Hi

    I do it like this:

    Heckert: Pc to TNC
    1.Start TNC-Remo, 2. In configuration: select "ME Send".
    3.Enter program file.

    4.Then go to the machine and press “EXT" and also read-in selected program” and press Enter. Enter the program number.


    TNC to PC
    1.start TNC-Remo, 2. In configuration: select "ME Send".
    3. Enter program file and press save.
    4. Then go to the machine, press "EXT" and “release selected program”
    and Enter. Enter choose program.
    The program is visible on the computer after pressing F5 (refres)


    Remo basic settings
    Baud rate : 9600 / interface : Com 1 / controller type : TNC355
    FE-settings
    Tick the both of the upper fields
    Folder
    No ticks
    In main window at the right side

    Protocol : LSV-2 / interface : Com 1 /Baud rate(Auto Detect) : 9600


    I have a Heckert with TNC 355

    Program file has to be .H (big).

    Try it out


    Kind regards

    Cleaner



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

data transfer between TNC355 and a computer

data transfer between TNC355 and a computer

data transfer between TNC355 and a computer