Need Help! 2nd Week using HAAS - G52 Problem


Results 1 to 3 of 3

Thread: 2nd Week using HAAS - G52 Problem

  1. #1
    Member BlaznLow's Avatar
    Join Date
    Jan 2020
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default 2nd Week using HAAS - G52 Problem

    Hey everyone,
    I am new to the HAAS world, approx 2 weeks.
    Prior to this, I have been running FANUC for 8 years.

    I am running a part where I am using a helix to create a 2"DIA x 1.5" deep hole.

    On the FANUC, to make sure I am not going to deep, on the work offset page, I could throw in .050" into G52. It would raise my program that amount, I could measure my depth and adjust accordingly.

    On the HAAS, I had centre drill and drilled my hole. I reset my program. I then put .050 into my work offset page in G52. I read the first part of my program, I go to edit, skip down to my endmill. However, when i go to edit, it erase my .050 from G52.

    Why does it keep erasing my .050 from G52? It never did this on a FANUC control.

    Thank you.

    Similar Threads:


  2. #2
    Moderator wms's Avatar
    Join Date
    Mar 2003
    Location
    United States
    Posts
    923
    Downloads
    0
    Uploads
    0

    Default Re: 2nd Week using HAAS - G52 Problem

    You can just add the .050 to your work offset Z value..

    So if you are using say G54, add .05 to the z value in the work offset table.

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  3. #3
    Member BlaznLow's Avatar
    Join Date
    Jan 2020
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by wms View Post
    You can just add the .050 to your work offset Z value..

    So if you are using say G54, add .05 to the z value in the work offset table.
    Which is what I did. But still curious as to why G52 cancels itself



  4. #4
    Member Edl44251's Avatar
    Join Date
    Jan 2020
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default

    You have to change a setting from yasnac to fanuc Haas will tell you setting # for your machine.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

2nd Week using HAAS - G52 Problem

2nd Week using HAAS - G52 Problem

2nd Week using HAAS - G52 Problem