Need Help! Motor X doesn't work the way it should


Results 1 to 10 of 10

Thread: Motor X doesn't work the way it should

  1. #1
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Question Motor X doesn't work the way it should

    Hello everyone,

    I have 50W CO2 Laser Engraving Cutting Machine Engraver Cutter (from China)

    The software I use is thunder Laser
    The controller I have is ruida.

    I have had this laser for less than a year and suddenly X motor doesn't work as it should.

    I have tried to check the setting in vendor but it made no difference (I have 3 more lasers like this so I copied the vendor settings and paste it in this laser machine but it still didn't made any difference) also I have replaced the X motor thinking that it's broken but after I put new motor it had the same problem.

    I have replaced X micro-step drive and mainboard with the new one but it made no difference.

    I change the pc thinking that it might cause the problem but nope :I

    I tried to look for the dirt in X motor path or belt thinking that maybe this is the problem but I couldn't find anything.

    the belt is not loose either so I have no idea what it could be.

    can anyone help me with this problem?

    Pov'

    Similar Threads:


  2. #2
    Member
    Join Date
    Nov 2008
    Location
    USA
    Posts
    527
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    What exactly is the X axis doing?
    Did you try swapping the X and Y axis to see if the problem follows?


    Sent from my iPhone using Tapatalk



  3. #3
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    Quote Originally Posted by Dean448 View Post
    What exactly is the X axis doing?
    Did you try swapping the X and Y axis to see if the problem follows?

    Sent from my iPhone using Tapatalk
    thank you for your messege

    the motor crunching and it doesn't go as smooth as Y axis



  4. #4
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    even when I switch the parts it the problem stay on X and not Y so strange



  5. #5
    Member
    Join Date
    Nov 2008
    Location
    USA
    Posts
    527
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    Here’s my suggestions:
    Run motors off the machine. If they are smooth then problem in slides

    Swap just motor leads. Problem stays then issue not in motor.

    Swap the XY leads from the controller to the motor drives. Problem stays then issue with controller Problem moves then issue with drive.

    Put back to normal between tests.


    Sent from my iPhone using Tapatalk



  6. #6
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    I have tried to take the belt of the motor and press the bottom to see how it mos but it does the same thing.



  7. #7
    Member
    Join Date
    Nov 2008
    Location
    USA
    Posts
    527
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    Ok so you disconnected the belt and it does the same thing. Now swap the X and Y motor connectors. Does the noise go to Y or stay with X?


    Sent from my iPhone using Tapatalk



  8. #8
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    Quote Originally Posted by Dean448 View Post
    Ok so you disconnected the belt and it does the same thing. Now swap the X and Y motor connectors. Does the noise go to Y or stay with X?


    Sent from my iPhone using Tapatalk

    the motor X works the same way as before it made no difference if it been plugged into Y motor controller or no.

    could it be software that creating the problem?



  9. #9
    Member cutncrftdesigns's Avatar
    Join Date
    Mar 2021
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    and motor Y controller with X motor controller works perfect.



  10. #10
    Member
    Join Date
    Nov 2008
    Location
    USA
    Posts
    527
    Downloads
    0
    Uploads
    0

    Default Re: Motor X doesn't work the way it should

    If everything driving problem X is now connected to Y, and the problem is still with X then the problem must be in X motor, or it’s wiring or connector.


    Sent from my iPhone using Tapatalk



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Motor X doesn't work the way it should

Motor X doesn't work the way it should

Motor X doesn't work the way it should