Need Help! Mitsubishi FX20 contact problem


Results 1 to 6 of 6

Thread: Mitsubishi FX20 contact problem

  1. #1
    Registered
    Join Date
    Nov 2016
    Location
    United States
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Mitsubishi FX20 contact problem

    We have 1997 Mitsubishi FX20 wire machine which we inherited about a year ago. It worked fine for a while but since about 5-6 months it started to show a contact with the IP settings of 4 and up. It works fine with smaller power settings. Initially that was happening only once in a while, now it seems to be working correctly only once in a while. I checked pretty much everything for any broken wires, so that is out of question. Beside that it would show the contact constantly not just on higher power settings. Did anybody experience something like that? Any suggestions what could be wrong?

    Thanks,
    Pete

    Similar Threads:


  2. #2
    Member
    Join Date
    Feb 2009
    Location
    United Kingdom
    Posts
    51
    Downloads
    0
    Uploads
    0

    Default Re: Mitsubishi FX20 contact problem

    On top of the generator is a cover covering fans and some load resistors, check the resistance of the 2off 4ohm resistors, they are wired in series so should read approximately 8ohms. Sometimes we see 1 of these resistors go open circuit.



  3. #3
    Registered
    Join Date
    Nov 2016
    Location
    United States
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Mitsubishi FX20 contact problem

    Thanks for the reply.
    I checked them and they seem to be fine.



  4. #4
    Member
    Join Date
    Feb 2009
    Location
    United Kingdom
    Posts
    51
    Downloads
    0
    Uploads
    0

    Default Re: Mitsubishi FX20 contact problem

    Check the 6 avr's on the back of the sub unit.



  5. #5
    Member
    Join Date
    Feb 2009
    Location
    United Kingdom
    Posts
    51
    Downloads
    0
    Uploads
    0

    Default Re: Mitsubishi FX20 contact problem

    Is your machine a straight FX machine or is it a FX20K machine?



  6. #6
    Member Luislopezcnc's Avatar
    Join Date
    Feb 2021
    Posts
    1
    Downloads
    0
    Uploads
    0

    Default

    We hace a FX-20, Shows contact anda have that red led in MW416, This happens when we want to start to Cut. Someone know what happens?

    Attached Thumbnails Attached Thumbnails Mitsubishi FX20 contact problem-img_20210221_094414-jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Mitsubishi FX20 contact problem

Mitsubishi FX20 contact problem

Mitsubishi FX20 contact problem