Need Help! Problem with rapid clearance and THC stop responding occasionally!


Results 1 to 4 of 4

Thread: Problem with rapid clearance and THC stop responding occasionally!

  1. #1
    Member
    Join Date
    Feb 2016
    Location
    Albania
    Posts
    3
    Downloads
    0
    Uploads
    0

    Unhappy Problem with rapid clearance and THC stop responding occasionally!

    Hi. About a year ago I had build my own CNC plasma table with torch height control. The problems I'm having is that every time i start cutting something mach3 stops executing the input signals from the THC after some lines of code. I cannot keep track after how much lines or blocks because it is random I think. I use mach3 and sheetcam , both have their licenses installed correctly and the THC I use is a PriceCNC AVCH10. While cutting, when mach3 stops executing the commands from the THC I just turn OFF THC mode on mach3 and turn it ON again, basically i just double click the THC mode button on mach3 and it starts correcting the height again for some time then it stops again. I have a lot of warped hot rolled 3mm mild steel to cut and I have to keep track when the torch stops following the material warping and quick double click the THC mode button to make it start correcting again. I think it is the BOB I am using . . . it is a chines USB breakout board. The PC I am using for the CNC does not have a parallel port that's why I got a USB controlled BOB. So I ordered two parallel to PCIe cards and I want to try it with two BOB that uses parallel ports. Why two? because I need more inputs. Inputs for the THC and inputs for every home/limit switch especially for my X axis because it has two stepper motors. So for now I am waiting for cards i have ordered and try it with the other breakout boards. The other problem I am having is with the rapid clearance. On sheetcam I have set the rapid clearance to 30mm and I use a floating head with G31 but on mach3 when THC mode is ON it ignores the G00 Z30 comand and after every cut it just raises the torch a few mm and sometimes it doesn't raise at all making the torch to crash on the material while traveling to the next cut. When THC mode is OFF the torch raises 30mm after every cut just fine.
    So please if anybody can help that would be grate

    Best regards. Llibert.

    Similar Threads:


  2. #2
    Member
    Join Date
    Sep 2011
    Location
    Italy
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Re: Problem with rapid clearance and THC stop responding occasionally!

    Quote Originally Posted by Liberty View Post
    Hi. About a year ago I had build my own CNC plasma table with torch height control. The problems I'm having is that every time i start cutting something mach3 stops executing the input signals from the THC after some lines of code. I cannot keep track after how much lines or blocks because it is random I think. I use mach3 and sheetcam , both have their licenses installed correctly and the THC I use is a PriceCNC AVCH10. While cutting, when mach3 stops executing the commands from the THC I just turn OFF THC mode on mach3 and turn it ON again, basically i just double click the THC mode button on mach3 and it starts correcting the height again for some time then it stops again. I have a lot of warped hot rolled 3mm mild steel to cut and I have to keep track when the torch stops following the material warping and quick double click the THC mode button to make it start correcting again. I think it is the BOB I am using . . . it is a chines USB breakout board. The PC I am using for the CNC does not have a parallel port that's why I got a USB controlled BOB. So I ordered two parallel to PCIe cards and I want to try it with two BOB that uses parallel ports. Why two? because I need more inputs. Inputs for the THC and inputs for every home/limit switch especially for my X axis because it has two stepper motors. So for now I am waiting for cards i have ordered and try it with the other breakout boards. The other problem I am having is with the rapid clearance. On sheetcam I have set the rapid clearance to 30mm and I use a floating head with G31 but on mach3 when THC mode is ON it ignores the G00 Z30 comand and after every cut it just raises the torch a few mm and sometimes it doesn't raise at all making the torch to crash on the material while traveling to the next cut. When THC mode is OFF the torch raises 30mm after every cut just fine.
    So please if anybody can help that would be grate

    Best regards. Llibert.
    what kind of plasma do you have? Could you have High Frequency interference problems?
    Regards
    Alfonso AQ TECNO



  3. #3
    Member
    Join Date
    Feb 2016
    Location
    Albania
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Problem with rapid clearance and THC stop responding occasionally!

    Hi. I don't think it's High Frequency interference because I use a Hypertherm powermax 45xp.



  4. #4
    Member
    Join Date
    Sep 2011
    Location
    Italy
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Re: Problem with rapid clearance and THC stop responding occasionally!

    Powermax doesn't use high frequency so the problem is different. I'm sorry, it's not easy to help you from a distance.
    Maybe a spike in initial tension. Put on a voltage limiter.
    Or the THC entrance is broken.
    Regards
    Alfonso AQ TECNO



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Problem with rapid clearance and THC stop responding occasionally!

Problem with rapid clearance and THC stop responding occasionally!

Problem with rapid clearance and THC stop responding occasionally!