Step direction voltage not changing


Results 1 to 5 of 5

Thread: Step direction voltage not changing

  1. #1
    Member mchesney1's Avatar
    Join Date
    Apr 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Step direction voltage not changing

    Hi gang,

    I have a homebuilt cnc router (PrintNC) that uses a UC300ETH controller with a C77 driver terminal board and UCCNC software. I started having intermittent problems with the X axis only moving in one direction and would eventually self correct. Well today it won't. With some searching here in the site, I eliminated loose connections, malfunctioning driver,keyboard, etc. When I checked the voltage for the direction terminals I get 4.7 and 0 for all the drives except the X. It stays at 4.7v despite inputting a direction change. Does this signify a bad controller or would it possibly the attached terminal board? Any thoughts or suggestions are greatly appreciated.

    Mike

    Similar Threads:


  2. #2
    Member
    Join Date
    Jan 2018
    Location
    United Kingdom
    Posts
    829
    Downloads
    0
    Uploads
    0

    Default Re: Step direction voltage not changing

    Quote Originally Posted by mchesney1 View Post
    Mike
    The C77 looks to me to have isolated outputs.
    That tells me that it is an issue with one of the optocouplers on the C77 itself.

    Any chance you could change things round and assign axis 5 or 6 to work as X instead?.

    https://www.cnc4pc.com/pub/media/pro...7rev1.5_v2.pdf



  3. #3
    Member mchesney1's Avatar
    Join Date
    Apr 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: Step direction voltage not changing

    Will try that today. Thanks for the response!



  4. #4
    Member mchesney1's Avatar
    Join Date
    Apr 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: Step direction voltage not changing

    Quote Originally Posted by dazp1976 View Post
    The C77 looks to me to have isolated outputs.
    That tells me that it is an issue with one of the optocouplers on the C77 itself.

    Any chance you could change things round and assign axis 5 or 6 to work as X instead?.

    https://www.cnc4pc.com/pub/media/pro...7rev1.5_v2.pdf

    That worked! Thanks for the help, it is very appreciated!



  5. #5
    Member
    Join Date
    Jan 2018
    Location
    United Kingdom
    Posts
    829
    Downloads
    0
    Uploads
    0

    Default Re: Step direction voltage not changing

    Quote Originally Posted by mchesney1 View Post
    That worked! Thanks for the help, it is very appreciated!

    Excellent. Good to hear your working again.

    Daz.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Step direction voltage not changing

Step direction voltage not changing

Step direction voltage not changing