Need Help! No voltage from DB25


Results 1 to 7 of 7

Thread: No voltage from DB25

  1. #1
    Member
    Join Date
    Mar 2011
    Location
    usa
    Posts
    11
    Downloads
    0
    Uploads
    0

    Default No voltage from DB25

    I have installed a G540, ESS and mach 3 onto my PC. I have followed the steps here https://warp9td.com/index.php/gettin...epper-and-mach
    and I cannot get my motors to move.
    They hold when powered and estop seems to be working. I can see my x and y axis change in Mach 3 after resetting the estop but the motors just hold and hummm white noise.

    I called Gecko and they had me check the output of pins 3 and 25 on the db25 while jogging the left and right arrows on the keyboard for voltage but I only get .054 volts or nothing, no fluctuations.
    Shouldn't the Ethernet smooth stepper test the same way at the db25 port? Because it dosent. I get no voltage on db25 pins 3 and 25 out of the ESS or LPT port when jogging the left and
    right arrow in Mach 3.

    Also is this motor wired correctly? I haven't put in a resistor "5 amp motor not 3.5amp" but I was told its not necessary to test motor output.

    Similar Threads:


  2. #2
    Member
    Join Date
    Mar 2011
    Location
    usa
    Posts
    11
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    No voltage from DB25-img_2559-jpg

    Last edited by Tconners; 09-04-2019 at 06:28 PM.


  3. #3
    Member john-100's Avatar
    Join Date
    Mar 2007
    Location
    uk
    Posts
    1986
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    attachment not visible - Invalid Attachment specified. If you followed a valid link, please notify the administrator

    while I have not used a Ethernet Smooth Stepper

    I would double check the mach 3 smooth stepper plug in is installed
    so Mach 3 can use the ESS insread of a PC parallel printer port
    and the ethernet connection is working

    we need a ESS user to reply

    John



  4. #4
    Member
    Join Date
    Mar 2011
    Location
    usa
    Posts
    11
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    I have the warp 9 plugin installed and it comes up and asks for ESS or printer port. It connects after setting the IP address. I can pull the eathernet cable and I get a
    message from mach 3 that the ess is not connected anymore.
    I also fixed the attachment.



  5. #5
    Member john-100's Avatar
    Join Date
    Mar 2007
    Location
    uk
    Posts
    1986
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    that's OK
    mach3 is obviously communicating with the ESS

    on the G540 do you have the charge pump switch enabled or disabled ?

    not having the current set resistor on the motor cables 9 pin plug results in the current being set to the maximum 3.5A G540 output
    ( fitting a 3K5 resistor results in the current being 3.5A when stepping and the current reduction being active when when the axis is inactive )

    in mach3 pins and ports
    how have you assigned the " printerport" emulated by the ESS

    John

    as its 23:50 I'll download the Mach 3 and ESS manuals
    and continue in the morning



  6. #6
    Member
    Join Date
    Mar 2011
    Location
    usa
    Posts
    11
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    Thanks and yes I have the charge pump off

    "in mach3 pins and ports
    how have you assigned the " printerport" emulated by the ESS"

    I have not done anything in pins and ports regarding the printer port, just set up the motors and estop in there per the ESS instructions. I will post a link in the am....Late for me to now so will check in the am and thanks again.



  7. #7
    Member john-100's Avatar
    Join Date
    Mar 2007
    Location
    uk
    Posts
    1986
    Downloads
    0
    Uploads
    0

    Default Re: No voltage from DB25

    I have not found any image on line showing the mach3 ports and pins config when using a ESS

    I assume this mach 3 engine config will be replaced by the ESS plugin and may not be visible

    PC printer port set up replaced by ESS version
    No voltage from DB25-engine-config-replaced-ess-plugin-jpg


    I expect the ESS port 1 will be equivalent to the the printer port 1 on this page -
    ports and pins motor outputs

    No voltage from DB25-ports-pins-motor-outputs-jpg

    G540 "printerport" pin assignment

    Pin Number function
    1 OUTPUT 2
    2 X-AXIS STEP
    3 X-AXIS DIRECTION
    4 Y-AXIS STEP
    5 Y-AXIS DIRECTION
    6 Z-AXIS STEP
    7 Z-AXIS DIRECTION
    8 A-AXIS STEP
    9 A-AXIS DIRECTION

    10 INPUT 1
    11 INPUT 2
    12 INPUT 3
    13 INPUT 4

    14 VFD PWM (50 Hz)
    15 FAULT (input to PC)
    16 CHARGE PUMP (>10 kHz)
    17 OUTPUT 1

    18 to 25 ground


    John



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

No voltage from DB25

No voltage from DB25

No voltage from DB25