Brand new Weike LC6090 not firing


Results 1 to 10 of 10

Thread: Brand new Weike LC6090 not firing

  1. #1
    Member
    Join Date
    Sep 2013
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Brand new Weike LC6090 not firing

    Hello everyone, long time reader but my first post. I finally took the leap and purchased my very first laser. A G Weike LC6090 from China. The machine arrived in what looks like perfect condition. I have everything set up but so far have not been able to get the laser tube to fire. Here is what I have done so far.

    1. Power up - everything seems to work. XYZ steppers go thru testing motions fine.
    2. Laser will not fire with the pulse button or running files.
    3. I removed the signal connector from the power supply. The red light comes on and the laser tube DOES fire with the test button.
    4. The proximity sensor on the lid tests good.

    I contacted my sale rep and was sent 2 instructional files on how to adjust the laser light path???
    Can anyone give me some direction on what to check next or where to find additional info? There may be older posts on this subject that I have not been able to find yet so I apologize if I am repeating. Again, I am brand new to this so I am trying to figure it all out but getting frustrated. Any help here is appreciated.

    Similar Threads:


  2. #2
    Member
    Join Date
    Sep 2005
    Location
    Canada
    Posts
    105
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    I am not sure this is what you are looking for, or want to hear.
    Last year I purchased a TS 4060 80w. Not quite the same, but very close. I also could not get the laser to fire. I ended up tossing the software and getting Lightburn ( you won't be disappointed) and purchasing a Cohesion 3D board and replaced the board that came with the laser. Replacement was plug and play, took 5 mins. The machine is now working great.

    Just something to think about. Both my recommendations have forums where you can learn about them before purchasing.



  3. #3
    Member
    Join Date
    Sep 2013
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    Thanks for the quick response.
    I am very skeptical when it comes to stock Chinese software (or hardware) so I would have no problem considering swapping the board. You said in your particular case this is all that was required to get your machine to fire? And you said I would not be disappointed, so you would consider this an upgrade over the stock board or just a second party alternative? Being under warranty I would push for replacement parts unless you think I'm better off.



  4. #4
    Member
    Join Date
    Jan 2008
    Location
    USA
    Posts
    891
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    Is your water flowing and is the flow switch working



  5. #5
    Member
    Join Date
    Sep 2005
    Location
    Canada
    Posts
    105
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    I had the M2 nano board and no Ruida panel. So for me it was a huge upgrade. This was my panel that came with the machine.
    Brand new Weike LC6090 not firing-e224460b011c09722308e6577e21a74494a628b9_2_666x500-jpeg

    With the cohesion board there is a GLCD panel that gives me far more control.
    I am just suggesting having a look. Nothing I did could get the laser to fire with the M2 board. The cohesion board fired first try, and works perfectly.
    As for the Lightburn software, ya, you can't go wrong with this for $40. Great forums, and youtube vids to help, but it really is pretty straight forward if you have used any other drawing software.... just much cheaper.



  6. #6
    Member
    Join Date
    Sep 2013
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    Quote Originally Posted by fixtureman1 View Post
    Is your water flowing and is the flow switch working
    I traced the water lines through the interior of the cabinet from the fittings all the way to the tube and back and could find no flow sensor! It is very difficult to follow but I don't think it would be placed in a wire trough (the only place I couldn't see). I do have great water flow and in the right direction. I'm going to trace those lines again just to make sure I didn't miss anything.



  7. #7
    Member
    Join Date
    Sep 2013
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    I went to the Lightburn website and it seems like a good idea if nothing more than the support you get. I do have a Ruida board, even if I upgrade software is it possible I have a bad control board?



  8. #8
    Member
    Join Date
    Sep 2005
    Location
    Canada
    Posts
    105
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    It is possible, as I said, my M2 board would not fire, no matter what i did.



  9. #9
    Member
    Join Date
    Sep 2013
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    Soooo... as it turns out. I finally managed to "talk" to an engineer in China thru an app called wechat that does the language translation. Apparently my machine was never equipped with a water flow sensor. Once we discovered that he had me add a jumper to the lasers power supply and MAGIC! I plan on adding a sensor real soon. Thanks everyone for your input, at least I don't feel all alone out here.



  10. #10
    Member
    Join Date
    Sep 2005
    Location
    Canada
    Posts
    105
    Downloads
    0
    Uploads
    0

    Default Re: Brand new Weike LC6090 not firing

    glad you got it working. have fun



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Brand new Weike LC6090 not firing

Brand new Weike LC6090 not firing

Brand new Weike LC6090 not firing