Fanuc OM - Z axis interlock without any errors/ alarm displayed


Results 1 to 9 of 9

Thread: Fanuc OM - Z axis interlock without any errors/ alarm displayed

  1. #1
    Member wowjow's Avatar
    Join Date
    Apr 2019
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default Fanuc OM - Z axis interlock without any errors/ alarm displayed

    Hello guys,

    i got a 3 axis milling machine with a Fanuc OM controller, its been running for years without using the ATC, until i accidentally ran a G-code ordering to change tools(T2M6) resulting in a few errors that appeared concerning the position of the ATC arm and the counter of the tool pot. i was able to get rid of these errors by manually moving everything back to its original place.

    But the problem was that i couldn't move the Z axis in JOG mode nor in AUTO, i can only move it with the HANDLE.

    I did my research and found out that there is a z axis interlock signal, it was shown in the diagnostic parameter DGN 128: 00000011 and the parameter PRM008#7 is 1 so the interlock is only effective on the Z axis.

    I looked for what triggering this signal in the ladder diagram and found this (please check the attached picture)
    G128 corresponds to DGN 128, but i don't know what's Y049.1 and what it corresponds to,it might be a switch that is not active i'm not sure i'm still looking in some hardware and installation manual i found online.

    I'm still new to this any help would be much appreciated, what should i do next ? is there an option to override this interlock signals by changing some parameters ? or should i keep looking for what is triggering this interlock?

    Thanks in Advance!



  2. #2
    Member
    Join Date
    Dec 2009
    Location
    ROMANIA
    Posts
    543
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    you did not attached any picture to this message
    what is the name of the machine?MTB?



  3. #3
    Member wowjow's Avatar
    Join Date
    Apr 2019
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    MTB is Marta Werke - machine name: Matra Vm 1020A,

    The problem is i don't have any manuals or documents for the machine, and its probably a Diagnostic parameter that i should change that is causing the interlock , and i discovered that the interlock is also effective on the spindle too.
    Does anyone know what this D parameter could be ? can i find it by following a certain signal in the ladder diagram or maybe if i analyse the macro program for tool change maybe there is an order there that toggles certain D parameters?
    Any help would be much appreciated !



  4. #4
    Member
    Join Date
    May 2016
    Location
    United States
    Posts
    85
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    Although Y049.1 is a higher number Y address then I'm use to seeing, a Y address is the CNC telling the machine to turn on or do something. An X address is the machine answering back or signalling that the machine has done something the control might be interested to know, like a FIN (finish) signal for instance. Both Y and X are physical things that somewhere will have a wire or relay coil attached that you can check or measure.

    I won't say it's impossible, but doubtful your tool change program would use an on the fly parameter change. The few tool or pallet change programs I've seen have been pretty basic affairs. Meaning nothing fancy.



  5. #5
    Member
    Join Date
    Jan 2014
    Posts
    63
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by wowjow View Post
    MTB is Marta Werke - machine name: Matra Vm 1020A,

    The problem is i don't have any manuals or documents for the machine, and its probably a Diagnostic parameter that i should change that is causing the interlock , and i discovered that the interlock is also effective on the spindle too.
    Does anyone know what this D parameter could be ? can i find it by following a certain signal in the ladder diagram or maybe if i analyse the macro program for tool change maybe there is an order there that toggles certain D parameters?
    Any help would be much appreciated !
    The arm is probably not in a safe position (home) to allow Z-axis to move without crash. I would keep jogging the arm around where it looks like the home should be. If it is a Prox switch to signal in position you may get lucky and hit it. If the arm is a servo you maybe out of luck.



  6. #6
    Member
    Join Date
    May 2016
    Location
    Lebanon
    Posts
    1
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    I'm the same guy but on another account ( can't access the initial account right now )

    So first of all the ATC has 2 motors ( not servos) and 1 pneumatic piston, the first one rotates the tool pots and it has 2 switch working as a counter, the other is connected to a gear box that by rotating the motor it will execute the sequence of rotating the arm to grab the tool than lowering it -> rotate again -> going up to insert the new tool and than going to the initial position, and its equipped with 3 on/off sensor to detect if the arm is up/or down and the third one is one when the arm is in the initial position. The pneumatic piston has 2 switch to detect if its up or down.
    I double checked and made sure that its all the sensors and switch connected to the ATC, and if i toggle any of these switch an error will show on the screen which means that everything should be OKAY with the ATC.

    Secondly i check the Macro programs O9001(ARM TYPEBMACRO) and there should be nothing there that is inputting an interlock signal or anything, i can post the codes here if you want.

    Any suggestions were to look next ?



  7. #7
    Member
    Join Date
    May 2016
    Location
    United States
    Posts
    85
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    Can you zero return the machine? Does your machine use trip dogs and grid shift to zero return or does it have absolute encoders with batteries? Sounds like the tool changer or machine is waiting for the Z axis to be at home or tool change position. Does your control panel have lights that light when an axis is home? If so you'll need to see that lit before it will tool change.

    You can try shutting down the machine with all axis at least a couple inches away from home. Then start up the control holding down "P" and "Cancel" at the same time until the control comes up. DO NOT HOLD DOWN ANY OTHER KEY COMBINATIONS THEN THAT! This will clear your home positions and allow the machine to reset them. If you haven't done anything drastic to the machine since the last time it was home it will just re-grid (home) to the old positions. Maybe someone can back me up on this but I'm pretty sure that's correct.

    What happens if you single block the tool change? Can you get anywhere with that?

    You seem to know enough to analyze things and work with the clues you find. Without being there, it's difficult to be of any great get-it-fixed value to you.

    You might try posting the exact error codes you got when you tried a tool change and their description.



  8. #8
    Member wowjow's Avatar
    Join Date
    Apr 2019
    Posts
    4
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    So let me tell you what happened exactly:

    As i mention before we never used the ATC until last week by 'accident', the machine went to Zero position (or tool change position) and started the tool change sequence (turning the tool magazine => lowering the tool using the pneumatic piston => swapping the tool using the arm ...) , but when it got to returning the piston to its initial position it couldn't due to a damaged air tube and the arm never moved also due to a malfunctioning contactor that supplies the arm motor (which i fixed later on).
    That's when i got 2 errors: the first one telling me about the piston not in the home position and the other something about the tool number/counter (i can get you the exact code number and name if needed) , so i fixed the first one by manually returning the piston to initial position and the second error by toggling the tool counter switch until the alarm was gone ( i matched the counter with the registered tool number) . after that i couldn't move the Z axis anymore only in Handle mode.

    Now answering your questions:

    1. I can only reference (zero return) X and Y axis, and yes there a lights for each axis on the control panel that blinks during homing and will stay on when its done. i cannot reference the Z axis it will keep blinking waiting for the Axis to go to zero ( i even tried manually pressing the limit switch to tell that the axis is at the home position but it did not work)

    2. The machine uses a limit switch on each axis, the limit switch on the X and Y axis got 2 switches the first one used for referencing and the other is physical limit working as an emergency stop, but the limit switch on the Z axis got 4 switches the first 2 same as X&Y and the other i'm not sure about but i think they are used to get to the tool change position ( i will double check their use tomorrow)

    3. I tried the P + CAN at start up near home position and it made no difference.

    4. i tried the single block for tool change but the machine waits for the Z to be in position, i can run any program for X and Y and when it get to a command for Z it waits for it to move.

    Its been 2 weeks and i did a lot of troubleshooting, i'm really open for any suggestion, i'm not that experienced but i can manage.

    Thank you !



  9. #9
    Member
    Join Date
    May 2016
    Location
    United States
    Posts
    85
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc OM - Z axis interlock without any errors/ alarm displayed

    Sounds like your machine is waiting for some signal or there is a mess up on what tool the control thinks it has. Is your machine ready light on? (MRDY) Or do you see that on the screen.

    The tool assignment is probably in the diagnostics area somewhere. On a YCI OM machine I have it starts at D440 for tool in spindle and then D441-D463 for what tool is in what pot for pots 1-22. You can likely find out where your tool register is at just by scanning your Diagnostic registers and look for a string of Diagnostic entries with numbers coinciding with how many tool pots you have. They may be simple two digit numbers like I have. Maybe there is a discrepancy there that's hanging up the machine.

    I'm really busy today as leaving for a week vacation tomorrow so can't help anymore for awhile.

    The machine is waiting for a signal. Maybe you could search MRDY in your ladder or something and find out what's holding up the completion of the ladder rung. Sorry I can't give this any more time now. Sort of shooting in the dark anyway, as I'm no expert by a long shot.

    Good luck.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Fanuc OM - Z axis interlock without any errors/ alarm displayed

Fanuc OM - Z axis interlock without any errors/ alarm displayed