Need Help! Fanuc 6T no PRDY on Z- controller


Results 1 to 3 of 3

Thread: Fanuc 6T no PRDY on Z- controller

  1. #1
    Registered
    Join Date
    Nov 2017
    Location
    Netherlands
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Fanuc 6T no PRDY on Z- controller

    Hi all!

    I recently got hold of an old flat bed lathe with Fanuc 6T control. Previous owner had crashed the Z-axis while jogging and didn't touch the machine again, until I picked it up. Swapped it for a couple of hours of labour I did for him.

    I hooked it up at home, but keep having the 401 alarm message. When I fire up the machine with the main switch, hydraulics and fans come in immediately. When I power up the NC, the PRDY signal on the X-axis comes in shorlty and the MCC of X-axis is pulled in. Z-axis gets no PRDY signal. After 1 second or less, the PRDY signal of X-axis drops and alarm is on.

    I already checked the following things:

    * 24V on Velocity Control PCB's: OK
    * +15V and -15V on that board's: OK
    * Thermo OL switch on Z servomotor was in open condition when I checked. After taking that from motor, the switch went to closed (is NC I believe) and still is.
    * All aux contacts on both MCC of VC are OK. (NC and NO contacts).
    * Checked diagnostics, but don't seem to have diagnostic 707. jumps from 702 to 710...
    * All limit switches are 1 (NC) in diagnostics, so that seems to be OK.
    * Checked cable from master PCB to both VC units, all leads are OK



    So it seems the NC is the problem here. According to the maintenance manual, I should replace the master PCB with such an error, but maybe somebody hs a better idea?

    Thanks,

    Edwin

    Similar Threads:


  2. #2
    Registered agering's Avatar
    Join Date
    Oct 2014
    Location
    Russia
    Posts
    109
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc 6T no PRDY on Z- controller

    Check the signals VRDY X,Y,Z on the side from drive of axises. I put the scheme with these relay contacts from drive. Any signal can be a reason of the error 401.

    Attached Thumbnails Attached Thumbnails Fanuc 6T no PRDY on Z- controller-vrdyx-pdf  


  3. #3
    Registered
    Join Date
    Nov 2017
    Location
    Netherlands
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Fanuc 6T no PRDY on Z- controller

    Thanks,

    I get a short VRDY signal from X-axis, but never a VRDY from Z. Doesn't the Velocity Control needs the prdy signal first to get the MCC pulled in? At least this is what happens to the X-Velocity Control and that seems to work, however very shortly.

    When the Numeric control cuts off the PRDY signal, the VRDY drops.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Fanuc 6T no PRDY on Z- controller

Fanuc 6T no PRDY on Z- controller