15XT Skipping Lines of Code


Results 1 to 3 of 3

Thread: 15XT Skipping Lines of Code

  1. #1
    Member
    Join Date
    Sep 2010
    Location
    United States
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default 15XT Skipping Lines of Code

    Hello,

    I've got a 15XT with a CNC88 controller that twice now has just randomly skipped lines of code in different programs. The first incident was a month or so back when it failed to drill a hole first before subsequently putting a tap into it. The machine had run all day making the same parts just fine but decided to miss drilling several holes across multiple parts. The drill cycle was controlled by a sub routine in a program that had the option of using block skip on all but one work offset. I did this so that the program could just be run in single part mode for when end of the run got near and there wasn't enough part blanks to populate all the work offsets. Coincidentally the station without the block skip option was the only one that didn't have missing holes on it despite block skip not being activated. My initial thought was that perhaps the controller randomly was block skipping even though it wasn't activated. Our tech wasn't really sure what to say could be the cause of it but he did have me reinitialize the memory and the machine ran just fine after that. I did remove all the block skips as a precaution in that program though. Since that time this machine has made thousands of parts without repeating this anomaly.

    Today however the problem came back. After running flawlessly all day on a 24 offset program with the same block skip program method to be able to eliminate stations. This happened, of course, on the first run after handing the machine over to another operator and going home. Much like the first time a drill cycle was skipped and the follow on tool discovered some extra work ahead of it. Except this time it happened on all stations and not just the optional blocked skipped ones. After thinking about this for awhile this evening something that comes to mind is that late this afternoon as I was heading home some welding began in the vicinity of the machine, probably 30 feet away. If I'm recalling right there was welding going on when this happened the first time as well. This machine as I am to believe it is on a totally separate circuit from the welding equipment, but in the same panel. Could this in anyway be related to the welding going on? Any other ideas perhaps as to what could cause a machine to skip random lines of code?

    Thanks,
    Nick

    Similar Threads:


  2. #2
    Member rodney247's Avatar
    Join Date
    Jan 2015
    Posts
    328
    Downloads
    0
    Uploads
    0

    Default Re: 15XT Skipping Lines of Code

    When you loaded the program did you do a NU renumber. Fadals can get confused on some programs if you do not renumber



  3. #3
    Member
    Join Date
    Sep 2010
    Location
    United States
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: 15XT Skipping Lines of Code

    Quote Originally Posted by rodney247 View Post
    When you loaded the program did you do a NU renumber. Fadals can get confused on some programs if you do not renumber
    None of my programs have line numbers in them. I let the machine assign them when I send them to it.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

15XT Skipping Lines of Code

15XT Skipping Lines of Code

15XT Skipping Lines of Code