I am new to the forum hi everyone. I have had a horrendous time with this 4x8 ez router. I purchased it used from ezrouter a few years ago supposedly as completely refurbished with a new paint job and it arrived as a non working machine with parts falling off that looks like it had not been touched in years. After the machine sat for nearly 3 months they finally flew someone out who go it going. It ran for 2 weeks and was down again. They sent the repair guy out again (who as pretty cool by the way) who finally swapped out all the parts. IT finally began doing its job but fell apart about a year after use.

Right now the machine is just sitting in place taking up our space and time so I need to either get it fixed asap or move it out of our shop asap.

Hopings someone can help. The biggest issue is with all of my employees working around 60 hour weeks and me at 90 it's hard to focus on this full time. We have already spent 2 weeks working on it so I think we are getting nowhere. Ez router is emailing us on occasion with ideas but it's hard to wait 2-4 days to try something that does not work.

We are totally fine with flying out someone who can make the repairs but after calling maybe 20 repair companies most of them have no clue what this is or how to fix it. Not sure if I am calling wrong people but noone seems to be capable of making the repair except the factory.

This is a 4x8 older EZrouter. We usually cut cast acrylics with this machine. Our software is Mach 3 and vectric vcarve.

The machine has had a series of multiple different issues over the year it has worked. Mostly we have been to fix but we are dead in the water on current issue. Problems began 4 weeks ago.
Phase 1- I came to work one morning and the machine was left on all night. Ez router told me this is no problem. The 5 pin wiring harness that connects the wires to the z stepper had melted/overheated. It melts through the harness and lost contact so it luckily did not burn my business down. I emailed ez and replaced the harness. Finally days after I heard from them and they said it might be power supply issues to keep an eye out , but they had hear of this happening before so it should be fine to continue use. So it ran for about 3 days then

Phase 2 A week or so later Started it up and was getting phantom limit switch error on mach 3 with no movement. Usually it's after we would reference the machine within maybe 5 seconds to 3 minutes the error would happen. Usually it was limit switch but once it said "e stop requested" I checked for obvious interference and inspected the visible cables. Finally I though maybe the eswitch is old and sticky so I popped it in and out while all was on, and mach 3 screen changed. I spent a few days trying to figure out so finally contacted factory again. They had never heard of it. Sent photos but was over weekend so had to wait for it dept. Never heard back so tuesday sent more pics or things I had tried which were A.) check parallel cable B.) check connections C.) reload software (unable) D.) read online etc... E.) bought new computer with parallel port (didnt work either) and I can't remember what else. Neeedless to say never got mach 3 back up and running. It's still down. Finally yesterday I hear back from them and they tell me win 7 os can not run machine on parallel port. Wow I was pretty pissed off for wasting my money and time but whatever lol. Could have told me that a week ago.

Anyways that's a rough overview of where I am. I am willing to pay a repair company/ person that is 100% able to repair this hunk of **** or I am totally cool to buy a new machine so if someone is interested in purchasing this I will go that route. As a business owner I just need a machine that is running no matter how I accomplish this. I just want to purchase from a machine that has a history of working from a reputable company to be honest but am totally cool with paying a repair team as well. We need this fastest route to get our shop back in working mode.

Thanks for any help.

Similar Threads: