Help! I deleted the firmware from my DSP controller - Page 3


Page 3 of 7 FirstFirst 123456 ... LastLast
Results 25 to 36 of 76

Thread: Help! I deleted the firmware from my DSP controller

  1. #25
    Registered
    Join Date
    Mar 2009
    Location
    Romania
    Posts
    90
    Downloads
    0
    Uploads
    0

    Thumbs up ok soo try this

    Last year a had the same problem with my dsp ...and i tryed all the thing's you posted here. and the only thing that worked...you need to ask an expert for this .....i have a friend that write bios cip's for pc's and he managed to write the firmwall directly to the main cip from the dsp..by detaching the cip from the motherboard and plug it in a special board for bios cip's....if you have a friend like that the you are saved.



  2. #26
    Registered
    Join Date
    Nov 2009
    Location
    India
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default DSP

    I got a new DSP from the CNC manufacturer in China.
    Landed into the same problem again.

    Can anyone save me from this.
    Since it is a software issue...it must get resolved over the internet.

    Would be very much obliged if someone can help me out.



  3. #27
    Registered
    Join Date
    May 2009
    Location
    Spain
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    Hi bimal,

    Can you tell us what happened to you exactly?

    You can try to restart the DSP: just press the green button with the power off and switch it on (keep pressing the button until you see the screen turns on).

    If that doesn´t work, you can try to update the firmware with the Signtek program.

    But if your firmware is deleted or corrupted, I´m afraid you´ll have to send your DSP for repair, unless you have a friend who knows exactly how to reprogram a chip as mecanicu said.



  4. #28
    Registered
    Join Date
    Mar 2009
    Location
    Romania
    Posts
    90
    Downloads
    0
    Uploads
    0

    Default

    what happend exactly????
    i had a lot of problems with the dsp just last week i connected the dsp via pc and i started the cnc in the same time...DON'T DO THAT EVER...and i fryed a cip inside...it is a power cip controller...a 3 by 3 mm with 8 legs... and i buyed a new one and replace it.....SOO DON'T DO THAT ....

    Maybe you cand download the dsp manual and it will help you..here is the link for the manual http://cnczone.com/forums/showthread.php?t=46637

    You need to explain your problem!!!!!

    i have my own problem's with a project maybe some one will help me i posted under Excitech routers/ 4th axis on a excitech



  5. #29
    Registered
    Join Date
    Nov 2009
    Location
    India
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default overwriten wrong Bin file

    the screen went blank just after I tried to update program and probably loaded wrong bin file through Signtek program on my PC. Now the DSP doesn't show anything , no buttons function , and I am unable to format it by pressing OK as before.

    It seems that only mecanicu's solution may work...by rewriting into the Bios chip.

    Can you please provide me the details on the procedure and steps.



  6. #30
    Registered
    Join Date
    Mar 2009
    Location
    Romania
    Posts
    90
    Downloads
    0
    Uploads
    0

    Default

    you need to search for a good electronic guy...with some experiance on pc's and he will know what to do.....



  7. #31
    Registered
    Join Date
    Sep 2008
    Location
    P.R.C
    Posts
    34
    Downloads
    0
    Uploads
    0

    Default

    Hi, I read the posts. I once worked the Dsp company for years. the questions for Cenicero and Andre09 are quite different. Andre09 have to send the controller back to the China for repaire because the controller you have lost its boot program which is saved in the dsp chip; but no neccessary for Cenicero because your controller just lost some files(80% possibility is the english menu file) which saved in Memory chip, those files can be update via the host program(signtek program you called).
    For Cenicero, you need a english version host program and the english menu file and maybe bin files. Normally your cnc router manufacturer should send you english version host program and all file with the controller.
    I can tell the Shannon is very experienced for the dsp controller.
    For RZNC0501, the dsp company had a special version since last year, which has:"CNC ROUTER", this one cannt be updated Logo file, bin files, otherwise it will lead to error.
    yes, for the .dat file is to save all your dsp settings parameter as a file, such as: pulse equivalent, machine size, motor direction, home direction, inputs/outputs properties. If you save it when you got your machine or got the file from your cnc manufacturer, then it will helps in future when the inside parameter changed by mistake or corrupted.
    The dsp can get power from the cnc router or the pc, but it is really dangerous to get from both of them, the inside chip needs only DC3.3v. of course the inside power manage chip converts DC5v to DC3.3V, but the chip gets power from both router and PC, it will destory it sometimes. So be careful!



  8. #32
    Registered
    Join Date
    May 2009
    Location
    Spain
    Posts
    12
    Downloads
    0
    Uploads
    0

    Default

    Thanks very much for the information king9558!

    However I already received a new DSP from my company, but what you said could be useful for other people who have a similar problem in the future.

    The new DSP I received is working fine, I just had to change the Z-axis pulse and the Spindle setup. I think I won´t connect the DSP to the PC anymore, it seems to be too risky. From now on I´ll always use a USB disk to pass the files from the PC to the machine.



  9. #33
    Registered
    Join Date
    Sep 2008
    Location
    P.R.C
    Posts
    34
    Downloads
    0
    Uploads
    0

    Default

    Hi Cenicero:
    it is nice that your new controller works well. Good luck all the time.



  10. #34
    Registered kram242's Avatar
    Join Date
    Mar 2005
    Location
    USA
    Posts
    98
    Downloads
    0
    Uploads
    0

    Default

    So if we updated the logo on the version of the DSP that has CNC ROUTER logo and now all we get is a blank screen does that mean it has to be sent back?!
    I tried all the options of holding down OK and Stop & OK but nothing happens.
    Any help would be great
    Thank you
    Mark



  11. #35
    Registered
    Join Date
    Oct 2006
    Location
    Australia
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Back to China

    Hi Mark, unfortunately the news is not good. I have gone through the same thing, although not because I tried to update the Logo. If the screen is blank when you power up, there is nothing you can do. It needs to be sent back to China for repair. Why they would create software to make it so easy for the user to corrupt the controller is beyond me. I felt like a real tool when I corrupted mine, but given that there is virtually no instruction, and that there are no warnings when you proceed with the program options & most other owners go through the same drama, I conclude that the whole setup is rubbish. The Chinese would do well to spend just a little time upgrading the software to be more user friendly and less susceptible to killing the controller...

    Sorry for the bad news...



  12. #36
    Registered
    Join Date
    Mar 2009
    Location
    Romania
    Posts
    90
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by Andre09 View Post
    Hi Mark, unfortunately the news is not good. I have gone through the same thing, although not because I tried to update the Logo. If the screen is blank when you power up, there is nothing you can do. It needs to be sent back to China for repair. Why they would create software to make it so easy for the user to corrupt the controller is beyond me. I felt like a real tool when I corrupted mine, but given that there is virtually no instruction, and that there are no warnings when you proceed with the program options & most other owners go through the same drama, I conclude that the whole setup is rubbish. The Chinese would do well to spend just a little time upgrading the software to be more user friendly and less susceptible to killing the controller...

    Sorry for the bad news...
    i explain to mark what happend to the dsp..the 5v cip controller was fried becaus it is dangeros to plug the usb and the 50pin cable in the same time(when the cnc it's on and you plug the usb in the dsp you overcharge the 5v controller). i had this bad experience last year....a electronic friend change the 5v controller cip a very small 8 pin's 3x3mm cip. and now it work's perfect 2$ for the cip:P:P. if you read this thread i posted my WARNING'S about this problem!!!!! post #28



Page 3 of 7 FirstFirst 123456 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Help! I deleted the firmware from my DSP controller

Help! I deleted the firmware from my DSP controller

Help! I deleted the firmware from my DSP controller