POST ISSUE EDGECAM 2011 fanuc milling post - Page 2


Page 2 of 3 FirstFirst 123 LastLast
Results 13 to 24 of 25

Thread: POST ISSUE EDGECAM 2011 fanuc milling post

  1. #13
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    PP sendt

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  2. #14
    Registered
    Join Date
    Nov 2005
    Location
    USA
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    ok now problem we have is % character in front of each turret and tool description in the header, (is multi tool program). We need only one occurrence at very top and one at very end of program.



  3. #15
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Ok, give me some minutes

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  4. #16
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Hmm... I can`t place it before the tool information, only after the tool list..
    But give me some minutes/days i will figure it out

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  5. #17
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    New PP sent!

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  6. #18
    Registered
    Join Date
    Nov 2005
    Location
    USA
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    now programs are missing % character at top



  7. #19
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Hmmm.. Wierd, that work for me..

    -Check it-

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  8. #20
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Here is the .nc code i get out.


    Please check that you are using the latest PP


    %
    (* Turret Position : 1 Tool Description : 25.0 mm Multi-Flute End Mill)
    (* Turret Position : 2 Tool Description : 8.0 mm Multi-Flute End Mill-LS)

    (*************************************)
    ( Innovative Engineered Solutions Inc.)
    (*************************************)
    (* Machine Tool : Chevalier Mill)
    (* Part Name : Parasolfot Chavalier test)
    (* Sequence : Operation 1)
    (* Programmed By : )
    (* Date : 01/30/19)
    (* Time : 22:31:49)
    (* Total Machining Time : 6.407 Minutes)

    O0001 (Parasolfot Chavalier test)
    G17 G40 G80 G90 G94
    G00 Z3.0
    X0.0 Y0.0
    T01 M06 (25.0 MM DIA MULTI-FLUTE END MILL)
    M3 S9999
    G00 G55 X0.0 Y0.0
    G43 Z3.0 H01
    G00 X0.0 Y0.0
    Z1.9685
    M8
    X0.1969 Y-1.8102
    Z0.1969
    Z0.1181
    G01 Z-1.2598 F7.87
    Y-1.7315
    G17 G03 X0.0 Y-1.5347 R0.1969
    G02 I0.0 J1.5347
    G03 X-0.1968 Y-1.7315 R0.1969
    G01 Y-1.8102
    G00 Z0.1969
    Z1.9685
    X0.0 Y0.0
    Z3.0
    X0.0 Y0.0
    M9
    M05
    T02 M06 (8.0 MM DIA MULTI-FLUTE END MILL - LS)
    M3 S9999
    G00 G55 X0.0 Y0.0
    G43 Z3.0 H02
    G00 X0.0 Y0.0
    Z1.9685
    M8
    X0.1969 Y-1.4756
    Z0.1969
    Z0.1181
    G01 Z-1.2598 F7.87
    Y-1.3969
    G03 X0.0 Y-1.2 R0.1969
    G02 I0.0 J1.2
    G03 X-0.1969 Y-1.3969 R0.1969
    G01 Y-1.4756
    G00 Z0.1969
    Z1.9685
    X0.0 Y0.0
    Z3.0
    X0.0 Y0.0
    M9
    M5
    G00 Z3.0
    X0.0 Y0.0
    M30
    %

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  9. #21
    Registered
    Join Date
    Nov 2005
    Location
    USA
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Our cam and or code wizard versions are different - still no % at top of program. The files you modified will not open with our version of code wizard.
    Can you tell me what you changed maybe we do it here.



  10. #22
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    I will try

    1. Under “Chavalier Mill --> NC Style, G-Codes and Modality --> Set Up Sheet
    Turn ON the "Output Setup Header / Trailer"

    2. Under “Chavalier Mill --> NC Style, G-Codes and Modality --> Code Constructors --> NC Program General --> Set-Up Header
    Delete all the text in the output bar and plase the % symbol

    3. Under "Chavalier Mill --> NC Style, G-Codes and Modality --> Code Constructors --> NC Program General --> Set-Up Trailer
    Delete all the text and leave it empty

    Then save it and compile. Then run out an code and check it

    Good luck!

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  11. #23
    Member Vegabond's Avatar
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    439
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    Don't think this is the most correct way to do it, but i think it will work. The % symbol should be in the top in the "Program Start" but the tool list is been posted out before that...

    So that is because i put it in the Header text...

    My second homebuilt cnc machine cnczone.com/forums/norwegian_club_house/123977-ombygget_cnc_-_gecko_540_a.html


  12. #24
    Registered
    Join Date
    Nov 2005
    Location
    USA
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: POST ISSUE EDGECAM 2011 fanuc milling post

    AHH Yes!!! May I heap praise upon you, I am not worthy...
    Output looks just like we want it.

    The reason for all this is our DNC software does not want to see anything above the % character
    we don't like editing programs
    we still want our operators to be able to see the tool descriptions list

    Thanks



Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

POST ISSUE EDGECAM 2011 fanuc milling post

POST ISSUE EDGECAM 2011 fanuc milling post

POST ISSUE EDGECAM 2011 fanuc milling post