Need Help! Warner/Swasey QCM-6 lathe with Kflop/Kanalog - Page 13


Page 13 of 13 FirstFirst ... 310111213
Results 241 to 250 of 250

Thread: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

  1. #241
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Tom,

    Back on it again. Had to take a break. Tried the low pass filter. Didn't seem to have much effect. Didn't find an oscilloscope, but found and bought a Perytech DSO-U2200 USB Oscilloscope for use with a PC. Now I have to try it out. Never used one much, so I have to read up and refresh.

    I just had some success with different connections on the axis command cables. First tried to minimize the exposed unshielded wire on the command cables. My cables were originally shield drained at the drives. I tried switching the shield drain to the Kanalog board.

    Turns out, as long as the axis shield drains are both disconnected at the drives, jogging does not affect the spindle.

    It doesn't seem to matter if the shields at the Kanalog end of the command cables are connected to each other or to Kanalog ground. As long as they are not connected to the drives, the spindle is not affected by axis jogging.

    I had them connected at pin 2, marked Signal Gnd, on the AMC 30A8 drives.

    Connecting even just one shield drain at an axis drive causes spindle jerking when jogging X or Z.

    As of now, axis and spindle command cable shield drains are connected to Kanalog ground and not connected to drives.

    Spindle still vibrates a little when enabled. It may be that tuning would help with that.

    Sorry to take so much of your time before I tried this.

    Thoughts?



  2. #242
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3766
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Charles,

    Interesting. I think that indicates sig GND on the drives is a source of noise. You might look at with your scope relative to Kanalog GND.

    Regards
    TK http://dynomotion.com


  3. #243
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Tom,

    As you suggested, I checked the AMC drive sig GND with the scope. Trying to remember the little I knew about using a scope. Looks like a lot of noise on the drive sig GND without moving the axis. See first picture, checking X drive. Noise is much worse when moving either axis. Second picture is when moving axis. Spindle still trembles a little when enabled.

    Attached Thumbnails Attached Thumbnails Warner/Swasey QCM-6 lathe with Kflop/Kanalog-scopetest2-png   Warner/Swasey QCM-6 lathe with Kflop/Kanalog-33-png  


  4. #244
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3766
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Charles,

    That's huge more than 15V? You might do a sanity check by checking something like Kanalog +5V. It should be 5V with small noise < 0.1V.

    The period seems to be ~50us or 20KHz likely the switching frequency of the amp.

    Regards
    TK http://dynomotion.com


  5. #245
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Tom,

    I may have something wrong in the scope setup. Using 10X on the probe.

    Checked the 5V on Kanalog to Kanalog ground. See first image.

    Checked the AMC drive Signal Ground to Kanalog ground. AMC block diagram notes that Signal ground and Power Ground are internally connected for "Non-ISO" configuration. See second image.

    Attached Thumbnails Attached Thumbnails Warner/Swasey QCM-6 lathe with Kflop/Kanalog-scope11-png   Warner/Swasey QCM-6 lathe with Kflop/Kanalog-scope10-png  


  6. #246
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3766
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Charles,

    +5V test shows scaling is correct. 20V differences between GNDs seems crazy. I suppose one or the other is floating.

    Regards
    TK http://dynomotion.com


  7. #247
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Hi Tom,

    Will look at scope readings again.

    New problem: When I try to Save/Compile/Download/Run a C program, I get a message:

    DSP_KFLOP.out Date Stamp Doesn't match KFLOP Firmware

    It says the Firmware is 4.35f and the .out file is 4.34.

    It tries to load from the 4.34_back folder. I tried to force it to load from the 4.35f folder, but it comes back after loading and restarting with the same mismatch error.

    Thanks



  8. #248
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    See attached

    Attached Thumbnails Attached Thumbnails Warner/Swasey QCM-6 lathe with Kflop/Kanalog-kflopmismatch-png   Warner/Swasey QCM-6 lathe with Kflop/Kanalog-flash01-png   Warner/Swasey QCM-6 lathe with Kflop/Kanalog-flash02-png  


  9. #249
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3766
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    Make sure you are running the KMotion435f\KMotion\Release\Kmotion.exe. Check Help About.

    Regards
    TK http://dynomotion.com


  10. #250
    Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    192
    Downloads
    0
    Uploads
    0

    Default Re: Warner/Swasey QCM-6 lathe with Kflop/Kanalog

    That did it. I had the shortcut going to KMotion434.

    Private message sent.

    Thanks



Page 13 of 13 FirstFirst ... 310111213

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Warner/Swasey QCM-6 lathe with Kflop/Kanalog

Warner/Swasey QCM-6 lathe with Kflop/Kanalog

Warner/Swasey QCM-6 lathe with Kflop/Kanalog