Need Help! Mach 3 does not recognize home position.


Page 1 of 2 12 LastLast
Results 1 to 12 of 13

Thread: Mach 3 does not recognize home position.

  1. #1
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Mach 3 does not recognize home position.

    Trying to get the Turn module to work correctly within Kmotion. Tom K helped get all set up with C files. The problem I have is that I cannot seem to get Mach to recognize a homed position.The LED lights are always red. The home buttons do not work,but you can type G28 in the command line and the machine moves to the homing switches correctly, but I get no indication of LED turning green for either axis. I believe that means I cannot set up coordinates for auto operation to happen in the correct place. The motor home soft limits are set to auto zero. I tried to change the G28 home location coordinates in this tab to the actual .25 back off from limit positions, but that did not change anything.I have gone through the Turn manual and cannot find anything else to check. Thanks for any suggestions.
    I have also tried just moving the axis to a safe location and clicking on the home x and home z buttons and that does not seem to work either.

    Thanks,
    Scott

    Similar Threads:


  2. #2
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3221
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Scott,

    Strangely it seems the standard Lathe 1024.lset screens don't have anything assigned to the HomeX, HomeY, or HomeAll buttons. Switching to the standard 1024.set screens for a mill and Pushing the Ref All button works for me. The Ref All button has the Basic Script:

    DoButton( 24 )
    DoButton( 23 )
    DoButton( 22 )
    DoButton( 25 )

    DoOEMButton(133)
    DoOEMButton(134)
    DoOEMButton(135)

    I downloaded a Mach3 Screen editor from here and used it to add that Basic Script to the Home All Button in 1024.lset. I saved that as 1024TK.lset (see attached).

    Please load this screen set (Mach3 | View | Load Screens) to see if the Home All button then does something.

    Attached Files Attached Files
    Regards
    TK http://dynomotion.com


  3. #3
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Well I have pretty well screwed things up again.I tried to follow your instructions and did so on my office computer so as not to mess up the lathe computer. Was finally able to use the editor to copy and paste the missing code into the turn file. Then tried to reference the axis and it worked.
    I thought I knew what I was doing at that point so I went out to the lathe computer and thought I did the same thing. My turn screen disappeared. I tried to recover the screen several times without success. Forgetting that you also changed several things in Mach to work with Kmotion, I reloaded the Mach 3 download. Now it locks up if you try to reinstall the screen set for turn. It also triggers a message Art error code 9991. When I open other screen sets and try to hit the reset button I get a message- Init.c not found. I tried Kmotion to see if it is still working and it will still run the programs as it did before,but the spindle does not run with program M commands or the command line inputs.I did copy the 4 c files and the 433 file to a flash drive right after you got it all set up.The method used the time it initially worked on the other machine was as follows: with Mach Screen open, we clicked view>load screens>open 1024.lset with notepad>copy and paste the seven lines of code from your 1024TK.lset.txt into the very end of the 1024.lset notepad file>save. The method used on the machine hooked up to the lathe was the same. When that created the error code, we copied and pasted the entire 1024TK.lset.txt file over the programs 1024.lset notepad file and that did not help either. I do not want to try to reload the c files or go any further without your help.
    Scott



  4. #4
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    When I went back to the office computer after closing out, I had no turn screen and got another Art error code. I got my laptop out and had success with it. I just downloaded the 1024 TK.lset.txt and dropped it into the main Mach folder. Went to the turn module/view and typed it in to the search tab. Your modified screen opened and the axis both zeroed. Moved away from zero and the x and z return to home buttons work. The home all seems to just zero out the settings, but I can live with that. Closed out and came back in a few times and it works every time.



  5. #5
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3221
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Scott,

    Was finally able to use the editor to copy and paste the missing code into the turn file.
    Not sure what you mean by this. What file? I already made a screen set with the code in place for the Home All Button, All you should need to do is save the file I posted. Remove the .txt extension. Then select it in Mach3.


    I reloaded the Mach 3 download. Now it locks up if you try to reinstall the screen set for turn. It also triggers a message Art error code 9991.
    You probably damaged the Turn Screen set by trying to edit it. You can't really edit screen sets a Mach3 screen designer should be used to modify them.


    When I open other screen sets and try to hit the reset button I get a message- Init.c not found.
    All the Mach3 configuration is saved in a Profile File. All the settings changes and configuration settings I made for you are saved in a Profile. Probably called Mach3Turn.xml. If you don't have any of the changes then by default the Reset Button will attempt to run Init.c which probably doesn't exist. So this is more of an issue with having the wrong Profile not the wrong Screen set.


    When I went back to the office computer after closing out, I had no turn screen and got another Art error code. I got my laptop out and had success with it. I just downloaded the 1024 TK.lset.txt and dropped it into the main Mach folder. Went to the turn module/view and typed it in to the search tab. Your modified screen opened and the axis both zeroed. Moved away from zero and the x and z return to home buttons work. The home all seems to just zero out the settings, but I can live with that. Closed out and came back in a few times and it works every time.
    I don't really follow all of that. Still doesn't seem as the Home All button is really homing. Without Homing then "Zero" will probably be where the axis is when powering up. So return to Home will probably go there.

    Note if you load my screen set you can check if the Home All code is properly assigned to the button by selecting Mach3 | Operator | Edit Button Script. The buttons with code assigned should then be blinking and you can then click a blinking button to see the code.

    HTH

    Regards
    TK http://dynomotion.com


  6. #6
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    HI Tom, Thanks for your answers. I do not see how to proceed from what you said. You indicated that I probably damaged the turn screen set. Do I need to try to download mach 3 again? Am I looking for a problem in just Mach 3 or in both Mach and the C files for Kmotion? There must be a problem in C files since Kmotion no longer turns the spindle on ? I have included a snip of the very end of the mach3 turn xml file that is in the lathe. Do these look to still be what you would have written?

    Attached Thumbnails Attached Thumbnails Mach 3 does not recognize home position.-mach3-turn-xml-12-2-19-png  


  7. #7
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3221
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Scott,

    You indicated that I probably damaged the turn screen set. Do I need to try to download mach 3 again?
    No. You should be able to just use the Screen Set I posted here previously.


    Am I looking for a problem in just Mach 3 or in both Mach and the C files for Kmotion? There must be a problem in C files since Kmotion no longer turns the spindle on ?
    Probably both. Those should be two separate and independent problems.

    I'd work on getting KMotionCNC Spindle commands working first. You might determine if you can control the Spindle from KMotion.exe using Console Jog Commands first. It might just be disabled or something.


    I have included a snip of the very end of the mach3 turn xml file that is in the lathe. Do these look to still be what you would have written?
    Yes that looks to contain my changes. See the filenames to the CNCLathe directory that we created. I do see a reference to V4.33 Dynomotion Plugin. That might have been my mistake that we never updated the Mach3 Plugin to V4.35b Version like we are running KMotionCNC from. This may or may not be a problem. It would be best to re-install KMotion 4.35b to have it install the Mach3 Plugin properly again. You might rename the current C:\KMotion435b folder to save it while re-installing KMotion and then reinstate it afterwards.

    Regards
    TK http://dynomotion.com


  8. #8
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Tom, I tried the Kmotion DAC commands for spindle and they work as they should. The 435 B indication shows in that DAC command window. I do not know exactly where else to look for the designation. I looked at the beginning of all the 4 C program files you used and do not see any designation. Is it in Mach 3 you wanted me to look? Is there a way I can save all the Mach 3 files/settings out of the operating system and then uninstall all the Mach files from the operating system so that I can do a clean new download of Mach3? I had to delete and reinstall Mach 3 in my office computer before I could get rid of the ART error codes which is the same problem I have in the lathe computer. The office computer works as it should now. I think Mach being corrupted is my main problem and want to delete because I have found just reloading mach over an existing set of files does not clean up problems in the previous load. Hope I am making sense. Thanks again Tom.
    Scott



  9. #9
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3221
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Scott,

    I tried the Kmotion DAC commands for spindle and they work as they should.
    ok great, DAC commands are working. Next try Jog commands. I believe your Spindle Axis is #4? If so then try Jog4=10000. Of course the Axis needs to be configured and enabled by running the Initialize Program first. Check the Axis Screen to see if the axes are enabled.

    Regards
    TK http://dynomotion.com


  10. #10
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Yes the jog commands work. I can jog in both directions and at varying speeds.
    Thanks,
    Scott



  11. #11
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3221
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Scott,

    Yes the jog commands work. I can jog in both directions and at varying speeds.
    great. Next check if KMotionCNC | Tool Setup | M3 M4 M5 S Actions are configured to use the Correct Jog Programs. Post a screen shot.

    What happens when you enter M3 S500 in KMotionCNC's MDI? Check for anything printed on the KMotion.exe Console Screen.

    Regards
    TK http://dynomotion.com


  12. #12
    Member
    Join Date
    May 2009
    Location
    United States
    Posts
    57
    Downloads
    0
    Uploads
    0

    Default Re: Mach 3 does not recognize home position.

    Hi Tom,
    I have attached a shot of the tool setup. Kmotion is acting real erratic. I entered the m03s500 and it worked. Did so a couple more times and it worked. Ran a program with M03 in it and it worked. I then changed to M04 and tried to run program and it was ignored. Reinitialized and tried again and the spindle started and ran to full speed and tripped out the drive. Tried the M04 from the command line and it started but only ramped to 4 rpm.The only message I saw on the console screen was following error when the drive failed to start. The x and z axis always work right. I did try the speed slider when the m03 worked correctly and the speed varied like it should.
    Thanks,
    Scott

    Attached Thumbnails Attached Thumbnails Mach 3 does not recognize home position.-tool-setup-12-4-19-jpg  


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Mach 3 does not recognize home position.

Mach 3 does not recognize home position.

Mach 3 does not recognize home position.