Newbie Lagun FTV3 - Page 2


Page 2 of 3 FirstFirst 123 LastLast
Results 13 to 24 of 34

Thread: Lagun FTV3

  1. #13
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Just when I was getting somewhere.

    Everything is unpluged from Kflop. 5v and my usb cable connected. The led lights on kflop flash once and turn solid. My computer doesnt reconize the klop. And I cant cant find it in device managers.
    Is it possiable to repair the kflop or do I need to order a new one?
    Kanalog board ok?

    I had my encoders on the same 5v supply for kflop. Wont be doing that again.



  2. #14
    Member Jim Dawson's Avatar
    Join Date
    Dec 2013
    Posts
    3838
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Quote Originally Posted by jeepguy88 View Post
    I had my encoders on the same 5v supply for kflop. Wont be doing that again.
    That should be the correct way to do it. The 5V supply should be common to both since the signal from the encoders are connected to the Kanalog. Not sure what happened there. But if I recall correctly there is a jumper on the Kflop board that needs to be changed when using an external 5V supply rather than the USB port 5V supply. Check the Kflop documentation.

    Jim Dawson
    Sandy, Oregon, USA


  3. #15
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Thanks Jim, always to the rescue. lol Ill try and look through that later today.
    I had the 5v for the encoders exposed. I moved somethings around, didnt notice I bumped something and moved a wire that pushed the +\- for the encoders together. The 5v supply is suppose to have "short protection". It did short that out.



  4. #16
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3219
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Hi JeepGuy,

    Only one blink of the LEDs indicates it thinks there isn't any USB connection. You might try a different USB cable, or USB port, or PC.

    The encoders do need to be common GND to KFLOP/Kanalog as Jim describes.

    KFLOP+Kanalog requires more power than USB can supply so an External +5V Supply is required. KFLOP by itself can run from USB.

    Leaving the USB Power Jumper in with External +5V applied feeds back +5V to the PC which is not a good idea and should be avoided but doesn't usually cause a problem.

    Hard to tell if Kanalog is working without a working KFLOP.

    Its not cost effective for us to repair KFLOPs. It may be just the U10 USB interface IC since most of the rest of KFLOP needs to work to light the LEDs. If you want to try repair yourself the part # is:
    FTDI FT245RL DigiKey 768-1011-A-ND

    Regards
    TK http://dynomotion.com


  5. #17
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    All good info.
    So Kflop lights on are kinda good?
    I tried just the USB and lights would come on, but was not able to connect to the computer. I'll try another cable and computer and see what happens. If that doesnt work, the link for the part you sent is only $4.50. Thats worth a try.



  6. #18
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Different cable, different computer, nothing. Just lights blinking once and then solid. Ill try that part, I dont know if my soldering skills are that good, but worth a shot before I order a new kflop.
    I cant be the first guy to short out the 5v supply.



  7. #19
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3219
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Hi JeepGuy,

    So Kflop lights on are kinda good?
    Yes, much of KFLOP (DSP, Boot FLASH, SDRAM, FPGA Configuration) must work for that to occur. But that doesn't mean those might not be partially damaged in some manner.


    I cant be the first guy to short out the 5v supply.
    Shorting the 5V supply would be similar to turning it off. Maybe something else happened or it caused a spark.


    I dont know if my soldering skills are that good
    If you don't have proper hot air soldering tools to remove the 28 pin IC I find cutting all the pins flush with the IC body with a razor blade can then allow you to use a soldering iron to remove each pin separately. Then cleanup the pads with solder wick before installing the new IC.

    Regards
    TK http://dynomotion.com


  8. #20
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Waited all week for that usb interface chip. Was not successful at getting it replaced. Ordered a new kflop. Hope my kanalog is still good....



  9. #21
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    New kflop and Im back in action! Now to continue tuning



  10. #22
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Tuning coming up, current problem is encoders.
    I cant seem to get the z axis encoder to read anything in kmotion. X and Y encoders work perfect
    X axis encoder has A+A-B+B-Z+Z-
    Y axis encoder only has A+B+Z+
    Z axis encoder only has A+B+Z +

    I took the y axis encoder all a apart. Same model # as X axis and same 8 connecters on the outside but inside its only wired or 5 options. +\- and ABZ. The Z axis encoder is wired the same way,and installed on the kanalog the same way.
    Z encoder KAnalog
    A+ to A2+
    B+ to B2+
    Z+ to A5+

    Measuring Z axis encoder voltage from 5v+ to A+B+Z+ is all 0.15v the same as measuring Y axis encoder. I think the z axis encoder is fine, Im probably not doing something correctly or I missed a step that I did for Y axis



  11. #23
    Member Jim Dawson's Avatar
    Join Date
    Dec 2013
    Posts
    3838
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Check the voltage from A+ to -5V or common as you turn the encoder very very slowly. The voltage should go from near 0 to about 5V as the encoder sends pulses. Then do the same with B+. And with Z+, but Z only has one pulse per encoder revolution so sometimes is a bit hard to find.

    Jim Dawson
    Sandy, Oregon, USA


  12. #24
    Member jeepguy88's Avatar
    Join Date
    Oct 2019
    Posts
    19
    Downloads
    0
    Uploads
    0

    Default Re: Lagun FTV3

    Hi Jim Thanks for the reply!
    5v+ to Common is 4.9v
    Measuring Common to A+ checks out and B+ Checks out. Voltage varies with rotation. Measuring Z+ is a solid 4.8v. Measured the Y Axis and it reads identical Z+ is solid 4.8v. I think that rules out the encoder?
    I did not have the Z encoder hooked up to anything when I shorted the kflop earlier.



Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Lagun FTV3

Lagun FTV3

Lagun FTV3