Newbie Konnect boards do not communicate with KFlop


Results 1 to 11 of 11

Thread: Konnect boards do not communicate with KFlop

  1. #1
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Question Konnect boards do not communicate with KFlop

    I have been in design mode for a DIY cnc router for more two years and am now testing circuitry for the KFlop and Konnect boards. When initializing the Konnect boards to set up the virtual bits, I get the error message "COMM ERROR AUX1 0 (signature not A5)". (I am using the provided C program Konnect2boards.c.) Based on my reading of the manual and forum(s), the error message indicates the hex value A5 should be returned, and not hex 0. Getting a sense of the protocol from the documentation, KFlop bits IO34 and IO35 are used for CLKIN and STARTIN respectively. From the error message the data pins were not toggled, (none of the bits 0-7 were toggled high to indicate a hex value). Using an oscilloscope, I thought to first monitor the CLKIN and STARTIN pins on JP6 port-KFlop board while running the Konnect2boards.c program. The scope indicates the IO34 and IO35 bits, (pins 15 and 16 on JP6) float at either 0 or ~2 volts and to not toggle. I am concluding that without clocking on the port, no hex values are set. Note that this test was conducted without the Konnect cable inserted into JP6 and it may be possible that IO34 and IO35 will not toggle without a connection to ground. At least this is a starting point to diagnose the communication problem.

    Anyone's kind advice is greatly appreciated.
    Thanks, Dave S.

    Similar Threads:


  2. #2
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi Dave,

    Do you have 2 Konnect boards connected and daisy chained onto KFLOP JP6?

    Does one Konnect board have the address set to 0 (no jumpers) and the other set to address 1 (A0 installed, A1 and A2 removed)?

    Regards
    TK http://dynomotion.com


  3. #3
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi Tom,
    Yes, that is correct. In the past hour, I have been using a logic analyzer to view activity on the JP6 port, again without the Konnect boards plugged in. No toggling of either the clock or DIO pins.
    Before I responded, I attempted again to plug my 2 Konnect boards in and run Konnect2Boards.c on Thread 1. Same error "COMM ERROR AUX1 0 (signature not A5)".
    Dave S



  4. #4
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi, Tom:
    In order to back up a bit, I have connect a single Konnect board, using the supplied 3" ribbon cable to JP6, and ran KonnetEnable.c. Same error "COMM ERROR AUX1 0 (signature not A5)".



  5. #5
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi Dave,

    Strange.

    Good idea to start with a single Konnect. I assume you meant EnableKonnect.c

    The sequence is KFLOP writes 2 Output Bytes (2 clocks) the reads 4 Input Bytes (4 clocks) then reads the A5 signature byte (1 clock) and if the signature is incorrect it stops and displays the error message. You should see CLOCK and START (IO 34 and 35) set as Outputs on the Digital IO Screen. So you should see the clock toggle at least a few times before stopping without any Konnect attached each time the EnableKonnect.c is Executed.

    Can you see IO 34 and 35 being configured as Outputs?

    If you toggle IO 34's state with the Digital IO screen does the bit change on the screen and does your scope see the change?

    What Version of KMotion are you using?

    Have you flashed any Configuration or Programs into KFLOP? If so reset to none and defaults using Flash New Version, re-boot, and do not run any other programs or set any configuration.


    Here is a program to continuously attempt to Initialize one Konnect board a few times per second to make it easier to scope.
    Code:
    #include "KMotionDef.h"
    
    // Configure KFLOP to service Konnect 32 Input 16 output IO board
    // Board address is 0, 
    // 16 Outputs are mapped to Virtual IO 48-63 (VirtualBits)
    // 32 Inputs are mapped to Virtual IO 1024-1055 (VirtualBits[0])
    
    main()
    {
        for (;;)
        {
            InitAux();
            AddKonnect(0,&VirtualBits,VirtualBitsEx);
            Delay_sec(0.2);
        }
    }


    Regards
    TK http://dynomotion.com


  6. #6
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi, Tom:
    OK, I will go back to JP6 and follow your instructions.
    Thanks.
    Dave S.



  7. #7
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi, Tom:

    IO34 and IO35 are configured as outputs.

    I do not see my scope change when I toggle IO34 or IO35. IO34 stays fixed at 2.2 volts and IO35 stays at 0.0 volts.

    I am running version 4.34, confirmed by the Version C program.

    I flashed the New Version, same as Version 4.34.

    Rebooted using the Reboot! program.

    I used the example program to initialize a single Konnect board and get the same error message every .2 seconds.

    Back to JP4, while running the example program, with my scope, I can see the CLKIN pin toggling. (Not sure yet of the exact IO number.)

    Dave S



  8. #8
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi Dave,

    Hmmm Its looking like IO35 and IO36 on KFLOP have somehow been damaged. If they were configured as Step/Direction Outputs they would not work as General Purpose IO which is why I asked whether anything was configured or and C programs run or flashed to do this. But Flashing New Version and re-booting should eliminate any such possibility.

    Does KFLOP Jumper J2 have a jumper between pins 1 and 2? If not install it. This controls the supply voltage for some of the KFLOP IO. If not installed some IO will not have power and will not work.

    If so, then test KFLOP IO 34 and 35:

    1 - Flash New Version again to be absolutely sure

    2 - Cycle Power to re-boot

    3 - do nothing other than below

    4 - Restart KMotion.exe

    5 - Use Digital IO Screen to check IO 34 and 35 as Outputs

    6 - Use Digital IO Screen to Toggle state of IO 34 and 35 while checking voltage of JP6 pins 15 and 16 respectively (should observe near 0V and 3.3V)

    Regards
    TK http://dynomotion.com


  9. #9
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi, Tom:
    J2 jumper between pins 1 and 2 is set.
    1-Flashed version - Check.
    2-Cycle power, reboot- Check.
    3-do nothing - Check.
    4-Restart Kmotion.exe -Check.
    5-Digital IO Screen... IO34 and IO35 are not checked as outputs. - Check
    6- With scope attached and toggling IO34 and IO35, IO34 (pin 15) is fixed at 2.7 volts, IO35 (pin 16) is fixed at 0.0 volts. - Check.
    Dead port, if so, can I proceed using JP4?

    Dave S



  10. #10
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi Dave,

    Just to be clear in step #5 they were not checked as Outputs but then you checked them to be Outputs. Correct?

    Any ideas how the IO might have been damaged? Those are 3.3V IO. Driving above 3.8V will damage them.

    The Konnects can be connected to either JP4 Aux0 or JP6 Aux1 just use the appropriate InitAux function.

    Regards
    TK http://dynomotion.com


  11. #11
    Member Beeker52djs's Avatar
    Join Date
    Nov 2018
    Posts
    13
    Downloads
    0
    Uploads
    0

    Default Re: Konnect boards do not communicate with KFlop

    Hi, Tom:
    Just to be clear in step #5 they were not checked as Outputs but then you checked them to be Outputs. Correct?
    <That is correct, the Outputs IO34 and IO35 were not checked when I first opened the Digital IO window in KMotion. I toggled them manually.>

    Any ideas how the IO might have been damaged? Those are 3.3V IO. Driving above 3.8V will damage them.
    < Not sure, but i would suspect that they were damaged by my making my own ribbon cable for the two Konnect boards. Before I started testing, I discovered that the connectors were reversed relative to the cable. I had flipped pairs of pins from the KFlop to the Kconnect board(s). I discovered that the connector alignment to the ribbon cable must consider the alignment tab in the connector as well as crimping the connector to the same side of cable. I my not being careful, I probably fried the IO34 and IO35 pins by connecting them to the 5 and 12 volts on pins 1 and 2. The corrected cable works fine on JP4.>

    So I will proceed with using JP4 going forward.

    Thanks much for your help in diagnosing my mistake. A word to the wise for anyone else reading this thread.

    Best Regards:

    Dave S.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Konnect boards do not communicate with KFlop

Konnect boards do not communicate with KFlop

Konnect boards do not communicate with KFlop