Need Help! Can’t turn on axis (after turn off machine during G-code)


Results 1 to 4 of 4

Thread: Can’t turn on axis (after turn off machine during G-code)

  1. #1
    Member RuslanRobot's Avatar
    Join Date
    May 2019
    Posts
    14
    Downloads
    0
    Uploads
    0

    Default Can’t turn on axis (after turn off machine during G-code)

    1. I pressed the button Home, - to home all axis (see file HOME_Axis.c). Machine start to go home, and during this I turned off the power.
    2. After 15 sec. I turn on the power. But in the screen of KmotionCNC all my axis are yellow.
    3. I restart computer and machine, in the screen of KmotionCNC all my axis are still yellow.
    4. In the screen of Kmotion > Axis, I found that axis 0, 1, 2, 3 are NOT Enable - somewhat unchek the boxes. Trying Enable axis, - but program don’t allow me to do this (it unchecks the box). But it allows me to Enable other axis 4, 5, 6, 7 - I don’t use these axis.
    5. I download in the Flash User Memory the file – see InitKStep4Axis.c. It doesn’t help, – after restarting machine, all axis are yellow, and in the menu Kmotion > Axis, I can’t Enable axis.

    How to Enable axis 0, 1, 2, 3? Why program don’t allow me to do this (it unchecks the boxes)?

    Similar Threads:
    Attached Files Attached Files


  2. #2
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Can’t turn on axis (after turn off machine during G-code)

    Hi RuslanRobot,

    Both programs have a loop disabling axes 0-3 if virtual bit 1024 (ESTOP) is not 1. See a fragment of your code below:

    Code:
    #define ESTOP_BIT 1028
    
    		// if ESTOP present disable any enabled Axis ??
    
    		if (ReadBit(ESTOP_BIT)!=1)                  // ÈÍÂÅÐÒÈÐÎÂÀÒÜ ÑÈÃÍÀË 
    		{
    			if (ch0->Enable) DisableAxis(0);  // axis still enabled?  - Disable it
    			if (ch1->Enable) DisableAxis(1);  // axis still enabled?  - Disable it
    			if (ch2->Enable) DisableAxis(2);  // axis still enabled?  - Disable it
    			if (ch3->Enable) DisableAxis(3);  // axis still enabled?  - Disable it
    		}
    Bit 1024 (ESTOP) is Konnect Input 0.

    Is ESTOP on?

    Regards
    TK http://dynomotion.com


  3. #3
    Member RuslanRobot's Avatar
    Join Date
    May 2019
    Posts
    14
    Downloads
    0
    Uploads
    0

    Default Re: Can’t turn on axis (after turn off machine during G-code)

    Yes!!!!
    I am idiot. I tried to make Kflop work while ESTOP is on.....
    Everything is work.
    Thank you very much!



  4. #4
    Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3137
    Downloads
    0
    Uploads
    0

    Default Re: Can’t turn on axis (after turn off machine during G-code)

    Ha ha. Thanks for taking the time to post back.

    Regards
    TK http://dynomotion.com


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Can’t turn on axis (after turn off machine during G-code)

Can’t turn on axis (after turn off machine during G-code)

Can’t turn on axis (after turn off machine during G-code)