Y axis limit switch not detecting or it detects at zero


Results 1 to 2 of 2

Thread: Y axis limit switch not detecting or it detects at zero

  1. #1
    Gold Member amitkumar171's Avatar
    Join Date
    Aug 2017
    Location
    India
    Posts
    108
    Downloads
    0
    Uploads
    0

    Default Y axis limit switch not detecting or it detects at zero

    Hi all ,

    I am using Kflop Board , in that board i am connecting pin IO 0 AND IO 6 to my limit switch for y axis. IO0 for positive and IO1 for negative.

    When i am trying to move y axis from 0 to positive it detects the limit switch and stops the axis.

    similarly from 0 to negative direction it is detecting and stopping the axis. That it is supposed to do.

    But when i am trying to move from +10 to 0 it only detects when it reached 0 whether it detects limit or not it reaches to 0 and stops.

    Similarly if am moving y axis from -10 to 0 it only detects when it reaches 0 before that whether it detects limit or not it reaches to 0 and stops and detects limit at 0.


    It only happening in y axis as axis channel generator 1, all other axis and their limits are working fine.

    Please solve my issue.

    Waiting for your kind reply

    Similar Threads:
    Regards

    Amit Kumar


  2. #2
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    3021
    Downloads
    0
    Uploads
    0

    Default Re: Y axis limit switch not detecting or it detects at zero

    Hi Amit,

    Check if your Soft Limits are set correctly. Post your Initialization file.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Y axis limit switch not detecting or it detects at zero

Y axis limit switch not detecting or it detects at zero