Problem Problems in CSS and Feed per rev mode


Results 1 to 4 of 4

Thread: Problems in CSS and Feed per rev mode

  1. #1
    Registered
    Join Date
    Apr 2018
    Location
    Czech Republic
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Problems in CSS and Feed per rev mode

    Hello

    I have some problems in KMotion V4.34j.


    First problem is that the machine stop movement after start running G01 with mode Feed per Rev G95.

    Example G code:

    G18 (XZ plane)
    G21 (mm units)
    G54
    M06 T1002
    G96 D2500 S100 M03 (CSS mode)
    G00 X23.412 Z0.407
    G01 G95 X21.998 Z-0.3 F0.1 <<-- at this row it stops

    There is no error or warning dialog. Spindle is running, but nothing moves.

    Second problem:
    In mode CSS (G96) the KMotionCNC show wrong surface speed in diameter mode. Speed is two times bigger than it should be.
    Spindle speed in RPS is good.
    In code KMotionCNCDlg.cpp at row 5700 – it counts with radius. Perhaps this should extend to the diameter mode.

    Third problem:
    Why after tool change is not set tool offset to actual position? In example C Programs\ToolChanger Service with M6 trig.

    Fourth small problem:
    In docs is swapped G code description - G96 Spindle RPM mode / G97 Dmax CSS mode
    On page G Code Screen in left panel.
    G96 is CSS mode and G97 is spindle RPM mode.

    I have three kflop boards with one kanalog, but this is first time I use it in CNC lathe.
    In attachment is C init script and screen of KMotionCNC TP.


    Thanks,

    Lukas

    Similar Threads:
    Attached Thumbnails Attached Thumbnails Problems in CSS and Feed per rev mode-kmotioncnc_tp-jpg  
    Attached Files Attached Files


  2. #2
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2790
    Downloads
    0
    Uploads
    0

    Default Re: Problems in CSS and Feed per rev mode

    Hi Lukas,

    First problem is that the machine stop movement after start running G01 with mode Feed per Rev G95.

    Example G code:

    G18 (XZ plane)
    G21 (mm units)
    G54
    M06 T1002
    G96 D2500 S100 M03 (CSS mode)
    G00 X23.412 Z0.407
    G01 G95 X21.998 Z-0.3 F0.1 <<-- at this row it stops

    There is no error or warning dialog. Spindle is running, but nothing moves.
    It might be that your Spindle Encoder is counting backwards. Please try reversing it in KFLOP by changing the sign of the InputGain0 parameter.

    Second problem:
    In mode CSS (G96) the KMotionCNC show wrong surface speed in diameter mode. Speed is two times bigger than it should be.
    Spindle speed in RPS is good.
    In code KMotionCNCDlg.cpp at row 5700 – it counts with radius. Perhaps this should extend to the diameter mode.
    I think you are correct. Please try this patch and let us know if it solves the problem.
    http://dynomotion.com/Software/Patch...KMotionCNC.exe

    Third problem:
    Why after tool change is not set tool offset to actual position? In example C Programs\ToolChanger Service with M6 trig.
    By GCode standard to enable Tool Length/Offset compensation G43Hxxx is required, then G49 to disable compensation.

    Fourth small problem:
    In docs is swapped G code description - G96 Spindle RPM mode / G97 Dmax CSS mode
    On page G Code Screen in left panel.
    G96 is CSS mode and G97 is spindle RPM mode.
    Thanks. We will correct this.

    Regards

    TK
    http://dynomotion.com


  3. #3
    Registered
    Join Date
    Apr 2018
    Location
    Czech Republic
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Re: Problems in CSS and Feed per rev mode

    Hi,


    first problem is solved as you said by changing the sign of the InputGain0 parameter.


    Your patch not work. Surface speed is still two times bigger.
    Can you post your code of this patch?


    In patch is new bug - the enter key does not work in code editor.




    Thanks,


    Lukas



  4. #4
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2790
    Downloads
    0
    Uploads
    0

    Default Re: Problems in CSS and Feed per rev mode

    Hi Lukas,

    Sorry the wrong file was uploaded. Please try again.

    Here is the added line:

    if (m_RealTimeSetup->DiameterMode) xp *= 0.5; // if result is a diameter, convert to radius to calc surface speed.

    The changed source module is here.

    HTH
    Regards

    TK
    http://dynomotion.com


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Problems in CSS and Feed per rev mode

Problems in CSS and Feed per rev mode