MACH3 hitting soft limits causes X axis to stall


Results 1 to 13 of 13

Thread: MACH3 hitting soft limits causes X axis to stall

  1. #1
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default MACH3 hitting soft limits causes X axis to stall

    Hi all thanks for having me here I shall post some pics of my machine a bit later on but for now was hoping some one might know whats going on.
    I have a CNC machine I built many years ago it has been running ok but I have noticed one odd thing.
    I have soft limits (no hard limit switches) and lets say I am manually returning the Z axis and X asis home if the Z axis gets to its limits first the X axis moto will give an odd twang noise (very odd as if the motor has a spring in it I cant explain it but shall posty a video) and some times stalls or makes an odd noise.
    It also does it if I am returning the Y axis the X axis will stall.

    The other thing is its ONLY the X axis that stalls if I return the Z axis while also moving the Y none will stall if one gets there first but does also give the twang like noise though the motor that has not reached its limits.

    I can post a pic and a video if need be a bit later on.
    I have been using this machine for a long time with not many issues this does not really cause an issue when cutting as I never hit the soft limits of any axis but would like to get it figured out.

    Thanks so so much in advance.

    https://i.imgur.com/3yw2nTr.jpg
    https://i.imgur.com/4gEJjPS.jpeg
    https://i.imgur.com/vGtYBu9.jpg
    https://i.imgur.com/YUERLSR.jpg
    https://i.imgur.com/L9LZQkV.jpg
    https://i.imgur.com/BgK4hK2.jpg
    https://i.imgur.com/CupcxMJ.jpg

    Similar Threads:
    Last edited by STK2008STK; 09-26-2020 at 12:18 PM. Reason: ADDED PHOTOS


  2. #2
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Sorry added pictures



  3. #3
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Sooo
    I have lowered the speed of the motors in Mach3 from 60 to 50 (it rounded it down to 49.??? for some reason) and does not do it now but I think this is just masking the real issue?.

    I did swap the X and Y over and the X was the one that still stalled so motor?.
    I am thinking it could be vibration as well? LOL I have no idea.

    If any one has any ideas that would be great

    thanks again all



  4. #4
    Member
    Join Date
    Mar 2010
    Location
    United States
    Posts
    575
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    I would try by starting to swap cables, electronics from one axis to another and see if the problem follows the cable, if not then swap them back.

    Then I would try swapping the drivers from one motor to another and see if the problem follows, etc.

    Lots of smarter people on the forum than I but that's where I would start.

    Adam,

    G540, Rack and Pinion Drives-X/Y axis, 1/2-Ball Screw-Z Axis w/THK HSR 25 Linear Slides, Steppers KL23H2100-35-4B, Power Supply-KL-600-48


  5. #5
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Hi thank you for your reply.
    I did swap the drivers over though I have not yet swapped the cabling going to the motor yet thats a bit more involved lol.

    Its the noise the motors make when one of the other motors gets to the homeing position first its odd I am going to make a video .

    Thanks again for replying appriciate it



  6. #6
    Member
    Join Date
    Mar 2010
    Location
    United States
    Posts
    575
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    If you swapped the motors then it couldn't be the motor...

    G540, Rack and Pinion Drives-X/Y axis, 1/2-Ball Screw-Z Axis w/THK HSR 25 Linear Slides, Steppers KL23H2100-35-4B, Power Supply-KL-600-48


  7. #7
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    No sorry I never swapped the motors I meant thats the next plan and cabling.
    I have only swapped controllers at the moment.

    For now I am having to leave it as I need the machine its running fine but as said would like to figure it out at some point

    Thanks for replying appriciate it



  8. #8
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    11541
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Quote Originally Posted by STK2008STK View Post
    Sooo
    I have lowered the speed of the motors in Mach3 from 60 to 50 (it rounded it down to 49.??? for some reason) and does not do it now but I think this is just masking the real issue?.

    I did swap the X and Y over and the X was the one that still stalled so motor?.
    I am thinking it could be vibration as well? LOL I have no idea.

    If any one has any ideas that would be great

    thanks again all
    You only stall a motor if it hits a solid stop, so when you home the machine what do you have for the Home offset add a number in here and when you have homed your machine activate the soft limit button and test it by jogging it until it stops, if your setup is correct it will stop before it hits your hard stop

    Check the travel set numbers as well it's a setup problem not a motor problem

    Mactec54


  9. #9
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Its not hitting the machine frame honestly the X axis could be in the centre moving towards the home position and if the Z or Y axis reaches home first the X axis will stall its very odd.
    As said there is a very odd twang noise coming from the motots that do not reach home if one of the other motors reaches it first almost like electrical feedback,noise ETC I am going to have to make a video but might be hard to hear.

    Thanks again for replying I am going to get a video up today .



  10. #10
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    OK back all with videos.

    So as you can see if I move the Z or Y axis and either one reaches home first then X will stall if its still moving.
    If I move Z and Y and either one reaches its hme neither one will stall its only X that stalls.

    I have also incuded a video called TWANG LOL in this video I have dropped the speed of the motors to 50 and the X axis does not stall (or very rare any way) at the above condition BUT you can hear the TWANG from the motors that I was talking about..

    here are the videos







    Thanks in advance



  11. #11
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    11541
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Quote Originally Posted by STK2008STK View Post
    OK back all with videos.

    So as you can see if I move the Z or Y axis and either one reaches home first then X will stall if its still moving.
    If I move Z and Y and either one reaches its hme neither one will stall its only X that stalls.

    I have also incuded a video called TWANG LOL in this video I have dropped the speed of the motors to 50 and the X axis does not stall (or very rare any way) at the above condition BUT you can hear the TWANG from the motors that I was talking about..



    Thanks in advance
    Turn the soft limit button off

    Home the machine

    Once you have moved all axis away from Homed position then set the Soft Limit Button On

    The axis will lock if the machine is not homed correctly with the Soft Limits Active

    Mactec54


  12. #12
    Member STK2008STK's Avatar
    Join Date
    Feb 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    UHHH ? if I turn off the soft limit home switch and move the machine to home it will hit the frame I have no hardware limits.
    or am I not understanding (very likely lol)

    Thanks



  13. #13
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    11541
    Downloads
    0
    Uploads
    0

    Default Re: MACH3 hitting soft limits causes X axis to stall

    Quote Originally Posted by STK2008STK View Post
    UHHH ? if I turn off the soft limit home switch and move the machine to home it will hit the frame I have no hardware limits.
    or am I not understanding (very likely lol)

    Thanks
    Then you can't use Soft limits correctly without a Home / limit switch, the software has no way to know where the machine limits are without it

    Having Soft limits turned on will lock the axis up if it has not been homed to a switch somewhere

    So try this at every startup move the machine axis ( Soft Limit Button Off ) as far as they can go without it getting to the end of travel, zero out the X Y Z axes move away from that point and then turn on the soft limits now you should be able to move any axis up to that point if that is setup in the homing and soft limit page

    Mactec54


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

MACH3 hitting soft limits causes X axis to stall

MACH3 hitting soft limits causes X axis to stall

MACH3 hitting soft limits causes X axis to stall