Need help tuning/setup i think ? Semi neewbie with new machine


Results 1 to 11 of 11

Thread: Need help tuning/setup i think ? Semi neewbie with new machine

  1. #1
    Member
    Join Date
    Aug 2016
    Location
    Denmark
    Posts
    24
    Downloads
    0
    Uploads
    0

    Default Need help tuning/setup i think ? Semi neewbie with new machine

    Hi all..

    Ok ., about a year and a half ago i built my first cnc... I sourced parts to make the workbee 1500x1500 cnc design.. and went with a bob from a company in france called Axemotion and bought their breakout board called Pulsar ,, reason for that decicion was that i already own a 30 year old Isel/Tecno mill that i use software Galaad for... and the pulsar works with galaad..

    Well ., used that thing for MANY projects , but wanted more..

    So i designed my own machine and built it with what i at least think are quality parts.. Need help tuning/setup i think ? Semi neewbie with new machine-newcnc-jpg

    The size is rougly 1500x1600mm made with 8040 / 4040 extrusions from german Maytec. 1605 ballscrews. AMB 1050 fme-p di spindle.. Y plates and Z plates are 20mm aluminium , endplates are 8mm aluminium. NSK LM rails and guides..

    Steppers / drivers come from Longs : https://www.aliexpress.com/item/3280...2db64c4dpNIRNu

    Im currently using this powersupply as i am trying to get good speeds working : https://uk.farnell.com/ea-elektro-au...ble/dp/1437548

    This is the Axemotion Pulsar board : Need help tuning/setup i think ? Semi neewbie with new machine-pulsar-jpg I have 4 steppers ,, 2xY.... run as coupled... using inputs for limit switches.



    BUT non the less im having troubles... and even though im very good at running a diy cnc , and ok at building them i think ;)

    im not that good when it comes to setting them up..

    No matter what i try im having either stalling issues , or steppers moving only to one direction.. im stalling around 2400 mm/m and by what i understand i should be able to make it up to 4600 without problems..

    Im posting 6 pictures with the settings that are accessable for me ,,, " im leaving out the spindle settings cause i have that working perfectly :) "..


    Need help tuning/setup i think ? Semi neewbie with new machine-set0-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-set1-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-set2-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-set3-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-set4-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-set5-jpg

    Now the settings shown here are basicly default settings from galaad " this is not from my cnc machine that is used with another pc "..

    Now i know im probably asking ALOT .,,

    But if there are anyone in here that just knows how to work magic and knows everything there is to know about setting up machines ,, it would BE SO nice if they could write back and get me started to set this up.. cause i know im doing something wrong but have no clue to what it might be , so therefor im thinking it would be
    best to just start on Zero and work from there...

    I tried changing the microstepping to all different settings there is , but nothing seems to work now..

    And all the electronics worked with the workbee , its the same setup just on a new machine and with more voltage / amps possible.... before i was using the 36v supplies that came in the Longs set..

    Hope to hear from someone ;)

    In advance thx..

    Best regards ,

    Kristjan

    Similar Threads:
    Attached Thumbnails Attached Thumbnails Need help tuning/setup i think ? Semi neewbie with new machine-set2-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-set1-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-set0-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-newcnc-jpg  

    Need help tuning/setup i think ? Semi neewbie with new machine-set3-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-set4-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-set5-jpg   Need help tuning/setup i think ? Semi neewbie with new machine-pulsar-jpg  



  2. #2
    Member
    Join Date
    Apr 2004
    Location
    Oakland CA USA
    Posts
    5037
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Usually when stepper motors will only go in one direction, there turns out to be a wiring problem to account for that. Is that happening with all your motors, or just some of them? Stalling issues are a lot more common with steppers; often they can be cured by reducing the acceleration value significantly. Try cutting it in half and seeing if things improve. Another thing that can cause steppers to perform poorly at high speeds is a mismatch between a motor's inductance and the power being fed to it. How much inductance do those motors have, and how many volts are you giving them?

    Andrew Werby
    https://computersculpture.com/


  3. #3
    Member
    Join Date
    Aug 2016
    Location
    Denmark
    Posts
    24
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by awerby View Post
    Usually when stepper motors will only go in one direction, there turns out to be a wiring problem to account for that. Is that happening with all your motors, or just some of them? Stalling issues are a lot more common with steppers; often they can be cured by reducing the acceleration value significantly. Try cutting it in half and seeing if things improve. Another thing that can cause steppers to perform poorly at high speeds is a mismatch between a motor's inductance and the power being fed to it. How much inductance do those motors have, and how many volts are you giving them?
    Hi..

    Tomorrow im gonna double check all wiring.

    Inductance is said to be 6.8 +-20% mh/ phase and im feeding 48v and limiting 12amps max from psu..

    Now dummie question : how do i find out what acceleration values should be , i dont know current setting by memory but will check on that tomorrow also..

    And thx mate for the reply.



  4. #4
    Member
    Join Date
    Apr 2004
    Location
    Oakland CA USA
    Posts
    5037
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Those motors really want about 83 volts supplied to run best at high speeds. That probably has a lot to do with how they're performing. Sellers on places like Aliexpress have a different idea of what a "kit" means than what you might expect. To them, it's a collection of things they can sell together cheaply, not necessarily things that work well together. If you replaced those motors with ones that had lower inductance, even if they had less holding torque, the machine would probably work better. Look for ones rated at about 2.5mH if you want to keep everything else the same.

    Andrew Werby
    https://computersculpture.com/


  5. #5
    Member
    Join Date
    Aug 2016
    Location
    Denmark
    Posts
    24
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Hi again .,

    Thx alot for the reply ,

    I´ve been reading alot about motors , drivers ect.. and found out a couple of things.. first off my drivers are basicly utter crap a friend of mine had some cheap cheap cheap drivers he bought from wish when he started with his little 3d printer, and those performed better then mine.. so i think my drivers are really bad..
    My wires are way to small , awg 26..... so really not ideal for use in a big cnc then hopefully will end up going fast and precise..

    Now to the good parts ,,

    I have gotten 4 drivers from a good homegrown company https://www.jvl.dk/ old ones , but good ones i think.. ( mine are SMD40 ) but JVL says on their site that the manual is the same for the newer smd41..
    i got hold of a psu that can do 80v with 50amps..
    i ordered new wires for the steppers awg 15 as reccomended from jvl.

    But there is always something that has to be hard

    I dont quite understand how im suppose to hook those drivers up... as they are not quite like the usual ones..

    Need help tuning/setup i think ? Semi neewbie with new machine-jvl-smd40-jpg

    https://www.jvl.dk/files/_2011clean/pdf/lb043gb.pdf

    I have step, dir , enable and 5v on my wire from the bob ,,, so where to put what ,, direction is easy ,, step would probably by logic go to step clock... but enable and 5v ????
    standby current , move current have some automatic function as i understand it , but i might be wrong.. im in no way very bright on all this and i have diffeculties learning by reading.. im much more a hands on guy..

    so if you or anyone else that probably have more knowledge about these things then i do might be able to help then it will be higly appriciated




    Quote Originally Posted by awerby View Post
    Those motors really want about 83 volts supplied to run best at high speeds. That probably has a lot to do with how they're performing. Sellers on places like Aliexpress have a different idea of what a "kit" means than what you might expect. To them, it's a collection of things they can sell together cheaply, not necessarily things that work well together. If you replaced those motors with ones that had lower inductance, even if they had less holding torque, the machine would probably work better. Look for ones rated at about 2.5mH if you want to keep everything else the same.


    Attached Thumbnails Attached Thumbnails Need help tuning/setup i think ? Semi neewbie with new machine-jvl-smd40-jpg  


  6. #6
    Member
    Join Date
    Sep 2005
    Location
    United States
    Posts
    1729
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Biggest mistake using a control board and software no one else uses and that equals zero support.

    1000x750 Workbee CNC - Mach4 - PMDX USB - Windows 10 Pro


  7. #7
    Member
    Join Date
    Apr 2007
    Location
    u s a
    Posts
    183
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    it looks like a chopper drive so i would do some digging on that key word to see if you can gain some insight on how they are wired. if the motors are bipolar with 4 wires those look pretty straight forward but the rest is not something i am not familiar with. you should be able to find something on the stepper motors to identify the wires in some kind of diagram manufactures usually provide that information.

    i always thought this sort of drive was dated and old. i have heard the term come up but never payed much attention to it. when i first looked through stuff it almost looked analog to me ? i was guessing the direction was controlled buy an active high or low 5v but that's just a guess. looks like the motors can be controlled by changing the amount of current or voltage based on which way you wire it? and the pulse train would determine the the changing current or voltage based on wiring. from what i picked up at a quick glance. one was easier than the other because one of the methods required pull up resistors i think?

    maybe someone might know that kind of system and be able to help you out?



  8. #8
    Member
    Join Date
    Apr 2007
    Location
    u s a
    Posts
    183
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    one other thing i noticed is i don't see anything for a supply 5V for the logic so my guess is that would be picked up from the computer through the USB taking another guess? sometimes you don't always need the enable pin for things to work. from what i have seen enable is usually for a fault to set and alarm the drive but usually you need something for feedback like an encoder to compare against if i'm not mistaken?

    it might be worth trying just to get the basic stuff working as it should first then come back to the fault signal once the rest is working as it should. i tried to find some better documentation on the USB board you are using but i could not find anything more than what you have already. i did notice the use of a in line fuse and resistor in the power supply circuit so you can use the dump pin 7. I took some screen grabs from the dive documents and took a look at the link for the motors i think you are using with this are bipolar 4 wire motors. those connections are pins 3,4,5,6 on the drive. i think if you just worry about the direction pin 8 step or pulse pin 9 and run a common grounding point back to the host device from pin 10 that might get the basics covered and get you moving in both directions at least. the rest should be in the software settings.

    i think the 5v and enable on the USB board will have a place on the ERROR pin of the drive if you need them but i'm not sure on that one? you might have to come back and look into this more if the drive requires it to work but sometimes they don't. the resistor size on the power supply circuit depends on the size of the supply your using so that's something to keep in mind too.

    i am by no means an expert on this but have no problem offering up a second set of eyes for a little bit to try and help. i'm thinking this drive might be able to be used for a hybrid stepper set up possibly but i never used one of them myself. the enable i have only seen with servo's so that's not to much help here.

    as far as the rest of the drive goes it looks like dip switches set the rest. the documentation on the drives seems pretty decent but the USB board is a different story.

    Need help tuning/setup i think ? Semi neewbie with new machine-long-motor-jpgNeed help tuning/setup i think ? Semi neewbie with new machine-power-supply-pngNeed help tuning/setup i think ? Semi neewbie with new machine-step-direction-jpg



  9. #9
    Member
    Join Date
    Sep 2005
    Location
    United States
    Posts
    1729
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Looks pretty straightforward, after all a bi polar stepper is just 4 wires all you need is an ohm meter to pick out the two winding's and A or B + or - is just change any two wire around until it goes the right direction and stepper drivers are universal (almost). My PMDX 416 board is USB and it gets the 5 volts from the USB port. I had no issues getting it set up, it was like $170 USD That would be my suggestion at this point IF he can not get his setup.

    Krist some of this stuff is trial and error also, but I hope you find the doc/s.

    1000x750 Workbee CNC - Mach4 - PMDX USB - Windows 10 Pro


  10. #10
    Member
    Join Date
    Apr 2007
    Location
    u s a
    Posts
    183
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    the motor winding's are actually color coded if those are the same motors being used.so you don't even need a meter with the posted diagram.



  11. #11
    Member
    Join Date
    Aug 2016
    Location
    Denmark
    Posts
    24
    Downloads
    0
    Uploads
    0

    Default Re: Need help tuning/setup i think ? Semi neewbie with new machine

    Quote Originally Posted by machinedude View Post
    the motor winding's are actually color coded if those are the same motors being used.so you don't even need a meter with the posted diagram.

    Hi guys .,,, Thanks for all your replies .,,

    I have gotten everything to work ,, and for a homemade cnc im VERY pleased ,,, im removing chips like crazy ,, can shave 3mm of oak in one pass with 3600mm/m without any problems ,,, for a perfect finish i can take 0.5mm off aluminium with 1800mm/m so i really cant complain there...


    Love that there are people here that are willing to give time and efford to help others in need

    Again thanks alot..

    Best reagards ,

    Kristjan



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Need help tuning/setup i think ? Semi neewbie with new machine

Need help tuning/setup i think ? Semi neewbie with new machine

Need help tuning/setup i think ? Semi neewbie with new machine